Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Services crashes cos of nicks with "|" in their name, known bug?  (Read 2751 times)

0 Members and 1 Guest are viewing this topic.

FriedCPU

  • Guest

Hi,
For some reason, my anope services crash when somebody with a | in their name trys to use any of the services...

It appears that registering and identifying with nickserv doesn't trigger it, but the following do, that I have noticed so far...

trying to group a nick with nickserv (/msg nickserv group)
reading your last memos with momoserv (/msg memoserv read last)

I have yet to see anymore, I was wondering if this is a known problem, or just a random bug that has seemed to occur with my installation?

Info:
Anope Version: 1.7.18
Compiled: 8th of June
IRCD: Unreal 3.2.6
OS: Debian 4.0
Kernel: 2.6.18-4-686-bigmem

Example:
Quote

*** Global -- from Services.ViSiON-iRC.net: PANIC! buffer = :Fhi| PRIVMSG MemoServ :READ LAST


I am pretty much at a loss here.

Any help would be great.

[Edited on 13-6-2007 by FriedCPU]

[Edited on 13-6-2007 by FriedCPU]
Logged

SNU

  • Anope User
  • Offline Offline
  • Posts: 158
    • http://www.firstclassirc.com
(No subject)
« Reply #1 on: June 13, 2007, 09:24:47 AM »

I cannot confirm. Try updating to anope 1.7.19 maybe its fixed there.

[Bearbeitet am 13-6-2007 von SNU]
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #2 on: June 13, 2007, 01:12:35 PM »

it can also happen becoz of an incorrect third party module loaded. DO you have any third party module loaded which can caused such a thing... try /os modlist third and give us the output
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.

FriedCPU

  • Guest
(No subject)
« Reply #3 on: June 13, 2007, 01:39:24 PM »

Hey,
thanks for your replys.

I recompiled with 1.7.19 and it appears to have worked, I cannot get it to crash again.
I am using the exact same modules, i just copied the .c files from my old src for the custom modules I use, doesn't appear any of them caused it.

If i run accross it again i will reactivate this thread, otherwise, I think its now defunct.

Thanks Again SNU & n00bie.

- FriedCPU
Logged
Pages: [1]   Go Up