Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Anope on same shell as bahamut server  (Read 8459 times)

0 Members and 1 Guest are viewing this topic.

Davey

  • Anope User
  • Offline Offline
  • Posts: 6
Anope on same shell as bahamut server
« on: March 04, 2012, 03:22:43 PM »

Hi all,

I have created a few shells on my server and on one of those shells setup bahamut and am trying to get Anope to connect. I want anope and bahamut running in the same shell and can't seem to get anope to connect. tried using localhost and 127.0.0.1 but no luck. service name is different from the ircd name etc.. What should I use for a IP to get anope to connect with bahamut when both running in the same shell?

I did a little looking around for internal IPs but don't see the usual 192.xxx etc.

From ip address show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:16:3e:ad:26:e0 brd ff:ff:ff:ff:ff:ff
    inet 50.7.193.90/29 brd 50.7.193.95 scope global eth0
    inet 50.7.193.91/29 brd 50.7.193.95 scope global secondary eth0:1
    inet 50.7.193.92/29 brd 50.7.193.95 scope global secondary eth0:2
    inet 50.7.193.93/29 brd 50.7.193.95 scope global secondary eth0:3
    inet 50.7.193.94/29 brd 50.7.193.95 scope global secondary eth0:4
    inet6 fe80::216:3eff:fead:26e0/64 scope link
       valid_lft forever preferred_lft forever

From ifconfig

eth0      Link encap:Ethernet  HWaddr 00:16:3e:ad:26:e0
          inet addr:50.7.193.90  Bcast:50.7.193.95  Mask:255.255.255.248
          inet6 addr: fe80::216:3eff:fead:26e0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:188412 errors:0 dropped:0 overruns:0 frame:0
          TX packets:19626 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:11617840 (11.0 MiB)  TX bytes:1136398 (1.0 MiB)
          Interrupt:15

eth0:1    Link encap:Ethernet  HWaddr 00:16:3e:ad:26:e0
          inet addr:50.7.193.91  Bcast:50.7.193.95  Mask:255.255.255.248
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:15

eth0:2    Link encap:Ethernet  HWaddr 00:16:3e:ad:26:e0
          inet addr:50.7.193.92  Bcast:50.7.193.95  Mask:255.255.255.248
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:15

eth0:3    Link encap:Ethernet  HWaddr 00:16:3e:ad:26:e0
          inet addr:50.7.193.93  Bcast:50.7.193.95  Mask:255.255.255.248
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:15

eth0:4    Link encap:Ethernet  HWaddr 00:16:3e:ad:26:e0
          inet addr:50.7.193.94  Bcast:50.7.193.95  Mask:255.255.255.248
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:15

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

root@localhost:~# ip
Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }
       ip [ -force ] -batch filename
where  OBJECT := { link | addr | addrlabel | route | rule | neigh | ntable |
                   tunnel | tuntap | maddr | mroute | monitor | xfrm }
       OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |
                    -f[amily] { inet | inet6 | ipx | dnet | link } |
                    -o[neline] | -t[imestamp] | -b[atch] [filename] |
                    -rc[vbuf] [size]}
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Anope on same shell as bahamut server
« Reply #1 on: March 04, 2012, 03:24:37 PM »

You can use 127.0.0.1, 50.7.193.90-94.

127.0.0.1 would be preferred.
Logged

Davey

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Anope on same shell as bahamut server
« Reply #2 on: March 04, 2012, 03:58:29 PM »

Hi Charles,

Thanks for the info. Now lets say I want to run 4 different shells each running their own ircd and anope service. I won't get a bind error if they are all using 127.0.01?
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Anope on same shell as bahamut server
« Reply #3 on: March 04, 2012, 04:01:42 PM »

Hi there,

Only if you clash on ports.

i.e. I'd do the following....

IRCD1 - 50.7.193.90 (using normal irc ports 6660-6669 etc, etc) & 127.0.0.1 10001 (for anope)
SERVICES1 - 127.0.0.1 to connect to 127.0.0.1 10001

IRCD2 - 50.7.193.91 (using normal irc ports 6660-6669 etc, etc) & 127.0.0.1 10002 (for anope)
SERVICES2 - 127.0.0.1 to connect to 127.0.0.1 10003

IRCD3 - 50.7.193.92 (using normal irc ports 6660-6669 etc, etc) & 127.0.0.1 10003 (for anope)
SERVICES3 - 127.0.0.1 to connect to 127.0.0.1 10003

IRCD4 - 50.7.193.94 (using normal irc ports 6660-6669 etc, etc) & 127.0.0.1 10004 (for anope)
SERVICES4 - 127.0.0.1 to connect to 127.0.0.1 10004

Anope doesn't "need" to bind to a port as such, it will connect out to your ircd listening on loopback(127.0.0.1) on a unique port to the box itself.

It's also possible you could use the 50.7.193.x IPs for anope but I don't see the point.

HTH.
Logged

Davey

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Anope on same shell as bahamut server
« Reply #4 on: March 04, 2012, 04:04:12 PM »

Great i will give that a go thanks!
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Anope on same shell as bahamut server
« Reply #5 on: March 04, 2012, 05:07:47 PM »

You might also want to use a version of bahamut that is more friendly to Anope.

I have a modified version at http://ircmojo.org/katsklaw/files/bahamut-1.8.9-svsfix.tar.gz that fixes the services aliases to work with Anope and other packages. Bahamut has hard coded aliases and on DALnet OperServ is on their stats server, not services server.

Note: There is no support for this version. The only thing altered is where the aliases point to, nothing more. All other issues you may encounter are bahamut or configuration or lack there of related.

UPDATE: It seems the good folks at DALnet released 2.0 without me noticing, so I fixed 2.0.3 too http://ircmojo.org/katsklaw/files/bahamut-2.0.3-svsfix.tar.gz :)
« Last Edit: March 04, 2012, 05:19:11 PM by katsklaw »
Logged

Davey

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Anope on same shell as bahamut server
« Reply #6 on: March 04, 2012, 09:05:45 PM »

Thanks katsklaw :) Will give this a try. I just finished installing bahamut and anope and tried to start Anope and in anopes logs it says error4 module not found. Not sure what thats about but will keep playing.

Hrmm still getting it and not sure why. Exact error is:

Quote
[Mar 04 21:41:40 2012] Every UserKey must be different. It's for YOUR safety! Remember that!
[Mar 04 21:41:40 2012] Loading IRCD Protocol Module: [Bahamut]
[Mar 04 21:41:40 2012] status: [4][Module Error, File does not exist]
« Last Edit: March 04, 2012, 09:42:47 PM by Davey »
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Anope on same shell as bahamut server
« Reply #7 on: March 04, 2012, 10:13:29 PM »

try all lowercase bahamut not Bahamut
Logged

Davey

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Anope on same shell as bahamut server
« Reply #8 on: March 04, 2012, 10:42:23 PM »

Love it when I miss stuff like that hehe. Thanks katsklaw that fixed that problem. Now I am getting another though.

Quote
[Mar 04 22:38:52 2012] Loading IRCD Protocol Module: [bahamut]
[Mar 04 22:38:52 2012] status:
  • [Module, Okay - No Error]
[Mar 04 22:38:52 2012] Loading Encryption Module: [enc_md5]
[Mar 04 22:38:52 2012] status:
  • [Module, Okay - No Error]
[Mar 04 22:38:52 2012] Anope 1.8.7 (3089) (ircd protocol: BahamutIRCd 1.4.*/1.8.*) starting up
[Mar 04 22:38:53 2012] MSMemoReceipt not enabled in services.conf
[Mar 04 22:38:53 2012] ms_rsend requested unload...
[Mar 04 22:38:53 2012] debug: trying to load core module [ms_rsend]
[Mar 04 22:38:53 2012] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Mar 04 22:38:53 2012] os_oline requested unload...
[Mar 04 22:38:53 2012] debug: trying to load core module [os_oline]
[Mar 04 22:38:53 2012] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Mar 04 22:38:53 2012] Databases loaded
[Mar 04 22:38:53 2012] Info: Reflecting database records.
[Mar 04 22:38:53 2012] Connected to Server 1 (127.0.0.1:10001)
[Mar 04 22:38:53 2012] trying to load [cs_appendtopic]
[Mar 04 22:38:53 2012] [cs_appendtopic] Loaded successfully
[Mar 04 22:38:53 2012] status:
  • [Module, Okay - No Error]
[Mar 04 22:38:53 2012] trying to load [cs_enforce]
[Mar 04 22:38:53 2012] status:
  • [Module, Okay - No Error]
[Mar 04 22:38:53 2012] trying to load [ns_maxemail]
[Mar 04 22:38:53 2012] status:
  • [Module, Okay - No Error]
[Mar 04 22:38:53 2012] trying to load [os_info]
[Mar 04 22:38:53 2012] os_info: Loading configuration directives...
[Mar 04 22:38:53 2012] os_info: OSInfoDBName is not defined in Services configuration file, using default os_info.db
[Mar 04 22:38:53 2012] os_info: Directive OSInfoDBName loaded (os_info.db)...
[Mar 04 22:38:53 2012] os_info: WARNING: can not open the database file! (it might not exist, this is not fatal)
[Mar 04 22:38:53 2012] status:
  • [Module, Okay - No Error]
[Mar 04 22:38:53 2012] trying to load [hs_request]
[Mar 04 22:38:53 2012] [hs_request] Unable to open database ('hs_request.db') for reading
[Mar 04 22:38:53 2012] hs_request loaded
[Mar 04 22:38:53 2012] status:
  • [Module, Okay - No Error]
[Mar 04 22:38:53 2012] Read error from server: Broken pipe (error num: 32)
[Mar 04 22:38:53 2012] [cs_appendtopic] Unloaded successfully
[Mar 04 22:38:53 2012] hs_request un-loaded

Services don't show up on the server. Guessing the broken pipe error is the cause? I was logged in as oper on the server when I started Anope as well to see if it said anything and there was no sign at all that Anope had tried to connect.

By the way is there a official Anope IRC channel?
« Last Edit: March 04, 2012, 10:50:28 PM by Davey »
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
Re: Anope on same shell as bahamut server
« Reply #9 on: March 05, 2012, 08:28:17 AM »

check anopes logs.. to get a more detailed error you can run anope in debug with ./services -support

and there s an #anope channel on irc.anope.org
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

Davey

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Anope on same shell as bahamut server
« Reply #10 on: March 05, 2012, 11:16:57 AM »

Hi Jan,

Thanks for the info and the channel :) The errors I posted on my last post were from the anope logs. I tried with services -support and get a whole bunch of

Quote
[Mar 05 11:10:28.869242 2012] debug: Emitting event "delcommand" (2 args)

There is some stuff that is different before that but it is gone to fast to read and it doesn't show up in anopes logs or syslogs. All I was able to see is this:

Quote
[Mar 05 11:10:28.610060 2012] debug: Sent: SQUIT services.ircdoffshore.com :Read                  error from server: Broken pipe (error num: 32)
[Mar 05 11:10:28.610081 2012] debug: firstuser() returning NULL (end of list)

Forgot to edit this: The guys on IRC helped me  fix this up. Turned out I had a ssl flag set on my port for 127.0.0.1
« Last Edit: March 06, 2012, 02:19:02 PM by Davey »
Logged
Pages: [1]   Go Up