Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: An odd situation (Or so I think)  (Read 4391 times)

0 Members and 1 Guest are viewing this topic.

Kitsune

  • Guest
An odd situation (Or so I think)
« on: February 16, 2007, 09:16:17 PM »

Alright, I'm running anope and unrealIRCd, both are run on the same computer. The web address for it consists of a subdomain linked to a webhop linked to a dynamic DNS account.

As such I don't have domain names to work with, or at least not easily. Before I take another go at it (I've gone through numerous IRC daemons and services) I wanted to ask advice.

Do I need to create more dyndns and webhop accounts, then another subdomain for services specifically, or can I use intranet IP addresses and 127.0.0.1 (I'm running windows, btw)

So far I've had no luck, when it did connect I got the message that services were online, but then when I tried to register a nickname, I got no response in the console or in the channel I was in.

I've read this tutorial: http://forum.anope.org/viewthread.php?tid=1267
but it made things worse, as now services won't connect at all.

I just tried connecting through the subdomain that is webhopped, but it won't work, so, oh well. I'll just stick with dyndns.

Any help would be appreciated, tell me what I need to copy/paste up.

Thank you all very much!
Logged

katsklaw

  • Guest
(No subject)
« Reply #1 on: February 16, 2007, 11:57:30 PM »

You didn't follow the tutorial correctly then, there is nothing wrong with my tutorial. You can use 127.0.0.1 for both of the ips of the ircd and for services, so the IP for #3 and #4 can be the same and in many cases it is the same. I used 2 different IP's to prevent confusion.

I'm so confident that you have a configuration setting wrong, that conflicts with my tutorial that I'm almost tempted to wager a free shell account on it. What I suggest is to go through the tutorial again, this time write down on paper all 7 items *before* you start editing your config files.

DNS has nothing to do with setting up and configuring services and it's uplink IRCd, in fact it's best that there is no DNS entries for Services and idealisticly services has it's own ircd that doesn't resolve either. I understand that the later isn't always possible.

As a sidenote since it's only slightly relevent to IRC, it's not recommended to use any dynamic IP to start with. You should invest a few bucks and get REAL hosting. It's very possible to run an ircd + plus services + website + DNS for a very resonable price. With the thousands of shell providers, VPS's, cheap dedi hosts out there that are willing to cut each others throat, I'm sure you can get hosting rather cheap. Think of it this way, you should invest money in your network if you are truely serious about it's success .. nothing is truely free, if you are just "playing" you don't need DNS.
Logged

Kitsune

  • Guest
(No subject)
« Reply #2 on: February 17, 2007, 02:40:39 AM »

I'm giving up until tomorrow, I've been at this all day using tutorial after tutorial.

This would be so much easier if I wasn't doing this on a 15 inch monitor, ha ha.

Anyway, I'm going to start completely over at the same time with both of them and follow a tutorial to the dot. I have sort of a stupid question though..

When you say services.mynet.org do you mean that I can use pretty much anything in that field as long as the other field is the same, or do I need to have a valid name for it?
Logged

katsklaw

  • Guest
(No subject)
« Reply #3 on: February 17, 2007, 03:21:27 AM »

yes, your services name doesn't need to exist as a real name, in fact it's best that it doesn't. Just make something up, you can even name it 'yo' .. the important thing is it matches everywhere.
Logged

Kitsune

  • Guest
(No subject)
« Reply #4 on: February 17, 2007, 11:16:16 PM »

Alright, I'm missing something completely obvious or I would have found it by now. I'll post up the related blocks..

Code: [Select]

unrealircd.conf:

listen         192.168.0.133:26025

link            yo
{
username *;
hostname 127.0.0.1;
bind-ip *;
port 26025;
hub             *;
password-connect "hidden";
password-receive "hidden";
class           servers;

ulines {
yo;
include "aliases/anope.conf";

services-server "yo";

services.conf:

IRCDModule "unreal32"

RemoteServer    192.168.0.133 26025 "hidden"

ServerName  "yo"


Anything glaringly obvious?
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #5 on: February 17, 2007, 11:40:06 PM »

Yeah, must have a . in the server name in all places :P
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Kitsune

  • Guest
(No subject)
« Reply #6 on: February 18, 2007, 12:02:35 AM »

So just adding a . after yo? or do I need to do something else? That's what I just did and it didn't help anything, have also tried yo.yo to no avail.

(My current error is a "No such file or directory" read error)
Logged

hc2995

  • Guest
(No subject)
« Reply #7 on: February 18, 2007, 12:20:45 AM »

Kitsune, heres how mine looks, services have always connected for me:

Code: [Select]

link            services.igahome.org  <-(this dosent exist as a real domain)
{
username *;
hostname *;
bind-ip *;
port 6667;
hub             *;
password-connect "RANDOM PASSWORD";
password-receive "RANDOM PASSWORD";
class           servers;
options {
/* Note: You should not use autoconnect when linking services */
};
};

and in anope this is what it looks like:

Code: [Select]

ServerName  "services.igahome.org"

ServerDesc  "IGAHome IRC Services"

ServiceUser "services@igahome.org"


None of the above are real domains or e-mail addresses, but they dont have to be
Logged

katsklaw

  • Guest
(No subject)
« Reply #8 on: February 18, 2007, 12:36:25 AM »

since you are connecting to 192.168.0.133, the ircd will see that you are also conecting from 192.168.0.133 and not 127.0.0.1 so either use 127.0.0.1 everywhere or 192.168.0.133  everywhere.

as a side note, if a dot is truely required in the server name, we should bail during startup with such an error.
Logged

Kitsune

  • Guest
(No subject)
« Reply #9 on: February 18, 2007, 01:47:37 AM »

Still a no go, is there any specific place I need to put the include "aliases/anope.conf"; ?

Also, as a last resort, is anyone willing to type up the blocks I need so I can just drop them in, so I know something isn't wrong somewhere else?

It looks like it's connecting to the server, but then not finding a file..I'm going to be installing unrealIRCd again and dropping my current config file in. Hopefully that works.
Logged

katsklaw

  • Guest
(No subject)
« Reply #10 on: February 18, 2007, 02:50:47 AM »

the "file" it's refering to is the open socket that is created by the ircd listening on an IP and port. sockets are files .. thus no such file or directory means that your link block does not match the info you used in the RemoteServer directive.

the tutorial has an example configuration, all you need to do is exchange the example info for your info .. meaning change the names and IPs.
Logged

Kitsune

  • Guest
(No subject)
« Reply #11 on: February 18, 2007, 03:22:05 AM »

I found the problem. It took me this long to catch it. Anyone want to take a wild guess as to what was missing at the end of the unrealircD listen address?

I'm so happy I could repeatedly smack myself with a heavy blunt object.

Thank you all for your help. I really appreciate it.
Logged
Pages: [1]   Go Up