Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: 1.7.17 - autoop  (Read 4709 times)

0 Members and 1 Guest are viewing this topic.

mEh

  • Guest
1.7.17 - autoop
« on: November 24, 2006, 11:10:58 AM »

Hey,

there seems to be a bug with...

/ns set autoop on
/ns set autoop off
/ns saset <Nickname> autoop on
/ns saset <Nickname> autoop off

Everytime i set one of this options i received one of the following messages...

-NickServ- Services will now autoop you in channels.
-NickServ- Services will now autoop <Nickname> in channels.

but autoop still won't work. Even the setting is not written to the database and...

/ns info <Nickname> all

didn't contain any autoop option.

But if i define...

NSDefAutoop

in the services.conf file everything works great?!

:/
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #1 on: November 24, 2006, 11:27:13 AM »

Quote
Originally posted by mEh
but autoop still won't work. Even the setting is not written to the database and...

/ns info <Nickname> all

didn't contain any autoop option.


Firstly the settings dont get written to the database live, secondly there is a bug where AutoOp even if set isn't displayed in /ns info.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

mEh

  • Guest
(No subject)
« Reply #2 on: November 24, 2006, 12:13:35 PM »

hi,

i know the database isn't live ...

it seems anope just sets the flag wrong. if i set autoop to on in irc, the NI_AUTOOP flag isn't set in db. But by turning off autoop anope set the NI_AUTOOP flag in db.

does it suppose to be? ...
Logged

katsklaw

  • Guest
(No subject)
« Reply #3 on: November 24, 2006, 03:04:41 PM »

What jobe means by it's not live is that Services writes it data to cache first, once UpdateTimeout is reached THEN it writes to the db files and optionally to mysql. So if you are checking NI_AUTOOP before UpdaeTimeout, then you will not see the flag changes.

Secondly, you need to enable NSModeOnID on the services.conf for autoop to work properly.

So in short, add NSModeOnID to your services.conf file, do an /os reload and all should be well. :)
Logged

Dave Robson

  • Team
  • *
  • Offline Offline
  • Posts: 357
(No subject)
« Reply #4 on: November 24, 2006, 06:17:00 PM »

Quote
Originally posted by mEh
hi,

i know the database isn't live ...

it seems anope just sets the flag wrong. if i set autoop to on in irc, the NI_AUTOOP flag isn't set in db. But by turning off autoop anope set the NI_AUTOOP flag in db.

does it suppose to be? ...


That's intentional - as it is a new flag, and we want existing nick names to have autoop on, the lack of the flag implies normal existing bahaviour.  When someone sets autoop off (the new behaviour) we set the flag.  so in short, yes it appears the wrong way around :)
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #5 on: November 25, 2006, 12:18:48 PM »

So in theory it would have been better naming the flag NI_AUTOOPOFF so its obvious that its presence means autoop is off not on as has been assumed.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/
Pages: [1]   Go Up