Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Webcpanel Connection via HTTPS dont work  (Read 1840 times)

0 Members and 1 Guest are viewing this topic.

Rene

  • Anope User
  • Offline Offline
  • Posts: 2
Webcpanel Connection via HTTPS dont work
« on: February 23, 2019, 12:24:16 PM »

hello anybody :) i have setup anope 2.0.6 and activate the webcpanel for it. now my problem is the connection from the url for default is http://url:8080 but i will connect with https://url:8080 i activate the m_ssl_openssl module in the modules.example.conf .. whats wrong?

how can i connect via https://url:8080 to the webcpanel ?
For a better understanding ...
I installed Plesk on my server and encrypted my domain using SSL Encrypt for SSL / TSL. Now I would like the data entered in the webcpanel are also encrypted this happens so if you use HTTPS ..
I hope you understand me I'm from Germany
I have encrypted the domain with Lets Encrypt so that all data entered in forms are encrypted.
But if I call  [HTTPS://domain:8080] an error comes
When I call the panel via HTTP it works but the data is not encrypted. if I go with firefox in the formularfeld he warns me that the connection is not encrypted entered data can get into wrong hands. I thought if I activate the SSL module in the modules.example.conf that I can then connect via HTTPS this is unfortunately not the case.

Please Help!
Here are 2 Pictures sorry i'm from germany

« Last Edit: February 23, 2019, 12:50:19 PM by Rene »
Logged

Rene

  • Anope User
  • Offline Offline
  • Posts: 2
Re: Webcpanel Connection via HTTPS dont work
« Reply #1 on: February 26, 2019, 09:46:29 PM »

Please HELP
Logged

Mohd Fhazal Aznan

  • Anope User
  • Offline Offline
  • Posts: 4
    • Bajubesi IRC Network
Re: Webcpanel Connection via HTTPS dont work
« Reply #2 on: April 03, 2022, 12:01:34 AM »

i also need help about this, i have certbot install for the domain, the cert is in letsencrypt folder, how i make it work with anope webcpanel
Logged

c-cris

  • Anope User
  • Offline Offline
  • Posts: 12
Re: Webcpanel Connection via HTTPS dont work
« Reply #3 on: April 03, 2022, 09:31:42 AM »

Hello,
This is what I did at home:

nano /etc/apache2/sites-available/webpanel.yourdomain.com.conf

Code: [Select]
<VirtualHost *:80>
ProxyPreserveHost On
ProxyRequests Off
ServerName webpanel.yourdomain.com
ServerAlias webpanel.yourdomain.com
ProxyPass / http://localhost:8080/
ProxyPassReverse / http://localhost:8080/
RewriteEngine on
RewriteCond %{SERVER_NAME} =webpanel.yourdomain.com
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>

sudo a2ensite webpanel.yourdomain.com
sudo systemctl reload apache2

sudo a2enmod ssl ( if not done )
sudo systemctl reload apache2

sudo certbot --apache ( Choose 2 for automatic redirection in https )

sudo systemctl reload apache2


Sorry for my English, I use the translator :p


Logged

Mohd Fhazal Aznan

  • Anope User
  • Offline Offline
  • Posts: 4
    • Bajubesi IRC Network
Re: Webcpanel Connection via HTTPS dont work
« Reply #4 on: April 03, 2022, 06:33:03 PM »

Code: [Select]
Apr 04 01:26:46 vps apachectl[294810]: The Apache error log may have more information.
Apr 04 01:26:46 vps systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
Apr 04 01:26:46 vps systemd[1]: Reload failed for The Apache HTTP Server.
Apr 04 01:26:53 vps systemd[1]: Reloading The Apache HTTP Server.
Apr 04 01:26:53 vps apachectl[294820]: AH00526: Syntax error on line 2 of /etc/apache2/sites-enabled/irc.mydomain.com.my.conf:
Apr 04 01:26:53 vps apachectl[294820]: Invalid command 'ProxyPreserveHost', perhaps misspelled or defined by a module not included in the server configuration
Apr 04 01:26:53 vps apachectl[294817]: Action 'graceful' failed.
Apr 04 01:26:53 vps apachectl[294817]: The Apache error log may have more information.
Apr 04 01:26:53 vps systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
Apr 04 01:26:53 vps systemd[1]: Reload failed for The Apache HTTP Server.

this happpen what i try to do like what u said, i have apache2 install in my box.

i already have configured virtual host on that domain, how do i modify it from the default code ?

i modify the default code and add yoiur reverse proxy code also enable the proxy module for apache2, seems like the https is still red, do u do anything on anope module config side??

« Last Edit: April 03, 2022, 07:44:29 PM by Fhazal »
Logged

Mohd Fhazal Aznan

  • Anope User
  • Offline Offline
  • Posts: 4
    • Bajubesi IRC Network
Re: Webcpanel Connection via HTTPS dont work
« Reply #5 on: April 05, 2022, 08:22:23 PM »

PeGaSuS teach me how to solve this and it's work

first in your ssh enable the apache mod :

a2enmod dir userdir rewrite headers session session_cookie proxy proxy_html proxy_http proxy_wstunnel lbmethod_bytraffic

sudo systemctl reload apache2

NOTE : if you don't have any other mod that is required by apache when you restart your apache just type in your ssh a2enmod (module name)

example :

Code: [Select]
Apr 04 01:26:53 vps apachectl[294820]: AH00526: Syntax error on line 2 of /etc/apache2/sites-enabled/irc.mydomain.com.my.conf:
Apr 04 01:26:53 vps apachectl[294820]: Invalid command 'ProxyPreserveHost', perhaps misspelled or defined by a module not included in the server configuration

a2enmod ProxyPreserveHost

now edit all the files accordingly as below :
 
Code: [Select]
###
# On your.domain.org.conf
###
<VirtualHost *:80>
    ServerAdmin webmaster@your.domain.com
    ServerName your.domain.com
    ServerAlias www.your.domain.com
    DocumentRoot /var/www/your.domain.com
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
RewriteEngine on
RewriteCond %{SERVER_NAME} =your.domain.com [OR]
RewriteCond %{SERVER_NAME} =www.your.domain.com
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>
 
 
###
# On your.domain.com-le-ssl.conf
###
<IfModule mod_ssl.c>
<VirtualHost *:443>
    ServerAdmin webmaster@localhost
    ServerName your.domain.com
    ServerAlias www.your.domain.com
    DocumentRoot /var/www/your.domain.com
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
 
Include /etc/letsencrypt/options-ssl-apache.conf
SSLCertificateFile /etc/letsencrypt/live/your.domain.com-0001/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/your.domain.com-0001/privkey.pem
RewriteEngine On
ProxyVia On
ProxyAddHeaders On
RemoteIPHeader X-Forwarded-For
RequestHeader set X-Forwarded-For "expr=%{REMOTE_ADDR}e"
ProxyPass / http://127.0.0.1:8070/
ProxyPassReverse / http://127.0.0.1:8070/
</VirtualHost>
</IfModule>
 
 
###
# On Anope modules.conf
###
module
{
        name = "m_httpd"
 
        httpd
        {
                /* Name of this service. */
                name = "httpd/main"
 
                /* IP to listen on. */
                ip = "127.0.0.1"
 
                /* Port to listen on. */
                port = 8070
 
                /* Time before connections to this server are timed out. */
                timeout = 30
 
                /* Listen using SSL. Requires an SSL module. */
                ssl = no
 
                /* If you are using a reverse proxy that sends one of the
                 * extforward_headers set below, set this to its IP.
                 * This allows services to obtain the real IP of users by
                 * reading the forwarded-for HTTP header.
                 * Multiple IP addresses can be specified separated by a space character.
                 */
                #extforward_ip = "127.0.0.1"
 
                /* The header to look for. These probably work as is. */
                extforward_header = "X-Forwarded-For Forwarded-For"
        }
}

thanks @PeGaSuS  ;D he even teach me how to modify the webcpanel interface.
« Last Edit: April 06, 2022, 08:13:48 AM by Mohd Fhazal Aznan »
Logged
Pages: [1]   Go Up