Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Failing to get superadmin  (Read 404 times)

0 Members and 1 Guest are viewing this topic.

WorldAxis

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 3
    • +World Services.
Failing to get superadmin
« on: October 25, 2022, 09:46:51 PM »

Hello all.  :)

I've bin out of this for almost 10 years. Lately I started a new website again and next to that an irc server.
I got it all working ,but I keep failing to config or login as a Superadmin.

I got the Anope 2.0.11... running on the latest UnrealIRCD 6...

It seems that I have to set my nick as a root.

I get the access denied on all what I try to get de superadmin.
It even says in some cases that there is no Operblock for my nick.

I did set the Operblock for my name in Unreal before connecting Anope.
My nick is registered and logged in as a Netadmin-With-Overide while I'm trying to get the Superadmin to work.

I feel kinda stupid for not getting it done.

Can somebody help me out with it?

Thank you in advance  :)

« Last Edit: October 25, 2022, 10:36:17 PM by WorldAxis »
Logged

Rene

  • Anope User
  • Offline Offline
  • Posts: 2
Re: Failing to get superadmin
« Reply #1 on: October 26, 2022, 01:21:03 AM »

Hello and Nice to meet you?
Are You sure that you configure your Ircd and Services correctly you must enable this option in the operserv.example.conf of anope...

Here are Examle of configs that you must setup:
After it do a restart of all and try again.

Unrealircd.conf section OperBlock:

Code: [Select]
oper Youroper {
class opers;
mask *@*;
password "yourpass";
/* Oper permissions are defined in an 'operclass' block.
* See https://www.unrealircd.org/docs/Operclass_block
* UnrealIRCd ships with a number of default blocks, see
* the article for a full list. We choose 'netadmin' here.
*/
operclass netadmin-with-override;
swhois "is a Network Admin";
vhost netadmin.example.org;
snomask bBcdfkqsSoO;
}

Services.conf of anope section Oper:

Code: [Select]

oper
{
/* The nickname of this services oper */
name = "Yournick"

/* The opertype this person will have */
type = "Services Root"

/* If set, the user must be an oper on the IRCd to gain their Services
* oper privileges.
*/
require_oper = yes

/* An optional password. If defined, the user must login using "/OPERSERV LOGIN" first */
password = "yourpass"

/* An optional SSL fingerprint. If defined, it's required to be able to use this opertype. */
#certfp = "ed3383b3f7d74e89433ddaa4a6e5b2d7"

/* An optional list of user@host masks. If defined the user must be connected from one of them */
#host = "*@*.anope.org ident@*"

/* An optional vHost to set on users who identify for this oper block.
* This will override HostServ vHosts, and may not be available on all IRCds
*/
#vhost = "oper.mynet"
}


And the Superadmin option in operserv.example.conf of Anope.

Code: [Select]

/*
 * os_set
 *
 * Provides the command operserv/set.
 *
 * Used to set various settings such as superadmin, debug mode, etc.
 */
module
{
name = "os_set"

/*
* If set, Services Admins will be able to use SUPERADMIN [ON|OFF] which will temporarily grant
* them extra privileges such as being a founder on ALL channels.
*
* This directive is optional.
*/
superadmin = yes
}
command { service = "OperServ"; name = "SET"; command = "operserv/set"; permission = "operserv/set"; }


if done do a restart it should be work. hopefully, :)
Logged

WorldAxis

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 3
    • +World Services.
Re: Failing to get superadmin
« Reply #2 on: October 27, 2022, 10:38:52 AM »

Hi Rene,

I forgot to configure the Services.conf part indeed.
I thought that I was getting to old for this  ;D
It's working like it should be now.

Thank you very much for helping me out.

Greets WorldAxis.
Logged
Pages: [1]   Go Up