Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Anope socket error! [ SOLVED ]  (Read 4900 times)

0 Members and 1 Guest are viewing this topic.

srg

  • Anope User
  • Offline Offline
  • Posts: 2
Anope socket error! [ SOLVED ]
« on: March 08, 2011, 08:27:23 PM »

Hi, I'm trying to run Anope on Windows 7.
It gives me following errors in logfile (debug):

Code: [Select]
[Mar 08 22:50:44 2011] Loading IRCD Protocol Module: [unreal32]
[Mar 08 22:50:44 2011] trying to load [unreal32]
[Mar 08 22:50:44 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/unreal32.so.a05508
[Mar 08 22:50:44 2011] Module unreal32 compiled against current version of Anope 1
[Mar 08 22:50:44 2011] SERVER: ircd.local (services) uplinked to no uplink connected to the network
[Mar 08 22:50:44 2011] trying to load [enc_none]
[Mar 08 22:50:44 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/enc_none.so.a05508
[Mar 08 22:50:44 2011] Module enc_none compiled against current version of Anope 1
[Mar 08 22:50:44 2011] trying to load [db_mysql]
[Mar 08 22:50:44 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/db_mysql.so.a05508
[Mar 08 22:50:44 2011] Module db_mysql compiled against current version of Anope 1
[Mar 08 22:50:44 2011] trying to load [m_socketengine_epoll]
[Mar 08 22:50:44 2011] Unable to load socket engine m_socketengine_epoll
[Mar 08 22:51:04 2011] Loading IRCD Protocol Module: [unreal32]
[Mar 08 22:51:04 2011] trying to load [unreal32]
[Mar 08 22:51:04 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/unreal32.so.a05304
[Mar 08 22:51:04 2011] Module unreal32 compiled against current version of Anope 1
[Mar 08 22:51:04 2011] SERVER: ircd.local (services) uplinked to no uplink connected to the network
[Mar 08 22:51:04 2011] trying to load [enc_none]
[Mar 08 22:51:04 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/enc_none.so.a05304
[Mar 08 22:51:04 2011] Module enc_none compiled against current version of Anope 1
[Mar 08 22:51:04 2011] trying to load [db_mysql]
[Mar 08 22:51:04 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/db_mysql.so.a05304
[Mar 08 22:51:04 2011] Module db_mysql compiled against current version of Anope 1
[Mar 08 22:51:04 2011] trying to load [m_socketengine_select]
[Mar 08 22:51:04 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/m_socketengine_select.so.a05304
[Mar 08 22:51:04 2011] Module m_socketengine_select compiled against current version of Anope 1
[Mar 08 22:51:04 2011] PID 4692
[Mar 08 22:51:04 2011] Launching Anope into the background
[Mar 08 22:51:04 2011] Anope 1.9.3 (1) (ircd protocol: UnrealIRCd 3.2.x) starting up (options: debug)
[Mar 08 22:51:04 2011] Loading Languages...
[Mar 08 22:51:04 2011] Found language file en_EN
[Mar 08 22:51:04 2011] Successfully bound anope to E:\test\ircd\Anope\data/languages/
[Mar 08 22:51:04 2011] trying to load [ns_help]
[Mar 08 22:51:04 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/ns_help.so.a05304
[Mar 08 22:51:04 2011] Module ns_help compiled against current version of Anope 1
[Mar 08 22:51:04 2011] trying to load [ns_register]
[Mar 08 22:51:04 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/ns_register.so.a05304
[Mar 08 22:51:04 2011] Module ns_register compiled against current version of Anope 1
[Mar 08 22:51:04 2011] trying to load [ns_group]
[Mar 08 22:51:04 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/ns_group.so.a05304
[Mar 08 22:51:04 2011] Module ns_group compiled against current version of Anope 1
[Mar 08 22:51:04 2011] trying to load [ns_identify]
[Mar 08 22:51:04 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/ns_identify.so.a05304
[Mar 08 22:51:04 2011] Module ns_identify compiled against current version of Anope 1
[Mar 08 22:51:04 2011] trying to load [ns_access]
[Mar 08 22:51:04 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/ns_access.so.a05304
[Mar 08 22:51:04 2011] Module ns_access compiled against current version of Anope 1
[Mar 08 22:51:04 2011] trying to load [ns_set]
[Mar 08 22:51:04 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/ns_set.so.a05304
[Mar 08 22:51:04 2011] Module ns_set compiled against current version of Anope 1
[Mar 08 22:51:04 2011] trying to load [ns_saset]
[Mar 08 22:51:04 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/ns_saset.so.a05304
[Mar 08 22:51:04 2011] Module ns_saset compiled against current version of Anope 1
[Mar 08 22:51:04 2011] trying to load [ns_set_autoop]
[Mar 08 22:51:04 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/ns_set_autoop.so.a05304
[Mar 08 22:51:04 2011] Module ns_set_autoop compiled against current version of Anope 1
[Mar 08 22:51:04 2011] trying to load [ns_set_email]
[Mar 08 22:51:04 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/ns_set_email.so.a05304
[Mar 08 22:51:04 2011] Module ns_set_email compiled against current version of Anope 1
[Mar 08 22:51:04 2011] trying to load [ns_set_greet]
[Mar 08 22:51:04 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/ns_set_greet.so.a05304
[Mar 08 22:51:04 2011] Module ns_set_greet compiled against current version of Anope 1
                                         ......................................
[Mar 08 22:51:04 2011] trying to load [ns_set_hide]
[Mar 08 22:51:05 2011] trying to load [hs_moo]
[Mar 08 22:51:05 2011] trying to load [ircd_defizzer]
[Mar 08 22:51:05 2011] trying to load [cs_appendtopic]
[Mar 08 22:51:05 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/cs_appendtopic.so.a05304
[Mar 08 22:51:05 2011] Module cs_appendtopic compiled against current version of Anope 1
[Mar 08 22:51:05 2011] trying to load [cs_enforce]
[Mar 08 22:51:05 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/cs_enforce.so.a05304
[Mar 08 22:51:05 2011] Module cs_enforce compiled against current version of Anope 1
[Mar 08 22:51:05 2011] trying to load [ns_maxemail]
[Mar 08 22:51:05 2011] Runtime module location: E:\test\ircd\Anope\data/modules/runtime/ns_maxemail.so.a05304
[Mar 08 22:51:05 2011] [ns_maxemail] NSEmailMax set to 0
[Mar 08 22:51:05 2011] Module ns_maxemail compiled against current version of Anope 1
[Mar 08 22:51:06 2011] Unable to accept connection: A non-blocking socket operation could not be completed immediately.

 and normal
Code: [Select]
[Mar 08 23:18:59 2011] Loading IRCD Protocol Module: [unreal32]
[Mar 08 23:18:59 2011] SERVER: ircd.local (services) uplinked to no uplink connected to the network
[Mar 08 23:18:59 2011] PID 1532
[Mar 08 23:18:59 2011] Launching Anope into the background
[Mar 08 23:18:59 2011] Anope 1.9.3 (1) (ircd protocol: UnrealIRCd 3.2.x) starting up
[Mar 08 23:19:01 2011] Unable to accept connection: Unable to accept connection: A non-blocking socket operation could not be completed immediately.

This is my linkblock:
Code: [Select]
listen         *:5001
{
    options
{
serversonly;
};
};

...

link services.local
{
   username    *;
   hostname    127.0.0.1;
   bind-ip        *;
   port        5001;
   hub *;
   password-connect "srvpl";
   password-receive "srvpl";
   class        servers;
   };
And part of anope config:
Code: [Select]
uplink
{
host = "127.0.0.1"
ipv6 = no
ssl = no
port = 5001
password = "srvpl"
}

Text from a Windows error message:
Quote
Problem signature:
  Problem Event Name: APPCRASH
  Application Name: anope.exe
  Application Version: 1.9.3.0
  Application Timestamp: 4d064bd4
  The name of the module with the error: MSVCR100.dll
  Version of the module with the error: 10.0.30319.1
  The time stamp module with the error: 4ba1dbbe
  Exception Code: 40000015
  Exception Offset: 0008d635
  OS Version: 6.1.7600.2.0.0.256.48
  Language Code: 1049
  Additional Information 1: b994
  Additional Information 2: b99443d80e215c616a6eb44576826cd2
  Additional Information 3: 604d
  Additional Information 4: 604d399ea53a6f5c0fb35ff202525048

What is this? What's wrong?
« Last Edit: March 08, 2011, 09:15:45 PM by srg »
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Anope socket error!
« Reply #1 on: March 08, 2011, 08:50:26 PM »

1> the passwords don't match (don't forget to /rehash if you change the pass on the ircd side)
2> Windows can't use epoll(), you must use select().
3> if you get #1 & #2 fixed, and it's still not working, try binding your listen block to the ip instead of *. Sometimes it helps.
« Last Edit: March 08, 2011, 08:53:05 PM by katsklaw »
Logged

srg

  • Anope User
  • Offline Offline
  • Posts: 2
Re: Anope socket error!
« Reply #2 on: March 08, 2011, 09:07:40 PM »

Fuck yeah, it works!  thanks!  ;D
Logged
Pages: [1]   Go Up