Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Request help...  (Read 6390 times)

0 Members and 1 Guest are viewing this topic.

Source

  • Guest
Request help...
« on: March 24, 2007, 02:31:58 PM »

Hello,
I have one problem and I hope that you can help me.
I have a little network but is from many years. Its bahamut and the services is "oXide" but, I wanna change the services to anope, because oxide is very buggy and unstable.
My question is, if there is some way to make my oxide databases to work with anope. Because I cant lose it.
I wish to know if is possible to convert them or to do something else.

Thank you in advanced.
Logged

katsklaw

  • Guest
(No subject)
« Reply #1 on: March 24, 2007, 02:36:49 PM »

currently there is only 1 db converter for anope, that is from epona to anope. There is very little chance you'd have any other choice but to start over if you switch to Anope. I've never heard of that services package and although I may be mistaken, I don't think any other currently popular services package can convert it either.
Logged

Source

  • Guest
almost finished.. please help
« Reply #2 on: March 29, 2007, 07:50:47 PM »

Its me again...
I was found a way to do it... and now everything is ok.. I just get anope to work with mysql and writted to mysql all nicks manualy. Its working perfect except one thing.
When I give info on some nick, its say "Nick is a services root administrator." and its say for all nicks :S , of course they are not administrators and cant do anything, but how to remove this msg. I think the problem is here:
in my sql table `anope_ns_core`
(1, 'Nick', 0xHEXhash, 'email@address.com', 0, '', 498, 0, 1, 0, 20, 0, 20, '', 1),

where 498 is the flag... I have maked all nicks 498 and only 2 nicks that is added in the config file as SRA to flag 33266
As I know the flag 33266 is for SRA..

however.. I puts mysql on my server.. starting services.. in log I see that they laod the db... but after few minutes services rewrite all nick flags in mysql db to 33266... and I don't know why..
I just wanna know if you can helps me to fix this problem..

P.S.: Sorry for my bad english, is not my own language... I hope that you have understand
Logged

katsklaw

  • Guest
(No subject)
« Reply #3 on: March 29, 2007, 08:30:10 PM »

Anope only writes to the sql db when it does it's update, it does not read from it and any changes you make while Anope is running will be lost.

What you want to do is shutdown Anope before you edit the sql db. Edit the sql db, then enable UseRDB, move your .db files out of the services directory and start Anope after you are finish editing the sql db. Anope will start and load from the sql db should run fine from then on so long as you edited everything correctly.

NOTE: It is very easy to corrupt your db files this way! and we do not officially recommend this solution. Do so at your own risk! Only at your own risk and we will refuse to take any responsibility for any damages done to your db files, shell account, dedicated server, colocation, personal PC, pregnant girlfriend(s), implosions of any known or unknown planet in any solar system or any moon of said planet, especially the Klingon moon, Praxis or any other oddity you'd like to blame on us.
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #4 on: March 29, 2007, 11:03:23 PM »

the nicknames being marked as services root might be a duplicate of bug #659 which has been fixed in svn...
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

Source

  • Guest
fixed
« Reply #5 on: March 30, 2007, 12:22:58 AM »

I found a way to do it.. I do this:
1. Stoping the services.
2. Upload with phpmyadmin the new db that I wish.
3. Activate in services.conf UseRDB function.
4. Starting the services.
5. After services is starting I deactivate in services.conf UseRDB.
6. Restarting anope.

Thats fix the problem... Thank you.
Logged

katsklaw

  • Guest
(No subject)
« Reply #6 on: March 30, 2007, 07:28:30 AM »

Quote
Originally posted by Source
I found a way to do it.. I do this:
1. Stoping the services.
2. Upload with phpmyadmin the new db that I wish.
3. Activate in services.conf UseRDB function.
4. Starting the services.
5. After services is starting I deactivate in services.conf UseRDB.
6. Restarting anope.

Thats fix the problem... Thank you.


That's exactly what I told you to do. I just didn't pay it out in numbered steps like you did. #2 reflects the editing of the sql db I was refering to.
Logged
Pages: [1]   Go Up