Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1] 2 3 ... 10
 1 
 on: May 16, 2018, 12:25:14 PM 
Started by Hasbullah Masby - Last post by CrazyCat
This is an option from your IRC server, not in anope.
For Unreal, when doing the ./Config, it's the question:
Quote from: Unreal
Do you want to enable prefixes for chanadmin and chanowner?
This will give +a the & prefix and ~ for +q (just like +o is @)
Supported by the major clients (mIRC, xchat, epic, eggdrop, Klient,
PJIRC, irssi, CGI:IRC, etc.)
This feature should be enabled/disabled network-wide.

 2 
 on: April 29, 2018, 08:56:30 PM 
Started by Andrew Blake - Last post by Andrew Blake
Yep, as it turns out my Anope installation was actually outdated. Using the unreal4 module, everything works fine.
Thanks a bunch!

 3 
 on: April 29, 2018, 07:57:53 PM 
Started by Andrew Blake - Last post by Andrew Blake
Thanks for the prompt response. I'll try that and report back with results.

 4 
 on: April 29, 2018, 07:55:21 PM 
Started by Andrew Blake - Last post by Adam
I recommend upgrading to 2.0.6.

 5 
 on: April 29, 2018, 07:52:39 PM 
Started by Andrew Blake - Last post by Andrew Blake
Hello everyone! I've been running into this problem, and I'm pretty confused as to what's causing it  ???
I've compiled Anope's latest stable source, as well as the most recent stable release of unrealircd. I've configured my ircd as follows:

Code: [Select]
link services.mynetwork.me {
        incoming {
                mask 127.0.0.1;
        };
        outgoing {
                bind-ip 127.0.0.1;
                hostname 127.0.0.1;
                port *;
                options { };
        };
        password "my_omitted_password";
        class servers;
};

ulines {
 services.mynetwork.me;
};

When I run ./anoperc start, the following is outputted, suggesting that the services have started successfully. Using my client I connect to my server, and run
Code: [Select]
/oper <nick> <password> Which throws me into #opers and gives me the expected netadmin permissions. I try to /msg ChanServ, and I'm told that the nickname doesn't exist. This suggests that anope isn't actually running, which I confirm with the following:

Code: [Select]
$ ./anoperc status
Anope is not currently running

Following advice I read online, I try ./services -debug -nofork, which reveals that anope is segfaulting:
https://pastebin.com/kNC3hfc0

Any help with this would be greatly appreciated. Thanks you very much Anope Developers and community. If you need any other information, just let me know.  :)

 6 
 on: April 28, 2018, 07:53:00 AM 
Started by Hasbullah Masby - Last post by Hasbullah Masby
i see founder chan with character ~ status and sop chan with character & status, i want to equate with aop with character status @ what should i do ?

 7 
 on: April 28, 2018, 07:48:59 AM 
Started by Hasbullah Masby - Last post by Hasbullah Masby
i find the error and resoved

 8 
 on: April 11, 2018, 07:49:07 PM 
Started by peter vd linden - Last post by peter vd linden
1129/5000
Hello all
first of all I want to apologize for any faulty English.
however, I scratched this in Dutch and translated it into English with google translate.
this because I am very busy writing in English.
reading generally wants me to succeed.

let me first say what I have done.
i have anope services 2.0.6 running on a 64 bit debian linux 9 server.
the irc server is unrealircd.
everything is working well.
however, I would like to see some things differently.
that's why I have 2 questions.
1: How do I ensure that anope service uses a mysql database?
2 I can state that with the comandows / msg NickServ REGISTER zig can not be controlled
3 can I use the passwords in md5 encripty when using mysql by anope in the table where the existing user acounts are located?
4: can it be asserted that people who do not zigzify within eg 3 minutes with / msg NIckServ IDENTIFY automatsies are kicked or have regrets that they can only read in chats and private chats and can not post anything themselves?

hopefully someone can help me with these things
greetings: Peter

 9 
 on: April 08, 2018, 07:44:29 AM 
Started by Hasbullah Masby - Last post by Hasbullah Masby
why can not I enable hostserv user when I have ircop with netadmin operclass
error messeg -HostServ- Password authentication required for that command.

 10 
 on: April 01, 2018, 03:58:46 PM 
Started by ekym - Last post by ekym
Thanks for the tips, I seam to have sorted this out now. Everything appears to work as intended. I guess the link in services.conf and links.conf needs to be the same, just not the same as your ircd.

Pages: [1] 2 3 ... 10