Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: i'm a new slatter of irc servics pls kindly tell me how to load new mudule on irc services and unreal  (Read 4240 times)

0 Members and 1 Guest are viewing this topic.

root

  • Guest

dear sir

pls kindly to give me some advice about how to load new module and how to update from anope 1.6x to 1.7x...

best Regaurd

khchat.net
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #1 on: September 14, 2006, 05:56:28 AM »

In order to load a custom module (or 3rd Party modules) for windows, you need to put the some_module.dll inside the data/modules folder. And for Unix/Linux... you need to put some_modules.c file inside the anope-1.7.x/src/modules directory. Go to back to your anope home directory and type (g)make depending on your compilers, after the compililation is finished and if it return no errors type (g)make install.

Next, from irc you can load the module(s) by giving the command
/OperServ MODLOAD some_module
without the filename extension (.c / .dll)

For more info read the MODULES file provided inside the DOCS folder.

And as for upgrading, backup all the *.db file(s). fetch the 1.7.15 tar.gz or .zip and configure/install them as you normally do. Its always better to start a new configuration from example.conf ... and also, remember to READ the CHANGES file :)
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.

root

  • Guest
(No subject)
« Reply #2 on: September 14, 2006, 07:00:27 AM »

Dear sir

i still get this message i use anope 1.6.4
[13:00] -OperServ- Unknown command MODLOAD.  "/msg OperServ HELP" for help.

best regaurd

khchat.net
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #3 on: September 14, 2006, 07:10:40 AM »

oh! :+ ... i started my services from 1.7.x branch only and didn't knew much about 1.6.4 version. Anyway, since 1.6.4 version is old, i'd like to suggest you to upgrade your services to the current latest release i.e 1.7.15 :)
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.
Pages: [1]   Go Up