Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Anope + Unreal error [SOLVED]  (Read 9572 times)

0 Members and 1 Guest are viewing this topic.

Mariano

  • Anope User
  • Offline Offline
  • Posts: 4
Anope + Unreal error [SOLVED]
« on: July 23, 2013, 03:13:23 AM »

Hi. Im gettis this in my log:

Code: [Select]
[Jul 22 23:06:49 2013] Loading IRCD Protocol Module: [unreal32]
[Jul 22 23:06:49 2013] status: [0][Module, Okay - No Error]
[Jul 22 23:06:49 2013] Loading Encryption Module: [enc_none]
[Jul 22 23:06:49 2013] status: [0][Module, Okay - No Error]
[Jul 22 23:06:49 2013] Anope 1.8.8 (3112) (ircd protocol: UnrealIRCd 3.2+) starting up
[Jul 22 23:06:49 2013] MSMemoReceipt not enabled in services.conf
[Jul 22 23:06:49 2013] Databases loaded
[Jul 22 23:06:49 2013] Info: Reflecting database records.
[Jul 22 23:06:49 2013] Connected to Server 1 (127.0.0.1:7070)
[Jul 22 23:06:49 2013] trying to load [cs_appendtopic]
[Jul 22 23:06:49 2013] [cs_appendtopic] Loaded successfully
[Jul 22 23:06:49 2013] status: [0][Module, Okay - No Error]
[Jul 22 23:06:49 2013] trying to load [cs_enforce]
[Jul 22 23:06:49 2013] status: [0][Module, Okay - No Error]
[Jul 22 23:06:49 2013] trying to load [ns_maxemail]
[Jul 22 23:06:49 2013] status: [0][Module, Okay - No Error]
[Jul 22 23:06:49 2013] trying to load [os_info]
[Jul 22 23:06:49 2013] os_info: Loading configuration directives...
[Jul 22 23:06:49 2013] os_info: Directive OSInfoDBName loaded (os_info.db)...
[Jul 22 23:06:49 2013] status: [0][Module, Okay - No Error]
[Jul 22 23:06:49 2013] trying to load [hs_request]
[Jul 22 23:06:49 2013] hs_request loaded
[Jul 22 23:06:49 2013] status: [0][Module, Okay - No Error]
[Jul 22 23:06:50 2013] Error: Your IRCD's link block may not be setup correctly, please check unrealircd.conf
[Jul 22 23:06:50 2013] Error: Your IRCD's link block may not be setup correctly, please check unrealircd.conf
[Jul 22 23:06:50 2013] Read error from server: No such file or directory (error num: 2)
[Jul 22 23:06:50 2013] [cs_appendtopic] Unloaded successfully
[Jul 22 23:06:50 2013] hs_request un-loaded




Code: [Select]
RemoteServer   127.0.0.1 7070 "xx"

ServerName  "services.127.0.0.1"
ServerDesc  "TestIRC Network Services"

ServiceUser "services@TestIRC.net"


Code: [Select]
link            services.127.0.0.1
{
        username        *;
        hostname        127.0.0.1;
        bind-ip         *;
        port            7070;
        hub             *;
        password-connect "xx";
        password-receive "xx";
        class           servers;

};

*/

#This is the ulines block

ulines {
        services.127.0.0.1;
        stats.ex.org;


Code: [Select]
listen         *:6697
{
        options
        {
                ssl;
                clientsonly;
        };
};




listen 127.0.0.1:7070
{
options
{
        serversonly;
};
};
I dont know if you guys need some extra info.

Cya.
« Last Edit: July 24, 2013, 03:54:41 AM by Mariano »
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Anope + Unreal error
« Reply #1 on: July 23, 2013, 07:51:25 PM »

1. If you changed the password for the paste to "xx" but you are really using something else, you didn't help any. Since you are on 127.0.0.1, it's not possible for anyone to connect so your password is perfectly safe. Please do not edit out passwords. If your password is really "xx", then disregard this point.

2. Insure you are uploading(if applicable) and rehashing the ircd before attempting to connect services. One scenario for this is editing your config on your desktop/workstation but forgetting to upload the file to your shell or forgetting to rehash after.

3. Try renaming your services to something else like "services.irc" just incase the "127.0.0.1" is causing weirdness.

thanks
Logged

Mariano

  • Anope User
  • Offline Offline
  • Posts: 4
Re: Anope + Unreal error
« Reply #2 on: July 23, 2013, 08:41:54 PM »

1- The password is xx XD.
2- Im doing the /rehash (will post later the code im getting in the console, im at work right now xd)
3- I tried to raname the service.127.0.0.1 to service.forbi.linkpc.net, with the same result.

Thx, cya!
Logged

Mariano

  • Anope User
  • Offline Offline
  • Posts: 4
Re: Anope + Unreal error
« Reply #3 on: July 24, 2013, 02:17:20 AM »

Code: [Select]
unrealircd.conf Rehashing
-
-Forbi.linkpc.net- *** Notice -- Loading IRCd configuration ..
-
-Forbi.linkpc.net- *** Notice -- unrealircd.conf:201: Ignoring extra data
-
-Forbi.linkpc.net- *** Notice -- unrealircd.conf:201: Ignoring extra data
-
-Forbi.linkpc.net- *** Notice -- unrealircd.conf:28: illegal oper::class, unknown class 'clients' using default of class 'default'
-
-Forbi.linkpc.net- *** Notice -- Configuration loaded without any problems ..
-
-Forbi.linkpc.net- *** LocOps -- Link denied for services.127.0.0.1(unknown@127.0.0.1) (No link block named 'services.127.0.0.1') [@127.0.0.1.34984]

That is the message afeter /rehash
-
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Anope + Unreal error
« Reply #4 on: July 24, 2013, 02:55:34 AM »

"unrealircd.conf:28: illegal oper::class, unknown class 'clients' using default of class 'default'"

Problem #1. Should be self explanatory.

"unrealircd.conf:201: Ignoring extra data"

Problem #2. You have extra characters on or near line 201. Start at line 201 and read backwards. Hint: extra data can also be cause by missing operators, delimiters and terminators such as semi-colons(;).

"*** LocOps -- Link denied for services.127.0.0.1(unknown@127.0.0.1) (No link block named 'services.127.0.0.1') [@127.0.0.1.34984]"


This will go away when you fix problems 1 and 2 above.
« Last Edit: July 24, 2013, 02:59:47 AM by katsklaw »
Logged

Mariano

  • Anope User
  • Offline Offline
  • Posts: 4
Re: Anope + Unreal error
« Reply #5 on: July 24, 2013, 03:54:19 AM »

Ty so much for u help.

What I was missing:

- 2 Class blocks (servers clients)
- 1 "ilegal" character (') this one, was breaking one comment line
- in the listen part, i was missing the { };

Again, thx you!!

Logged

shaaneson

  • Anope User
  • Offline Offline
  • Posts: 1
Re: Anope + Unreal error [SOLVED]
« Reply #6 on: October 07, 2013, 06:35:03 AM »

Thank you vet much for your valuable contribution. keep sharing info. GOD bless you
 :P
Pages: [1]   Go Up