Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Problem starting services (Inspircd2.0)  (Read 9691 times)

0 Members and 1 Guest are viewing this topic.

James

  • Anope User
  • Offline Offline
  • Posts: 4
Problem starting services (Inspircd2.0)
« on: June 30, 2013, 09:50:40 AM »

Hello,

I've been trying to troubleshoot this for some time now and I just can't seem to figure it out on my own.

Code: [Select]
Jun 30 00:44:01.556178 2013] Connected to Server 1 (irc.xxx.org:6667)
[Jun 30 00:44:01.556512 2013] debug: Sent: CAPAB START 1202
[Jun 30 00:44:01.556628 2013] debug: Sent: CAPAB CAPABILITIES :PROTOCOL=1202
[Jun 30 00:44:01.556717 2013] debug: Sent: CAPAB END
[Jun 30 00:44:01.556872 2013] debug: Sent: SERVER services.xxx.org xxxxx 0 3AX :Services for the xxxx Network
[Jun 30 00:44:01.556905 2013] debug: Creating services.xxx.org(3AX) uplinked to No uplink
[Jun 30 00:44:01.557022 2013] debug: Sent: :3AX NOTICE $services.xxx.org :Services are now back online - have a nice day
[Jun 30 00:44:01.557048 2013] debug: Emitting event "connect" (1 args)
[Jun 30 00:44:01.557107 2013] debug: Received: :irc.xxx.org NOTICE Auth :*** Looking up your hostname...
[Jun 30 00:44:01.557194 2013] debug: Received: :irc.xxx.org NOTICE Auth :*** Could not resolve your hostname: Domain name not found; using your IP address (x.141.x.181) instead.
[Jun 30 00:44:01.557273 2013] debug: Received: :irc.xxx.org 451 SERVER :You may not register as a server (servers have separate ports from clients, change your config)
[Jun 30 00:44:01.557295 2013] debug: unknown message from server (:irc.xxx.org 451 SERVER :You may not register as a server (servers have separate ports from clients, change your config))
[Jun 30 00:44:01.557436 2013] debug: Received: :irc.xxx.org 451 NOTICE :You have not registered
[Jun 30 00:44:01.557476 2013] debug: unknown message from server (:irc.xxx.org 451 NOTICE :You have not registered)
[Jun 30 00:44:12.567726 2013] debug: Received: ERROR :Closing link: (unknown@xxx.141.xxx.181) [Registration timeout]
[Jun 30 00:44:12.567807 2013] debug: unknown message from server (ERROR :Closing link: (unknown@xxx.141.xxx.181) [Registration timeout])
[Jun 30 00:44:12.567877 2013] debug: Emitting event "db_saving" (1 args)
[Jun 30 00:44:12.567908 2013] debug: Saving FFF databases
[Jun 30 00:44:12.568976 2013] debug: Emitting event "db_saving" (1 args)
[Jun 30 00:44:12.569016 2013] debug: Emitting event "shutdown" (1 args)
[Jun 30 00:44:12.569041 2013] Read error from server: Success (error num: 0)
[Jun 30 00:44:12.569148 2013] debug: Sent: :3AX SQUIT services.xxx.org :Read error from server: Success (error num: 0)
[Jun 30 00:44:12.569190 2013] debug: firstuser() returning NULL (end of list)
[Jun 30 00:44:12.569217 2013] debug: Emitting event "shutdown" (1 args)
[Jun 30 00:44:12.569343 2013] debug: Emitting event "delcommand" (2 args)
[Jun 30 00:44:12.569628 2013] debug: Emitting event "delcommand" (2 args)
[Jun 30 00:44:12.569814 2013] debug: Emitting event "delcommand" (2 args)
...
repeated message from above x 20?
...
[Jun 30 00:44:12.595275 2013] debug: Cleaning out Module run time directory (/home/xxx-irc/services/modules/runtime) - this may take a moment please wait
[Jun 30 00:44:12.595571 2013] debug: Module run time directory has been cleaned out


I see something about, "You may not register as a server (servers have separate ports from clients, change your config)"

How am I supposed to register to use the services?


Here is my link:

Code: [Select]
<link name="services.xxx.org"
      ipaddr="localhost"
      port="7000"
      sid="3AX"
      allowmask="127.0.0.0/8"
      sendpass="xxx"
      recvpass="xxx">


Here is my binds:

Code: [Select]
<bind address="" port="6660-6669" type="clients">
<bind address="services.xxx.org" port="7000,7001" type="servers">
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: Problem starting services (Inspircd2.0)
« Reply #1 on: June 30, 2013, 09:52:14 AM »

[Jun 30 00:44:01.557273 2013] debug: Received: :irc.xxx.org 451 SERVER :You may not register as a server (servers have separate ports from clients, change your config)

Should be rather self explanatory? Don't connect services to a client port, like 6667.

Also use "" for binds, not services hostname.
Logged

James

  • Anope User
  • Offline Offline
  • Posts: 4
Re: Problem starting services (Inspircd2.0)
« Reply #2 on: June 30, 2013, 10:06:20 AM »

[Jun 30 00:44:01.557273 2013] debug: Received: :irc.xxx.org 451 SERVER :You may not register as a server (servers have separate ports from clients, change your config)

Should be rather self explanatory? Don't connect services to a client port, like 6667.

Also use "" for binds, not services hostname.

Wow what a fast reply!

I tried out what you said and changed the bind to "" and also changed the connect port to the services port.

[Jun 30 02:02:41.465207 2013] Connected to Server 1 (services.damaplus.org:7000)
[Jun 30 02:02:41.465333 2013] debug: Sent: CAPAB START 1202
[Jun 30 02:02:41.465385 2013] debug: Sent: CAPAB CAPABILITIES :PROTOCOL=1202
[Jun 30 02:02:41.465408 2013] debug: Sent: CAPAB END
[Jun 30 02:02:41.465436 2013] debug: Sent: SERVER services.damaplus.org 0599226714 0 3AX :Services for the DamaPlus Network
[Jun 30 02:02:41.465458 2013] debug: Creating services.damaplus.org(3AX) uplinked to No uplink
[Jun 30 02:02:41.465491 2013] debug: Sent: :3AX NOTICE $services.damaplus.org :Services are now back online - have a nice day
[Jun 30 02:02:41.465509 2013] debug: Emitting event "connect" (1 args)
[Jun 30 02:02:41.465539 2013] debug: Received: â–’
[Jun 30 02:02:41.465557 2013] debug: unknown message from server (â–’)

[Jun 30 02:02:41.465594 2013] debug: Emitting event "db_saving" (1 args)
[Jun 30 02:02:41.465611 2013] debug: Saving FFF databases
[Jun 30 02:02:41.466335 2013] debug: Emitting event "db_saving" (1 args)
[Jun 30 02:02:41.466358 2013] debug: Emitting event "shutdown" (1 args)
[Jun 30 02:02:41.466374 2013] Read error from server: Broken pipe (error num: 32)
[Jun 30 02:02:41.466398 2013] debug: Sent: :3AX SQUIT services.damaplus.org :Read error from server: Broken pipe (error num: 32)


How would I go about fixing a broken pipe?
« Last Edit: June 30, 2013, 10:09:54 AM by James »
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: Problem starting services (Inspircd2.0)
« Reply #3 on: June 30, 2013, 10:12:35 AM »

Are you still connecting services to the correct host? First post had
]Jun 30 00:44:01.556178 2013] Connected to Server 1 (irc.xxx.org:6667)
Second has
[Jun 30 02:02:41.465207 2013] Connected to Server 1 (services.damaplus.org:7000)

Also you need to load m_spanningtree on inspircd.
Logged

James

  • Anope User
  • Offline Offline
  • Posts: 4
Re: Problem starting services (Inspircd2.0)
« Reply #4 on: June 30, 2013, 10:19:17 AM »

Are you still connecting services to the correct host? First post had
]Jun 30 00:44:01.556178 2013] Connected to Server 1 (irc.xxx.org:6667)
Second has
[Jun 30 02:02:41.465207 2013] Connected to Server 1 (services.damaplus.org:7000)

Also you need to load m_spanningtree on inspircd.

They resolve to the same IP and m_spanningtree is being loaded.

Not sure if it helps but here is my anope config:

http://pastie.org/private/7kpwqucecpudlzqetslofa
Logged

James

  • Anope User
  • Offline Offline
  • Posts: 4
Re: Problem starting services (Inspircd2.0)
« Reply #5 on: July 01, 2013, 09:07:04 PM »

They resolve to the same IP and m_spanningtree is being loaded.

Not sure if it helps but here is my anope config:

http://pastie.org/private/7kpwqucecpudlzqetslofa

Anyone have any ideas with what might be wrong?
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Problem starting services (Inspircd2.0)
« Reply #6 on: July 01, 2013, 09:45:07 PM »

Just because they resolve to the same doesn't mean anything. The name in your ircd link configuration *must match the name you specified in ServerName. In some cases it is even case sensitive.
Logged
Pages: [1]   Go Up