Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Compiling Anope 1.8.6 on ARM x19 based NAS  (Read 3278 times)

0 Members and 1 Guest are viewing this topic.

spoonmore

  • Anope User
  • Offline Offline
  • Posts: 1
Compiling Anope 1.8.6 on ARM x19 based NAS
« on: October 01, 2011, 03:14:59 AM »

Hi there!

I'm currently trying to compile Anope on my QNAP TS-219P+ ARM x19 based NAS, however I'm running into a problem. I've been able to compile 1.8.5 last year on my x86 based QNAP without any issues but now it seems to dislike the awk versions I use.

When I run the Config script it will halt at;

configure: creating ./config.status
config.status: creating Makefile
awk: ./confdDz7Pe/subs.awk:2: Unexpected token
config.status: error: could not create Makefile


So I tried using the gnu based awk from the Optware tools because I had the funny feeling that the busybox version of awk probably was a bit too feature poor to deal with the stuff it had to process but when I try gawk (4.0.0-1) it still does b0rk on running Config however it being a bit more verbose;

Full output at: http://pastebin.com/mGRk0ucT

...and this is the section from config.status it is trying to parse with awk: http://pastebin.com/TFW5Xuav

Would appreciate suggestions/ideas or better yet a fix on how to remedy this ;)


Thanks,
spoon
« Last Edit: October 01, 2011, 03:18:45 AM by spoonmore »
Logged
Pages: [1]   Go Up