Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: upgrade 1.8.5 -> 1.8.6  (Read 11457 times)

0 Members and 1 Guest are viewing this topic.

Gianluca

  • Anope User
  • Offline Offline
  • Posts: 27
upgrade 1.8.5 -> 1.8.6
« on: June 27, 2011, 12:40:17 PM »

Hi i have anope services version *.8.5 and i can upgrade this version in 1.8.6.

I must download a new file or here another method ( salving an exist Databases of NS/CS/BS/OS? )

Tnk y for your reply!!!

Gianluca
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: upgrade 1.8.5 -> 1.8.6
« Reply #1 on: June 27, 2011, 12:42:14 PM »

Shut services down.
Back it all up.
Extract + configure the 1.8.6 and it will install into the same directory by default as 1.8.5 (ie ~/services)
Check Changes.conf for any config changes (I forget if there are any)
Start services again.
Logged

Gianluca

  • Anope User
  • Offline Offline
  • Posts: 27
Re: upgrade 1.8.5 -> 1.8.6
« Reply #2 on: June 27, 2011, 01:24:48 PM »

this is easy good...but for testing this a new version i have a problem..when i connect a new user or my clone the services close connection..seen this report on -/services -debug

Code: [Select]
PANIC! buffer = NICK G\ 2 1309176958 Gogatassj5 *@* xxx.xxx.net 0 :Arayashiki
[Jun 27 14:15:59.156140 2011] debug: Sent: :Services.xxxx.net GLOBOPS :PANIC! buffer = NICK G\ 2 1309176958 Gogatassj5 *@* xxx.xxx.net 0 :Arayashiki

Segmentation fault

i have disabilited the now log user...
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: upgrade 1.8.5 -> 1.8.6
« Reply #3 on: June 27, 2011, 01:31:57 PM »

What did you do?

(Try reproducing running ./services -support)
Logged

Gianluca

  • Anope User
  • Offline Offline
  • Posts: 27
Re: upgrade 1.8.5 -> 1.8.6
« Reply #4 on: June 27, 2011, 01:39:30 PM »

This is a report

Code: [Select]
[Jun 27 14:37:25.804817 2011] debug: Received: NICK G\ 2 1309178244 Gogatassj5 *.libero.it xxx.xxx.net 0 :Arayashiki
[Jun 27 14:37:25.804860 2011] debug: new user: G\
[Jun 27 14:37:25.804885 2011] PANIC! buffer = NICK G\ 2 1309178244 Gogatassj5 *.libero.it xxx.xxx.net 0 :Arayashiki
[Jun 27 14:37:25.804934 2011] debug: Sent: :Services.xxx.net GLOBOPS :PANIC! buffer = NICK G\ 2 1309178244 Gogatassj5 *.libero.it xxx.xxx.net 0 :Arayashiki

Segmentation fault

I have connect my clone ( nick G\ ) and Gogetassj5 is my main nick

Segmentation fault
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: upgrade 1.8.5 -> 1.8.6
« Reply #5 on: June 27, 2011, 01:41:49 PM »

Is this when using ./services -support ?

I need more information on what you are doing.
Logged

Gianluca

  • Anope User
  • Offline Offline
  • Posts: 27
Re: upgrade 1.8.5 -> 1.8.6
« Reply #6 on: June 27, 2011, 01:44:09 PM »

yes i have used ./services -support

Which information do y want?
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: upgrade 1.8.5 -> 1.8.6
« Reply #7 on: June 27, 2011, 01:45:41 PM »

What you're actually doing to make it crash.

Ie, are you connecting lots of users, or is it because of the nick with a \ or what.

Pastebin the whole log file too.

Does it create a core file? (ensure DumpCore is enabled in the config).

Logged

Gianluca

  • Anope User
  • Offline Offline
  • Posts: 27
Re: upgrade 1.8.5 -> 1.8.6
« Reply #8 on: June 27, 2011, 01:55:18 PM »

Services Crash when i connect new user!!

I Don't use the DumpCore

The log file is only this

Jun 27 14:37:25.804817 2011] debug: Received: NICK G\ 2 1309178244 Gogatassj5 *.libero.it xxx.xxx.net 0 :Arayashiki
[Jun 27 14:37:25.804860 2011] debug: new user: G\
[Jun 27 14:37:25.804885 2011] PANIC! buffer = NICK G\ 2 1309178244 Gogatassj5 *.libero.it xxx.xxx.net 0 :Arayashiki
[Jun 27 14:37:25.804934 2011] debug: Sent: :Services.xxx.net GLOBOPS :PANIC! buffer = NICK G\ 2 1309178244 Gogatassj5 *.libero.it xxx.xxx.net 0 :Arayashiki

Segmentation fault
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: upgrade 1.8.5 -> 1.8.6
« Reply #9 on: June 27, 2011, 02:01:05 PM »

Enable dump core and get a backtrace.

ulimit -c unlimited
Enable the DumpCore directive on services.conf
Start Anope and reproduce the crash to create a core.
Load the core using: gdb services core.number
On gdb type: bt
Provide the relevant information of the bt command just issued. 
Logged

Gianluca

  • Anope User
  • Offline Offline
  • Posts: 27
Re: upgrade 1.8.5 -> 1.8.6
« Reply #10 on: June 27, 2011, 02:15:08 PM »

who is gbd?
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: upgrade 1.8.5 -> 1.8.6
« Reply #11 on: June 27, 2011, 02:17:39 PM »

gdb is a debugging tool that will help us understand your crash.
Logged

Gianluca

  • Anope User
  • Offline Offline
  • Posts: 27
Re: upgrade 1.8.5 -> 1.8.6
« Reply #12 on: June 27, 2011, 02:22:49 PM »

mm i can istalled that tools...?
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: upgrade 1.8.5 -> 1.8.6
« Reply #13 on: June 27, 2011, 02:29:18 PM »

Yes.
Logged

Gianluca

  • Anope User
  • Offline Offline
  • Posts: 27
Re: upgrade 1.8.5 -> 1.8.6
« Reply #14 on: June 27, 2011, 02:38:53 PM »

that's ok..i installed in another directory or in directory of services?
Logged

VisioN

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 82
    • myIRC Project Hosting IRC Network
Logged
______________________________
VisioN
Find me: irc.myirc.net | irc.anope.org
Contact me: vision@myirc.net

Gianluca

  • Anope User
  • Offline Offline
  • Posts: 27
Re: upgrade 1.8.5 -> 1.8.6
« Reply #16 on: June 28, 2011, 05:48:55 PM »

hi tnk for y reply and help but where i can this core.number?
Logged

Gianluca

  • Anope User
  • Offline Offline
  • Posts: 27
Re: upgrade 1.8.5 -> 1.8.6
« Reply #17 on: June 29, 2011, 07:22:15 AM »

Good Morning :)
mmm when i make (gdb) attach process-services i read this core:

Code: [Select]
warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7fffc3082000
0x00002b73a230b6d3 in __select_nocancel () from /lib64/libc.so.6

error in libc?

and if i write "bt" this is an error:

Code: [Select]
#0  0x00002b73a230b6d3 in __select_nocancel () from /lib64/libc.so.6
During symbol reading, incomplete CFI data; unspecified registers (e.g., rax) at 0x2b73a230b6e0.
During symbol reading, cannot get low and high bounds for subprogram DIE at 276756.
#1  0x0000000000446ef9 in sgets (
    buf=0x698340 ":IRC.NomeServer.net SMO o :\002(sync)\002 Link Services.xxx.net -> IRC.NomeServer.net is now synced [secs: -1 recv: 1.611 sent: 6.423]",
    len=1024, s=1) at sockutil.c:425
#2  0x0000000000446f99 in sgets2 (buf=0x2 <Address 0x2 out of bounds>, len=-1023137472, s=0) at sockutil.c:453
#3  0x000000000042f5d9 in main (ac=<value optimized out>, av=0x7fffc3043ac8, envp=0x7fffc3043ad8) at main.c:664

« Last Edit: June 29, 2011, 07:26:30 AM by Gianluca »
Logged
Pages: [1]   Go Up