Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Unable to load module bs_bot  (Read 7622 times)

0 Members and 1 Guest are viewing this topic.

Charles

  • Anope User
  • Offline Offline
  • Posts: 6
Unable to load module bs_bot
« on: March 21, 2011, 08:33:06 PM »

Hi @ all,

hopefully someone can help me out with this:

Code: [Select]
/msg operserv modload bs_bot
gives me:

Code: [Select]
Unable to load module bs_bot
===

Info:
There are 117 Modules loaded and in the modules folder there is a file called "bs_bot.so"

Maybe someone can help me out?

Thanks in advance

Logged

Charles

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Unable to load module bs_bot
« Reply #1 on: March 22, 2011, 12:21:53 PM »

Btw. i'm using the latest stable version of anope. Everything seems to work fine except bots. Recompiling didn't helped.

Any other idea?

Thanks in advance
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Unable to load module bs_bot
« Reply #2 on: March 22, 2011, 02:48:30 PM »

Pastebin your debug log.
Logged

Charles

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Unable to load module bs_bot
« Reply #3 on: March 22, 2011, 11:46:18 PM »

hey charles,


[Mar 22 23:45:32 2011] Loading IRCD Protocol Module: [unreal32]
[Mar 22 23:45:32 2011] status:
  • [Module, Okay - No Error]
[Mar 22 23:45:32 2011] Loading Encryption Module: [enc_md5]
[Mar 22 23:45:32 2011] status:
  • [Module, Okay - No Error]
[Mar 22 23:45:32 2011] Anope 1.8.5 (3037) (ircd protocol: UnrealIRCd 3.2+) starting up
[Mar 22 23:45:32 2011] ns_sendpass requested unload...
[Mar 22 23:45:32 2011] debug: trying to load core module [ns_sendpass]
[Mar 22 23:45:32 2011] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Mar 22 23:45:32 2011] cs_sendpass requested unload...
[Mar 22 23:45:32 2011] debug: trying to load core module [cs_sendpass]
[Mar 22 23:45:32 2011] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Mar 22 23:45:32 2011] MSMemoReceipt not enabled in services.conf
[Mar 22 23:45:32 2011] ms_rsend requested unload...
[Mar 22 23:45:32 2011] debug: trying to load core module [ms_rsend]
[Mar 22 23:45:32 2011] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Mar 22 23:45:32 2011] MySQL: has been disabled.

hope this helps :)
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Unable to load module bs_bot
« Reply #4 on: March 22, 2011, 11:49:18 PM »

Do you have BotServName commented out by chance?
Logged

Charles

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Unable to load module bs_bot
« Reply #5 on: March 22, 2011, 11:53:49 PM »

hey katsklaw,

i don't think so:


Code: [Select]
NickServName    "NickServ"  "Nickname Server"
ChanServName    "ChanServ"  "Channel Server"
MemoServName    "MemoServ"  "Memo Server"
BotServName     "BotServ"   "Bot Server"
HelpServName    "HelpServ"  "Help Server"
OperServName    "OperServ"  "Operator Server"
GlobalName      "Global"    "Global Noticer"
#DevNullName     "DevNull"   "/dev/null -- message sink"
HostServName    "HostServ"  "vHost Server
"

thanks for your help
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Unable to load module bs_bot
« Reply #6 on: March 22, 2011, 11:59:58 PM »

on IRC do: /os modlist core See if bs_bot is already loaded.

If not, in your shell type:

> cd services
> ./anoperc stop
> ./anoperc start -debug -debug -debug -debug -nofork (yes the 4 -debug is intentional)

After services connects, on IRC type: /os modload bs_bot then look at anope running in the forground at debug level 4 on your shell for any errors.
Logged

Charles

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Unable to load module bs_bot
« Reply #7 on: March 23, 2011, 12:08:27 AM »

i got the following now:

Code: [Select]
[Mar 23 00:07:34.649996 2011] debug: Sent: :OperServ NOTICE haze:Unable to load module bs_bot
[Mar 23 00:07:34.650032 2011] debug: Top of main loop
[Mar 23 00:07:34.650061 2011] debug: Checking timeouts at 1300838854
[Mar 23 00:07:34.650088 2011] debug: Finished timeout list
[Mar 23 00:07:39.655197 2011] debug: Top of main loop
[Mar 23 00:07:39.655280 2011] debug: Checking timeouts at 1300838859
[Mar 23 00:07:39.655308 2011] debug: Finished timeout list
[Mar 23 00:07:44.660416 2011] debug: Top of main loop
[Mar 23 00:07:44.660498 2011] debug: Checking timeouts at 1300838864
[Mar 23 00:07:44.660524 2011] debug: Finished timeout list
[Mar 23 00:07:49.665632 2011] debug: Top of main loop
[Mar 23 00:07:49.665723 2011] debug: Checking timeouts at 1300838869
[Mar 23 00:07:49.674869 2011] debug: Finished timeout list

does this help?
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Unable to load module bs_bot
« Reply #8 on: March 23, 2011, 12:39:04 AM »

not really, I need the few lines above where you started your paste.
Logged

Charles

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Unable to load module bs_bot
« Reply #9 on: March 23, 2011, 09:09:23 AM »

hopefully this helps:

Code: [Select]
[Mar 23 09:08:29.886996 2011] debug: buffered_read_one(4) returning 111
[Mar 23 09:08:29.887023 2011] debug: buffered_read_one(4) returning 97
[Mar 23 09:08:29.887050 2011] debug: buffered_read_one(4) returning 100
[Mar 23 09:08:29.887077 2011] debug: buffered_read_one(4) returning 32
[Mar 23 09:08:29.887104 2011] debug: buffered_read_one(4) returning 98
[Mar 23 09:08:29.887131 2011] debug: buffered_read_one(4) returning 115
[Mar 23 09:08:29.887159 2011] debug: buffered_read_one(4) returning 95
[Mar 23 09:08:29.887186 2011] debug: buffered_read_one(4) returning 98
[Mar 23 09:08:29.887212 2011] debug: buffered_read_one(4) returning 111
[Mar 23 09:08:29.887240 2011] debug: buffered_read_one(4) returning 116
[Mar 23 09:08:29.887267 2011] debug: buffered_read_one(4) returning 13
[Mar 23 09:08:29.887294 2011] debug: buffered_read_one(4) returning 10
[Mar 23 09:08:29.887321 2011] debug: Received: :haze PRIVMSG operserv :modload bs_bot
[Mar 23 09:08:29.887367 2011] debug: finduser(0x7fff08d24b30)
[Mar 23 09:08:29.887394 2011] debug: finduser(haze) -> 0x0x1b5bea0
[Mar 23 09:08:29.887421 2011] OperServ: haze: modload bs_bot
[Mar 23 09:08:29.887554 2011] debug: flush_write_buffer wanted 55, got 55
[Mar 23 09:08:29.887606 2011] debug: buffered_write(4,0x7fff08d1e357,55) returning 55
[Mar 23 09:08:29.887643 2011] debug: Sent: :OperServ NOTICE haze :Unable to load module bs_bot
[Mar 23 09:08:29.887677 2011] debug: Top of main loop
[Mar 23 09:08:29.887706 2011] debug: Checking timeouts at 1300871309
[Mar 23 09:08:29.887732 2011] debug: Finished timeout list
[Mar 23 09:08:34.892828 2011] debug: Top of main loop
[Mar 23 09:08:34.892910 2011] debug: Checking timeouts at 1300871314
[Mar 23 09:08:34.892936 2011] debug: Finished timeout list
[Mar 23 09:08:39.898036 2011] debug: Top of main loop
[Mar 23 09:08:39.898132 2011] debug: Checking timeouts at 1300871319
[Mar 23 09:08:39.909312 2011] debug: Finished timeout list
Logged
Pages: [1]   Go Up