Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  


Pages: [1]   Go Down

Author Topic: [SOLVED] "status: [11][Module Error, File I/O Error]"  (Read 4688 times)

0 Members and 1 Guest are viewing this topic.

Zath Erus

  • Anope User
  • Offline Offline
  • Posts: 2
[SOLVED] "status: [11][Module Error, File I/O Error]"
« on: September 12, 2010, 09:08:26 PM »

(yeah, I tried to reply to 2 other posts of the same subject, however, I was instructed to start a new post..)


Hello everyone!

now, I probably will sound like a newbie here, a little.. I just ask that you read the post all-the-way through before making a quick judgement :-)


after installing services (anope 1.8.5) on a new server build (FBSD 6.3 [SMP]) and after spending hours (re)setting up that cfg file (I had to import the old one, but made a brand new one just to be "on the safe side")..

I got hit with the:

[Sep 12 20:22:04 2010] Loading IRCD Protocol Module: [unreal32]
[Sep 12 20:22:04 2010] status: [11][Module Error, File I/O Error]
message followed by an immediate shutdown of the anope services bot.

I have read the other posts here, which suggest running it in "debug mode" and installing it "as a standard user" and all that..

makes sense.. however, I was forced to take the actions that I have- but I did attempt to do the right things..

I could not install anope under ANY user/account except the root user.. but I also made sure to "chown" all the dirs and libs approppiately so that its "designated user" has full access to said libs and dirs/folders (including the modules, language and runtime dirs.. AND, of course, the anope base dir proper.. )

I have  carefully set up the config file.. spent HOURS on that puppy to make sure it was right.. AND I designated a dedicated port, just for anope, into the ircd/configs and rebooted everything cold..

debug mode doesn't reveal anything new- in fact, theres nothing at all.. it appears anope shuts itself down before it can write any debug information!

so, I'm a little puzzled here...   I did attempt re-installig it, and that didn't do anything except make a small mess on the drives (I'll clean that up later) and  I also tried installing it as its designated user- with make bawking out errors and killing itself almost immediately!

(somethig about "using a POSIX shell"  which POSIX is installed and DETECTED ... )

I have Icecast, UnrealIRCd, eggdrop, Perl 5.8, Libshout/p5-shout, and Apache allready on the box.. and all that installed, compiled and is operating Okay... Server is in a Datacenter/CoLo and I own it and have "full" root.. The box is a 4-core xeon CPU 2.8 Ghz with 2 gigs ram and 600 Gigs of hard drive space (which is mostly empty)

so, I'm a tad puzzled as to why this is not working..  I followed the steps to the best I can..

oh! I should mention, orginally, I had anope 1.6.2 on there.. why? dumb ports weren't updated!  I gave up on the ports and came HERE and got the latest;  v1.6.2 DID install without any problems.. however, its really "broken"; example,  typing /nickserv help" gives out a bit of garbage (like "you are now a member of %d%s group" ) instead of giving the help screens (like it should)
and, though the databases DID load.. it seems "unresponsive" to possable new users). I felt it was "damaged" and decided to go for the latest (which seems to be v1.8.5...)

so, there ya have it :)  if I seem a  little "testy", I apologize.. I'm just very flustered at the thing at the moment..

I've used anope for years..  and always had SOME kind of odd/small issue with installing it..  but this ones got me stumped!

any help would be appreciated!

:) :)
« Last Edit: September 12, 2010, 11:04:35 PM by Zath Erus »

Zath Erus

  • Anope User
  • Offline Offline
  • Posts: 2
Re: [SOLVED] "status: [11][Module Error, File I/O Error]"
« Reply #1 on: September 12, 2010, 11:08:56 PM »

this issue has been corrected- it was caused by trying to untar the package on the root dir (/) and the kernel security not allowing it to be modified once it was laid down

for anope, you MUST create a "lower" dir off root.. and then untar it there.. (example: /test/anope-1.8.5/)  do not attempt "/anope-1.8.5" as  thats what I was doing!"

thanks to the gang in the IRC chatroom for all their help  and helping me to track this issue down.

(now to solve the OTHER problems!)

:) :)
Pages: [1]   Go Up