Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Help Installing Binary Modules  (Read 5695 times)

0 Members and 1 Guest are viewing this topic.

tinlar

  • Anope User
  • Offline Offline
  • Posts: 14
Help Installing Binary Modules
« on: December 19, 2009, 05:03:03 PM »

Okay, first off I apologize if this is documented somewhere I've been unable to find.  Everything thus far I've been able to find revolves around installing modules from source and I don't have a compiler on the system running anope and I'm trying to avoid installing one just for this.  It is a windows system so it's not as simple as apt-get.

That being said I've noted that several modules are distributed in binary form which is great but thus far I've been unable to get them installed and loaded and haven't found documentation on this yet.  Could someone point me to the documentation or outline how it's done?  This is Unreal3.2 with Anope1.8

My attempts thus far have been:
- copy the binary dll into \\server\Anope\data\modules
- add the module to ModuleDelayedAutoload in the config file
- restart service
- confirm that the new module now appears in os modlist
- when running os modload moduleName it returns the error 'Unable to load module moduleName'
- the log shows Module loading status: 4 (Module Error, File does not exist) which seems to imply I've installed it in the wrong place but no where else in the directory structure appears even remotely right to me

Any help would be appreciated.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Help Installing Binary Modules
« Reply #1 on: December 19, 2009, 05:08:04 PM »

The *.dll should be put into the modules dir as you've done.

Then try and /os modload it and see what happens.
Logged

tinlar

  • Anope User
  • Offline Offline
  • Posts: 14
Re: Help Installing Binary Modules
« Reply #2 on: December 19, 2009, 11:50:40 PM »

Thanks Charles but I'm still getting the error...

- when running /os modload moduleName it returns the error 'Unable to load module moduleName'
- the log shows 'Module loading status: 4 (Module Error, File does not exist)' which seems to imply I've installed it in the wrong place but no where else in the directory structure appears even remotely right to me
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Help Installing Binary Modules
« Reply #3 on: December 20, 2009, 08:51:48 AM »

Hm, and you're certain anope is running from that dir? (I know that sounds silly but just checking).

Have you tried more than 1 module?

What version of windows are you using?

Have you ensured it is a .dll you are asking for it to load and not a .c. (Similarly you are using the precompiled version of anope (supplied as .exe))?
Logged

tinlar

  • Anope User
  • Offline Offline
  • Posts: 14
Re: Help Installing Binary Modules
« Reply #4 on: December 21, 2009, 02:57:55 AM »

I confirmed that anope is running from the directory I'm putting the module in. 
I've yet to try another module, I'm making an attempt to load diceserve_1.8.dll which if my memory isn't failing me you were kind enough to build for me.
This is running on a windows XP box with SP3 installed.
I've confirmed it is the binary dll I've placed in the modules directory and not the source.
Anope 1.8.2 was installed from the pre compiled version supplied as an exe.

/os modlist returns the bellow for diceserv ...
-OperServ- Module: diceserv_1.8 [v2.0] [3rd]

So it appears it has detected the dll, noted that it was version 2.0 and a third party module.  Yet when trying to load it it fails with the below in the logs ...

[Dec 20 20:53:13 2009] OperServ: Tinlar: modload diceserve_1.8
[Dec 20 20:53:13 2009] Trying to load module [diceserve_1.8]
[Dec 20 20:53:13 2009] Module loading status: 4 (Module Error, File does not exist)

very perplexing... I wonder if it is because I'm running on Windows and the filename doesn't follow the 8.3 standard?  I'm going to pick a different random stable module and try it... I'll let you know.
Logged

Adam

  • Team
  • *
  • Offline Offline
  • Posts: 463
Re: Help Installing Binary Modules
« Reply #5 on: December 21, 2009, 03:01:38 AM »

If it shows on /os modlist then the module is loaded.

Quote
[Dec 20 20:53:13 2009] OperServ: Tinlar: modload diceserve_1.8
[Dec 20 20:53:13 2009] Trying to load module [diceserve_1.8]
[Dec 20 20:53:13 2009] Module loading status: 4 (Module Error, File does not exist)

You spelled diceserv wrong?
Logged

Naram Qashat

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 192
    • CBX's Sprite Animations
Re: Help Installing Binary Modules
« Reply #6 on: December 21, 2009, 03:01:50 AM »

Well, for one, it's diceserv_1.8 not diceserve_1.8.  Also, if the module is already loaded, it won't let you use /os modload on it.
Logged

tinlar

  • Anope User
  • Offline Offline
  • Posts: 14
Re: Help Installing Binary Modules
« Reply #7 on: December 21, 2009, 03:08:12 AM »

 ???

diceservE ... forgive me while I go outside and kick myself in the nads.

it of coarse works as intended.
Logged
Pages: [1]   Go Up