Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  


Pages: [1]   Go Down

Author Topic: Services Seg fault  (Read 3950 times)

0 Members and 1 Guest are viewing this topic.


  • Guest
Services Seg fault
« on: April 03, 2006, 05:38:15 PM »

Hello there.

Up until yesterday.... i was using the previous development version you had on (the version before the one thats up now).

We were using it with ratbox 2.1.7 and it kept seg faulting.

Yesterday.... i updated the services to the latest development version... Today, when i logged into my network, the services wern't there.... so i logged into our services server and the services process was still running... but using 100% cpu.

No errors were logged in the log file.... do you have any idea what could be wrong.

The server the services runs on... also hosts services for another network as well... using unreal.... and that services DOES NOT seg fault.... so i dont think its a problem related to the server itself... i think its related to ratbox.

One thing i have noticed is some people are complaining that chanserv gives the following message when they try to get +o in a channel they are in

"User <nickname> is not on channel <channel>"

thats not the exact thing it says... but simular..... it only does this for a few people.... and AOP also doesn't work for these people

But, if we use Operserv to +o that user... it works.

the weird thing is that it ALWAYS happens to the same people... and we have tried dropping the channel.

We have also had errors that the channel doesn't exist as well.... e.g, when we try to register a channel, it says the channel doesn't exist... and we have to completly empty out the channel and go back in to fix it.

I think this is what is causing the services to seg fault.

Now, going back to when we originally setup ratbox (we switched from unreal to ratbox) someone made a sanick module for us....

The services had been up for a week before we loaded this module.... and when we loaded it and used it.... this is when we started to get problems... i think.

the module allowed us to /sajoin users into a shannel, and /sanick to change a users nickname..... so i wouldn't be surprised if the module has caused the ircd's to sort of... loose track of nicknames maybe?

We have tried restarting all our leaf servers in turn..... but if the information about users and such is incorrect on the hub they would just get that same info on all the leafs again correct?

maybe the only way we could fix this is try killing all the servers in our network then bringing them all back up to clear everything....

if anyone could let me know if this is a reasonable idea... or if im going off in completly the wrong direction.



  • Anope User
  • Offline Offline
  • Posts: 22
(No subject)
« Reply #1 on: April 04, 2006, 02:06:28 AM »

modules in some case can made errors, this erros are not supported by Anope Team
Pages: [1]   Go Up