Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: suspected bug in BotServ..  (Read 6751 times)

0 Members and 1 Guest are viewing this topic.

Lion-O

  • Guest
suspected bug in BotServ..
« on: September 18, 2008, 01:36:42 AM »

I have recently encountered a bug in BotServ i think
the description is as follows...
made a change in services.conf -> LogChannel enabled
/msg OperServ restart
services restarted but not all bots came back to their channels,"worry about that later" i thought to myself.
made a change in OperServ -> /msg OperServ SET LOGCHAN ON
then came back to see whay 1 bot didn't come back to his chan
i tried:
1./msg BotServ ASSIGN #לובי Tushikony
Reply from BotServ: Bot Tushikony is already assigned to channel #לובי.
2./msg BotServ UNASSIGN #לובי
Reply from BotServ: There is no bot assigned to #לובי anymore.
1 again with the same reply from BotServ...Doesn't work.
even tried to DEL bot and then ADD the bot to chan - doesn't work.
tried to assign different bot to that channel - doesn't work.
tried to undo changes related to that LogChannel like disabling LogChannel in services.conf + /msg OperServ SET LOGCHAN OFF + restart. - doesn't work.
* tried to get some info...
/msg BotServ help INFO Tushikony
Reply from BotServ: No help available for INFO Tushikony.
there seems to be a trouble with the chan itself BUT i don't want to drop the channel cuz then i'll be forced to set all my old parameters for that channel.
p.s.
i may add that the specified channel is the only chan who had these parameters set through BotServ:
1.PRIVATE -> on
2.GREET -> on
3.FANTASY -> on
finally tried to set something like greet...
Reply from BotServ: Greet mode is now ON on channel #לובי.
final solution:
/hop
made my bot come in to the channel :)
don't know why didn't tried to do this in the first place
well you can delete this topic if you want or you can keep it to enable others that might fall to this situation like i did.
alternatively to show other ANOPE users how to deal with their own "ANOPE bugs"
thank's for helping me :)
Lion-O
Logged

deiks

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 139
  • Shizle my nizle
Re: suspected bug in BotServ..
« Reply #1 on: September 18, 2008, 02:25:04 AM »

* [dx] said lol

If u have more than one ircd in link, try to /squit all of them, and then /connect
TSCTL times seems to not correct,

show us your /TSCTL ALLTIME Reply
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
Re: suspected bug in BotServ..
« Reply #2 on: September 18, 2008, 09:27:58 AM »

This looks to me like some form of desync, which may not be time.

Also, I notice the channel name uses unicode characters, please note that Anope does NOT support unicode characters in channel names or nick names at present.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Lion-O

  • Guest
Re: suspected bug in BotServ..
« Reply #3 on: September 22, 2008, 05:46:25 PM »

Jobe,
if that was the problem i'd be glad :)
just to change the unicode chars and we'r done.
the slutionsolution was far simple than that.
i just did /hop and then the bot come back to the channel
so it wasn't a char unicode problem at-all
just /hop , how simple is that... :)
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
Re: suspected bug in BotServ..
« Reply #4 on: September 22, 2008, 05:53:17 PM »

only more proof there is some sort of desync that cause the problem in the first place though..
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

katsklaw

  • Guest
Re: suspected bug in BotServ..
« Reply #5 on: September 23, 2008, 12:25:32 AM »

Jobe,
if that was the problem i'd be glad :)
just to change the unicode chars and we'r done.
the slutionsolution was far simple than that.
i just did /hop and then the bot come back to the channel
so it wasn't a char unicode problem at-all
just /hop , how simple is that... :)

If you and the bot was the only ones in the channel, then you essentially cured any channel desync because you destroyed and created the channel resetting it's creation TS.
Logged
Pages: [1]   Go Up