Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Problems with InspIRCd 1.1.x  (Read 2358 times)

0 Members and 1 Guest are viewing this topic.

Mike.XIII

  • Guest
Problems with InspIRCd 1.1.x
« on: May 03, 2008, 03:17:14 AM »

The OperServ command UMODE seems to be non functional.
Quote
[May 02 20:43:20 2008] Anope 1.7.21 (1341) (ircd protocol: inspircdIRCd 1.1) starting up
[May 02 20:43:23 2008] os_umode requested unload...
[May 02 20:43:23 2008] debug: trying to load core module [os_umode]
[May 02 20:43:23 2008] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[May 02 20:43:24 2008] Databases loaded

I know it works fine with UnrealIRCd though.

Also it doesn't seem to recognize channel modes m and M in DefConChanModes.
Quote
DefConChanModes "+RM"

Quote
[May 02 20:56:38 2008] DefConChanModes unknown mode character 'M'

It doesn't accept +m and +M, but -m or -M works.
This also worked with UnrealIRCd so I know it's not my configuration.

Is there something in my InspIRCd config file that these depend on?
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #1 on: May 03, 2008, 11:12:48 AM »

os_umode checks whether the ircd supports a umode command..
if it unloads itself that means that it is for some reason disabled in the inspircd protocol module.
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

Mike.XIII

  • Guest
(No subject)
« Reply #2 on: May 03, 2008, 04:23:38 PM »

hmm, that sucks lol
oh well

Thanks for the help anyways.
Logged
Pages: [1]   Go Up