Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: NickServ problem  (Read 8506 times)

0 Members and 1 Guest are viewing this topic.

Tyseah

  • Guest
NickServ problem
« on: March 19, 2006, 12:54:50 PM »

Hello all ^^
I'm sorry if the question has been already asked but a problem annoys me...
Indeed, i would want to set [Nickserv SET KILL ON] as default, that's to say that all users trying to change their nick into a registered nick will be asked to change it(or to identify themselves) within 20sec or their nick will be changed.
Because at the moment, i've to change the option manually with SASET and it's a bit boring so i would want it to be as a "default" option... ^^'
I hope you'll understand ^^

I'm sure the answer is simple but i can't find it !

[Edited on 19-3-2006 by Tyseah]
Logged

Arma

  • Guest
(No subject)
« Reply #1 on: March 19, 2006, 01:40:13 PM »

servus,
myself activated "NSDefKill" and "NSDefKillQuick" on the line 697,698 in the services.conf. But this wont change the kill option for the earlierer accounts. It will set it default on for the new assigned user.

[Edited on 19-3-2006 by Arma]
Logged

Tyseah

  • Guest
(No subject)
« Reply #2 on: March 19, 2006, 03:13:08 PM »

I already deleted the # before NSDefKill and NSDefKillQuick but it doesn't seem to work :/

I tried to register myself under another nickname, and then i changed it, and rechanged it to the registered nick but...nothing... :/
Logged

SkaterStuff

  • Guest
(No subject)
« Reply #3 on: March 19, 2006, 06:45:39 PM »

Quote
Originally posted by Tyseah
I already deleted the # before NSDefKill and NSDefKillQuick but it doesn't seem to work :/

I tried to register myself under another nickname, and then i changed it, and rechanged it to the registered nick but...nothing... :/


Did you rehash or restart services ?  any time you edit the config file you have to restart or rehash. for it to know that you changed anything.
Logged

Tyseah

  • Guest
(No subject)
« Reply #4 on: March 19, 2006, 07:54:14 PM »

Actually, i reload, shutdown, restart, but it doesn't seem to work...
Maybe, i'm doing it the wrong way but i really don't know why it doesn't work :/
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #5 on: March 19, 2006, 08:09:51 PM »

Quote
Originally posted by Tyseah
I already deleted the # before NSDefKill and NSDefKillQuick but it doesn't seem to work :/

I tried to register myself under another nickname, and then i changed it, and rechanged it to the registered nick but...nothing... :/


Try registering, and disconnect reconnect. 1.7 supports nick tracking.
Logged

Tyseah

  • Guest
(No subject)
« Reply #6 on: March 19, 2006, 08:33:53 PM »

I already did that too, because i knew the nick tracking ;)
Thus, i asked a friend to register, to disconnect and then reconnect, without his autoident, but.....just the NickServ message, without "If you do not change within one minute, I will change your nick."

It's so weird :/
Logged

ShelLuser

  • Guest
(No subject)
« Reply #7 on: March 19, 2006, 08:47:15 PM »

Quote
Originally posted by Tyseah
I already did that too, because i knew the nick tracking ;)

Just in case, could you try "/msg nickserv info <nick> all" for the specific newly registered nickname and at least paste the "Options" line ?
Logged

Tyseah

  • Guest
(No subject)
« Reply #8 on: March 19, 2006, 09:11:46 PM »

Options: Protection, Security, Private

>>> 5mins ago, a friend of mine tested it, and it doesn't work :/
Logged

Dave Robson

  • Team
  • *
  • Offline Offline
  • Posts: 357
(No subject)
« Reply #9 on: March 20, 2006, 08:09:44 AM »

the problem is you have the host on the nick access list.   /msg nickserv help access
Logged

Tyseah

  • Guest
(No subject)
« Reply #10 on: March 20, 2006, 01:14:08 PM »

I deleted the host that was present in the access list and it seems to work. But will my users have to do it when they will register themselves to NickServ ?*
That is to say, will they have to write : "/msg NickServ access DEL ..." when they will register ?

EDIT : WooW, i just added # before NSAddAccessOnReg and now it seems to work very well ! At last ! Thank you very much guys for your help ! ;)

[Edited on 20-3-2006 by Tyseah]
Logged
Pages: [1]   Go Up