Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Setting up Anope 1.7  (Read 5486 times)

0 Members and 1 Guest are viewing this topic.

Blake81

  • Anope User
  • Offline Offline
  • Posts: 22
Setting up Anope 1.7
« on: March 17, 2006, 02:56:54 AM »

I'm using Anope 1.7.13 with Unreal IRCD and this is my first time, and I'm having some problems setting it up.  When I run Anope, I get this notice in my status window in mIRC:
*** LocOps -- Link denied for services.braab.myftp.org(unknown@192.168.1.97) (No link block named 'services.braab.myftp.org') [@192.168.1.97.1392]

It's odd that the last IP there has too many octets.  I've noticed in netstat that some of my connections are on ports arount that 1200 or 1300 number, so maybe it's putting a port into the IP somewhere.

I'm not really sure whether this is originating from Anope or Unreal.  I would really appreciate any help in setting this up.  Thanks.

[Edited on 17-3-2006 by Blake81]
Logged

Spy

  • Guest
(No subject)
« Reply #1 on: March 17, 2006, 07:03:30 AM »

You should set up a link block in the unrealircd.conf. It will look like:
Code: [Select]

link services.braab.myftp.org {
username *;
hostname 192.168.1.97;
bind-ip *;
<other options here>
};
Logged

Blake81

  • Anope User
  • Offline Offline
  • Posts: 22
(No subject)
« Reply #2 on: March 17, 2006, 02:26:32 PM »

I have two link blocks.  I'm not sure if I need them both, but I have two now.  I changed mine to look like yours.  I had previously put my local network IP in as the bind IP, but I just changed it to *;.  I'm not getting that error in the status window anymore, but it is still saying that services are down.  Here are the two blocks.  Does it matter where I have them in the config file?  Thanks.

link services.braab.myftp.org
  {
   username   *;
    hostname   192.168.1.97;
   bind-ip      *;
};
link braab.myftp.org {
username   *;
hostname   192.168.1.97;
bind-ip   *;
};

Forget what I said, I forgot to run Anope again.  I'm still getting that same notice in the status window:

-braab.myftp.org- *** LocOps -- Link denied for services.braab.myftp.org(unknown@192.168.1.97) (No link block named 'services.braab.myftp.org') [@192.168.1.97.1884]
-

[Edited on 17-3-2006 by Blake81]
Logged

Spy

  • Guest
(No subject)
« Reply #3 on: March 17, 2006, 02:43:30 PM »

1. I`m not sure if there is any difference from where your link block is, I was setting up my config just like it is in the example conf, so I suggest you to follow that too.
2. Have you rehashed the server after you updated your unrealircd.conf?
Logged

Blake81

  • Anope User
  • Offline Offline
  • Posts: 22
(No subject)
« Reply #4 on: March 17, 2006, 03:32:15 PM »

I got it working.  I'm still not sure what the problem was,  but I used a wildcard for the bind IP this time.  Thanks for all your help. :)
Logged
Pages: [1]   Go Up