Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Anope 1.7.18 + MySQL 5.0.37 won't work together  (Read 5685 times)

0 Members and 1 Guest are viewing this topic.

bawalker

  • Guest
Anope 1.7.18 + MySQL 5.0.37 won't work together
« on: May 11, 2007, 12:40:15 AM »

Hello all,

I have been using Anope services before and am familiar with it.  So when I went to setup a new IRC server with services, I decided to use UnrealIRCD 3.2.6 and Anope 1.7.18.  I created separate accounts for each service and downloaded the Anope source.  From there I extracted and ran the ./Config command.  I answered the questions as honestly as possible and at the end of the ./Config command... it says:

Modules:  Yes
MySQL:  No

I take it that means it's not recognizing I have MySQL server binaries installed?  I have the standard server, devel, and other essential MySQL RPM's installed on this CentOS 3.8 box.

Anyway I proceeded forward and make and make install on the source so that I now had an installed /home/ircd/anope/services folder.  I immediately then went to my MySQL server and created the appropriate database/user/password for anope.   I then immediately imported the tables.sql file to ensure that the table structure of the database was setup like it should be.

From this point I then went to the ../data directory and ran the ./mydbgen file to get all of the appropriate information setup.  After all of this was done, I copied my services.conf file to my folder which was pre-setup to make sure it has the correct values/information.  I startup services and register a new nick and everything connects to the IRCd GREAT.

However when I register a new nick and then go back into the database to check... nothing is there.  Only ONE table has info in it and that is the "anope_info" table.  

Am I missing something here?  Have I screwed something up?!?!

Help!!

Brad
Logged

katsklaw

  • Guest
(No subject)
« Reply #1 on: May 11, 2007, 02:15:46 AM »

you need to install the mysql-devel package then recompile Anope.
Logged

bawalker

  • Guest
(No subject)
« Reply #2 on: May 11, 2007, 02:27:59 AM »

I already have the mysql-devel package and it shows the mysql_compat already installed in /usr/bin.



Quote
Originally posted by katsklaw
you need to install the mysql-devel package then recompile Anope.
Logged

bawalker

  • Guest
(No subject)
« Reply #3 on: May 11, 2007, 02:28:14 AM »

*removed* - Double post

[Edited on 10-5-2007 by bawalker]
Logged

SNU

  • Anope User
  • Offline Offline
  • Posts: 158
    • http://www.firstclassirc.com
(No subject)
« Reply #4 on: May 11, 2007, 09:20:04 AM »

make sure you have the correct mysql-client -devs ind debian they're called libmysqlclient4-dev maybe centos also has such packages. try "yum install apt" and then "apt-get update" then "apt-cache search libmysql | grep dev" ... maybe you'll find something
Logged

Armadillo

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 72
    • http://www.penguinfriends.org
(No subject)
« Reply #5 on: May 15, 2007, 10:03:33 PM »

The MySQL-Suport of the Anopes 1.7.x is very buggy. I had several hard problems during the last weeks, until I disabled it although i need it.:(
It often crashes the services, so think about this, before you use it ;)
Logged
IRC-Network: irc.PenguinFriends.org | Website: www.PenguinFriends.org
Anope: 1.9.9 | InspIRCd: 2.0

katsklaw

  • Guest
(No subject)
« Reply #6 on: May 16, 2007, 01:29:21 PM »

Quote
Originally posted by Armadillo
The MySQL-Suport of the Anopes 1.7.x is very buggy. I had several hard problems during the last weeks, until I disabled it although i need it.:(
It often crashes the services, so think about this, before you use it ;)


The 1.7 branch is the Development branch, which means it's likely to be buggy. This is a normal part of the development process, so if you can't handle the bugs then use the stable 1.6 branch.
Logged
Pages: [1]   Go Up