Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Anope 1.7.18 + MySQL + USERDB => Segfault  (Read 3172 times)

0 Members and 1 Guest are viewing this topic.

Sw1fty

  • Guest
Anope 1.7.18 + MySQL + USERDB => Segfault
« on: April 08, 2007, 07:38:14 PM »

Hi

we installed Anope a few days ago and everything was fine ... until this morning ...

We installed the new version of the module bs_fantasieext and a few hours later we saw that the services have delinked with the message:
No response from services.PenguinFriends.org[127.0.0.1], closing link

but the services are still in ps -ux.

So we killed them and tried to start them but from now on ... the only produced segfaults like:
[Apr 08 20:28:55.933908 2007] debug: MySQL: SELECT nm_id, number, flags, time, sender, text FROM anope_ms_info WHERE receiver = 'caytchen' AND active = 1 AND serv = 'NICK' ORDER BY number ASC
./anoperc: line 141: 10094 Segmentation fault      $ANOPROG $*

And in /var/log/messages

Apr  8 20:35:42 Sid kernel: services[10505]: segfault at 0000000000000033 rip 00002aaaaadfa7b7 rsp 00007fffffd90480 error 4

So we tried to start without USERDB and everything is fine but all databases are lost. And everytime we try to load with USERDB the only thing we get are segfaults. So what to do?
We recompiled the hole services with completly fresh sources and still segfaults ...

Greetz

Sw1fty
Logged
Pages: [1]   Go Up