Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: weird segfault on chanserv  (Read 7101 times)

0 Members and 1 Guest are viewing this topic.

thepitster

  • Guest
weird segfault on chanserv
« on: March 09, 2006, 12:18:51 AM »

ok first heres the log:
Mar 08 12:21:24 2006] OperServ: SBrown: help
[Mar 08 12:21:38 2006] OperServ: Seji: help
[Mar 08 12:22:21 2006] OperServ: SBrown: staff
[Mar 08 12:27:30 2006] PANIC! buffer = :Seji PRIVMSG ChanServ@Services.allripped.net :listall
[Mar 08 12:27:30 2006] PANIC! buffer = :Seji PRIVMSG ChanServ@Services.allripped.net :listall
[Mar 08 12:27:30 2006] PANIC! buffer = :Seji PRIVMSG ChanServ@Services.allripped.net :listall
[Mar 08 12:27:30 2006] PANIC! buffer = :Seji PRIVMSG ChanServ@Services.allripped.net :listall
[Mar 08 12:27:30 2006] PANIC! buffer = :Seji PRIVMSG ChanServ@Services.allripped.net :listall

about a few hundred lines of this then the end of it is this:

[Mar 08 12:27:30 2006] Backtrace: Segmentation fault detected
[Mar 08 12:27:30 2006] Backtrace: report the following lines
[Mar 08 12:27:30 2006] Backtrace: Anope version 1.7.13 (951) build #1, compiled Jan  6 2006 01:32:27  TM
[Mar 08 12:27:31 2006] Backtrace(1): ./services(sighandler+0x14a) [0x806d57a]
[Mar 08 12:27:31 2006] Backtrace(2): /lib/libpthread.so.0 [0x4005a715]
[Mar 08 12:27:31 2006] Backtrace(3): /lib/libc.so.6 [0x400c8cb8]
[Mar 08 12:27:31 2006] Backtrace(4): ./services(destroyModule+0x2a) [0x807159a]
[Mar 08 12:27:31 2006] Backtrace(5): ./services(delModule+0x88) [0x8071778]
[Mar 08 12:27:31 2006] Backtrace(6): ./services(modules_unload_all+0xec) [0x80714ac]
[Mar 08 12:27:31 2006] Backtrace(7): ./services(sighandler+0x1db) [0x806d60b]
[Mar 08 12:27:31 2006] Backtrace(8): /lib/libpthread.so.0 [0x4005a715]
[Mar 08 12:27:31 2006] Backtrace(9): /lib/libc.so.6 [0x400c8cb8]
[Mar 08 12:27:31 2006] Backtrace: complete
[Mar 08 12:27:31 2006] Services terminating: Segmentation fault

the oper seji said he has done this command:

msg wwww({h> 0" X
%Hx(H=+-:Seji PRIVMSG ChanServ@Services.allripped.net :listall HELP LEVELS DESC

any one have any idea wot happened here?
Logged

Trystan Scott Lee

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 343
(No subject)
« Reply #1 on: March 09, 2006, 01:54:45 AM »

1. What modules do you have loaded?
2. Is the box a x64 install?
3. Is this reproducable? if so

gdb services
run -nofork -debug
crash services
type bt
paste results here
Logged
my God my tourniquet, return to me salvation

thepitster

  • Guest
(No subject)
« Reply #2 on: March 09, 2006, 08:05:11 PM »

modules loaded are:
bs_seen
bs_moremodesperline
cs_appendtopic
cs_listall
cs_statusupdate
hs_request_fant
ircd_gameserv
ircd_loveserv
ns_regnick
ns_glist
os_svsjoinpart
os_notinchanlist
os_svskill
os_sysuptime
os_notidlist
os_staychan
os_superadminpass
os_rawservicesrootonly
os_mkill
os_logbot
os_debug
os_routing
os_forceid
os_eventmsg
profileserv
ultimate3

no its not a x64 machine and i have tried to reproduce this error along with seji and nothing happened
Logged

Dave Robson

  • Team
  • *
  • Offline Offline
  • Posts: 357
(No subject)
« Reply #3 on: March 10, 2006, 08:18:15 AM »

The only place i've seen this (almost exact) error is on a AMD 64 box, the solution is to update to the latest SVN version, we have it fixed on there - while this isnt a 64 bit box, if you do get it again or manage to be able to reproduce it any way, can you try the SVN version? :)
Logged

thepitster

  • Guest
(No subject)
« Reply #4 on: April 01, 2006, 09:53:50 PM »

ok heres another thing almost the same i think:

[Apr 01 04:11:48 2006] PANIC! buffer = :speedracer PRIVMSG #speedracin :!op pit-bot
[Apr 01 04:11:48 2006] PANIC! buffer = :speedracer PRIVMSG #speedracin :!op pit-bot
[Apr 01 04:11:48 2006] PANIC! buffer = :speedracer PRIVMSG #speedracin :!op pit-bot
[Apr 01 04:11:48 2006] PANIC! buffer = :speedracer PRIVMSG #speedracin :!op pit-bot
[Apr 01 04:11:48 2006] PANIC! buffer = :speedracer PRIVMSG #speedracin :!op pit-bot
[Apr 01 04:11:48 2006] PANIC! buffer = :speedracer PRIVMSG #speedracin :!op pit-bot
[Apr 01 04:11:48 2006] PANIC! buffer = :speedracer PRIVMSG #speedracin :!op pit-bot
[Apr 01 04:11:48 2006] Backtrace: Segmentation fault detected
[Apr 01 04:11:48 2006] Backtrace: report the following lines
[Apr 01 04:11:48 2006] Backtrace: Anope version 1.7.14 (1023) build #1, compiled Mar 28 2006 21:56:27  TM
[Apr 01 04:11:48 2006] Backtrace(1): ./services(sighandler+0x14a) [0x806d8ca]
[Apr 01 04:11:48 2006] Backtrace(2): /lib/libpthread.so.0 [0x4005a715]
[Apr 01 04:11:48 2006] Backtrace(3): /lib/libc.so.6 [0x400c8cb8]
[Apr 01 04:11:48 2006] Backtrace(4): ./services(destroyModule+0x2a) [0x80719ea]
[Apr 01 04:11:48 2006] Backtrace(5): ./services(delModule+0x88) [0x8071bc8]
[Apr 01 04:11:48 2006] Backtrace(6): ./services(modules_unload_all+0xec) [0x80718fc]
[Apr 01 04:11:48 2006] Backtrace(7): ./services(sighandler+0x1db) [0x806d95b]
[Apr 01 04:11:48 2006] Backtrace(8): /lib/libpthread.so.0 [0x4005a715]
[Apr 01 04:11:48 2006] Backtrace(9): /lib/libc.so.6 [0x400c8cb8]
[Apr 01 04:11:48 2006] Backtrace: complete
[Apr 01 04:11:48 2006] Services terminating: Segmentation fault

[Apr 01 04:15:54 2006] PANIC! buffer = :speedracer PRIVMSG #speedracin :!op pit-bot
[Apr 01 04:15:54 2006] PANIC! buffer = :speedracer PRIVMSG #speedracin :!op pit-bot
[Apr 01 04:15:54 2006] PANIC! buffer = :speedracer PRIVMSG #speedracin :!op pit-bot
[Apr 01 04:15:54 2006] PANIC! buffer = :speedracer PRIVMSG #speedracin :!op pit-bot
[Apr 01 04:15:54 2006] PANIC! buffer = :speedracer PRIVMSG #speedracin :!op pit-bot
[Apr 01 04:15:54 2006] PANIC! buffer = :speedracer PRIVMSG #speedracin :!op pit-bot
[Apr 01 04:15:54 2006] PANIC! buffer = :speedracer PRIVMSG #speedracin :!op pit-bot
[Apr 01 04:15:54 2006] Backtrace: Segmentation fault detected
[Apr 01 04:15:54 2006] Backtrace: report the following lines
[Apr 01 04:15:54 2006] Backtrace: Anope version 1.7.14 (1023) build #1, compiled Mar 28 2006 21:56:27  TM
[Apr 01 04:15:54 2006] Backtrace(1): ./services(sighandler+0x14a) [0x806d8ca]
[Apr 01 04:15:54 2006] Backtrace(2): /lib/libpthread.so.0 [0x4005a715]
[Apr 01 04:15:54 2006] Backtrace(3): /lib/libc.so.6 [0x400c8cb8]
[Apr 01 04:15:54 2006] Backtrace(4): ./services(destroyModule+0x2a) [0x80719ea]
[Apr 01 04:15:54 2006] Backtrace(5): ./services(delModule+0x88) [0x8071bc8]
[Apr 01 04:15:54 2006] Backtrace(6): ./services(modules_unload_all+0xec) [0x80718fc]
[Apr 01 04:15:54 2006] Backtrace(7): ./services(sighandler+0x1db) [0x806d95b]
[Apr 01 04:15:54 2006] Backtrace(8): /lib/libpthread.so.0 [0x4005a715]
[Apr 01 04:15:54 2006] Backtrace(9): /lib/libc.so.6 [0x400c8cb8]
[Apr 01 04:15:54 2006] Backtrace: complete
[Apr 01 04:15:54 2006] Services terminating: Segmentation fault

this happen back to back about an hour apart

this was using Anope-1.7.14 (1023)

[Edited on 1-4-2006 by thepitster]
Logged

Dave Robson

  • Team
  • *
  • Offline Offline
  • Posts: 357
(No subject)
« Reply #5 on: April 01, 2006, 11:14:55 PM »

does this still happen if you unload all those extra modules?
Logged

thepitster

  • Guest
(No subject)
« Reply #6 on: April 02, 2006, 01:36:34 AM »

yes it does seem to still do it, give me a few and ill test it all out to be sure

[Edited on 2-4-2006 by thepitster]
Logged

thepitster

  • Guest
(No subject)
« Reply #7 on: April 02, 2006, 02:50:08 AM »

ok found the issue its was a module called bs_moremodesperline.c this is a useful module on my network though, sure hate to lose it

[Edited on 2-4-2006 by thepitster]
Logged
Pages: [1]   Go Up