Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Need help with starting Anope  (Read 4724 times)

0 Members and 1 Guest are viewing this topic.

Fussi

  • Guest
Need help with starting Anope
« on: March 07, 2006, 06:22:48 PM »

I got almost everything working for my small irc server, but not the services. They still wont connect somehow.

The point is, there isnt ANY error message, he just quits o_O
Here's the logfile:

Quote

[Mar 07 19:13:44 2006] Loading IRCD Protocol Module: [inspircd]
[Mar 07 19:13:44 2006] status:
[Mar 07 19:13:44 2006] Anope 1.7.13 (951) (ircd protocol: inspircdIRCd Beta 6+) starting up
[Mar 07 19:13:45 2006] ns_sendpass requested unload...
[Mar 07 19:13:45 2006] debug: trying to load core module [ns_sendpass]
[Mar 07 19:13:45 2006] debug: status: [6]
[Mar 07 19:13:45 2006] ns_getpass requested unload...
[Mar 07 19:13:45 2006] debug: trying to load core module [ns_getpass]
[Mar 07 19:13:45 2006] debug: status: [6]
[Mar 07 19:13:45 2006] cs_sendpass requested unload...
[Mar 07 19:13:45 2006] debug: trying to load core module [cs_sendpass]
[Mar 07 19:13:45 2006] debug: status: [6]
[Mar 07 19:13:45 2006] ms_rsend requested unload...
[Mar 07 19:13:45 2006] debug: trying to load core module [ms_rsend]
[Mar 07 19:13:45 2006] debug: status: [6]
[Mar 07 19:13:46 2006] os_umode requested unload...
[Mar 07 19:13:46 2006] debug: trying to load core module [os_umode]
[Mar 07 19:13:46 2006] debug: status: [6]
[Mar 07 19:13:46 2006] MySQL: has been enabled.
[Mar 07 19:13:46 2006] MySQL: client version 4.0.15.
[Mar 07 19:13:46 2006] RDB: All DataBases loaded.
[Mar 07 19:13:46 2006] Databases loaded
[Mar 07 19:13:46 2006] Info: Not reflecting database records.
[Mar 07 19:13:46 2006] Connected to Server 1 (81.169.180.xx:xxxx)
[Mar 07 19:13:46 2006] trying to load [cs_appendtopic]
[Mar 07 19:13:46 2006] [cs_appendtopic] Loaded succesfully
[Mar 07 19:13:46 2006] status:
[Mar 07 19:13:46 2006] trying to load [cs_enforce]
[Mar 07 19:13:46 2006] status:
[Mar 07 19:13:46 2006] trying to load [ns_maxemail]
[Mar 07 19:13:46 2006] status:
[Mar 07 19:13:46 2006] trying to load [ns_noop]
[Mar 07 19:13:46 2006] ns_noop: Loading configuration directives
[Mar 07 19:13:46 2006] ns_noop: Directive NSAutoOPDBName loaded (autoop.db)...
[Mar 07 19:13:46 2006] status:
[Mar 07 19:13:46 2006] trying to load [os_info]
[Mar 07 19:13:46 2006] os_info: Loading configuration directives...
[Mar 07 19:13:46 2006] os_info: Directive OSInfoDBName loaded (os_info.db)...
[Mar 07 19:13:46 2006] status:
[Mar 07 19:13:46 2006] trying to load [hs_request]
[Mar 07 19:13:46 2006] hs_request loaded
[Mar 07 19:13:46 2006] status:
[Mar 07 19:13:46 2006] Read error from server: Success (error num: 0)
[Mar 07 19:13:46 2006] [cs_appendtopic] Unloaded succefully
[Mar 07 19:13:46 2006] hs_request un-loaded



Any idea?
Logged

ShelLuser

  • Guest
(No subject)
« Reply #1 on: March 07, 2006, 09:47:26 PM »

Quote
Originally posted by Fussi
[Mar 07 19:13:46 2006] status:
[Mar 07 19:13:46 2006] Read error from server: Success (error num: 0)
[Mar 07 19:13:46 2006] [cs_appendtopic] Unloaded succefully
[Mar 07 19:13:46 2006] hs_request un-loaded

Its impossible to determine the cause of the problem, but my guess is that you have to reconfigure your ircd. Better check its logfiles to see what it says about this connection. Make sure you have everything setup to authorize the connection.
Logged

Fussi

  • Guest
(No subject)
« Reply #2 on: March 08, 2006, 09:47:25 AM »

Is there any known problem with InspIRCd 1.0.2 and Anope 1.7.x ?
And shall i use the module shipped with Anope, or the module provided by InspIRCd?
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #3 on: March 08, 2006, 01:17:44 PM »

Use the one supplied with inspircd, and I have Inspircd 1.0.2 working with anope 1.7.13 (rev 951).
Logged
Pages: [1]   Go Up