Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Compiling Anope  (Read 4312 times)

0 Members and 1 Guest are viewing this topic.

Jason

  • Anope User
  • Offline Offline
  • Posts: 1
Compiling Anope
« on: September 27, 2012, 01:42:21 AM »

I recently just switched to a new dedicated server (going from CentOS to Ubuntu) and trying to get Anope installed onto the new server. But I keep encountering a few errors on the last bit of the configuration.

When Anope prompts me to enter make or gmake. I get the following error:

Code: [Select]
All done!  Now run "make" (or possibly "gmake") to compile Anope.
See the INSTALL, README and FAQ files if you have any problems.
~/anope-1.7.8$ make
(cd lang ; make 'CFLAGS=-pipe -g -O2 -pthread -export-dynamic' 'CC=gcc' 'ANOPELIBS=-lnsl   -l                                        dl' 'LDFLAGS=' 'BINDEST=/home/irc/services' 'INSTALL=/usr/bin/install' 'INCLUDEDIR=../include                                        ' 'RM=/bin/rm' 'CP=/bin/cp' 'TOUCH=/usr/bin/touch' 'SHELL=/bin/sh' 'DATDEST=/home/irc/service                                        s' 'RUNGROUP=' 'MODULE_PATH=/home/irc/services/modules/' 'RDB=' 'MYSQL=' 'IRCDFILE=unreal31.c                                         ' all language.h ; cp language.h ../include/)
make[1]: Entering directory `/home/irc/anope-1.7.8/lang'
gcc -pipe -g -O2 -pthread -export-dynamic langcomp.c -o langcomp
langcomp.c:118:7: error: conflicting types for âgetlineâ
/usr/include/stdio.h:675:20: note: previous declaration of âgetlineâ was here
make[1]: *** [langcomp] Error 1
make[1]: Leaving directory `/home/irc/anope-1.7.8/lang'
cp: cannot stat `language.h': No such file or directory
make: *** [language] Error 1


I'm running Unreal3.2.9. I also noticed Anope is asking me to select which version of IRC during configuration which never did this on CentOS.

Any advice or suggestions to what's wrong would be grateful.
Logged

katsklaw

  • Supporter
  • Anope User
  • Offline Offline
  • Posts: 537
Re: Compiling Anope
« Reply #1 on: September 27, 2012, 02:18:11 AM »

Anope 1.7.8 is no longer supported. Try downloading the latest stable version from http://anope.org
Logged
Pages: [1]   Go Up