Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Anope Would not Link with Unreal  (Read 515 times)

0 Members and 1 Guest are viewing this topic.

Rene

  • Anope User
  • Offline Offline
  • Posts: 2
Anope Would not Link with Unreal
« on: October 19, 2022, 12:40:30 AM »

Sorry if I'm wrong here but I can't anope with my unrealircd link. He always says this:
Quote
[Oct 18 23:22:57 2022] Lost connection from uplink #1 (xx.xxx.xxx.xx:6000)
[Oct 18 23:22:57 2022] Check that you are not connecting Anope to an SSL enabled port without configuring SSL in Anope (or vice versa)

This is the link block etc. that something is wrong but I just can't find anything? maybe you can help me there? I don't have SSL enabled on this port.

Quote
Both Config Parts located on diferent machines

Unrealircd.conf part Link block and ulines: (Unrealircd Windows Server)
Code: [Select]
link services.igamerpg.de {
    incoming {
        mask *;
    };
    outgoing {
        bind-ip *; /* or explicitly an IP if you have a shell provider, as mentioned in step 1 */
        hostname xx.xxx.xxx.xx; /*  or if 'beta.test.net' does not exist then you can use an IP or something like 'beta.dyndns.org' */
        port 6000; /* the special SSL server port we opened up earlier */
        options { };
    };
    password "xxxxx";
    class servers;
};

/* U-lines give other servers (even) more power/commands.
 * If you use services you must add them here.
 * NEVER put the name of an UnrealIRCd server here!!!
 */
ulines {
services.igamerpg.de;
}


Services.conf section uplink (Ubuntu VM in Virtualbox):
Code: [Select]
uplink
{
/*
* The IP or hostname of the IRC server you wish to connect Services to.
* Usually, you will want to connect Services over 127.0.0.1 (aka localhost).
*
* NOTE: On some shell providers, this will not be an option.
*/
host = "xx.xxx.xxx.xx"

/*
* Enable if Services should connect using IPv6.
*/
ipv6 = no

/*
* Enable if Services should connect using SSL.
* You must have an SSL module loaded for this to work.
*/
ssl = no

/*
* The port to connect to.
* The IRCd *MUST* be configured to listen on this port, and to accept
* server connections.
*
* Refer to your IRCd documentation for how this is to be done.
*/
port = 6000

/*
* The password to send to the IRC server for authentication.
* This must match the link block on your IRCd.
*
* Refer to your IRCd documentation for more information on link blocks.
*/
password = "xxxx"
}

So what's wrong with it?
Thanks for help!

« Last Edit: October 19, 2022, 02:45:01 AM by Rene »
Logged

Maltesers

  • Anope User
  • Offline Offline
  • Posts: 2
Re: Anope Would not Link with Unreal
« Reply #1 on: October 23, 2022, 05:53:20 PM »

Hi Rene

How does your listen block for servers look like in unrealircd.conf? It should look similar like

Code: [Select]
listen {
ip 127.0.0.1; //or any other ip
port 6000;
options { serversonly; }
}

check there if you possibly have set tls in the options directive and remove it if it exists, because you have set SSL to no in services.conf.


Wthout knowing exactly how your network setup looks like, you can also try to remove

Code: [Select]
    outgoing {
        bind-ip *; /* or explicitly an IP if you have a shell provider, as mentioned in step 1 */
        hostname xx.xxx.xxx.xx; /*  or if 'beta.test.net' does not exist then you can use an IP or something like 'beta.dyndns.org' */
        port 6000; /* the special SSL server port we opened up earlier */
        options { };
    };

from link services.igamerpg.de
Logged
Pages: [1]   Go Up