Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  


Pages: [1] 2 3 ... 10
 on: June 26, 2024, 04:38:49 AM 
Started by Marisa Giancarla - Last post by Chris P
When trying to start it I get this error:
[May 26 19:34:58 2024] modules/ cannot open shared object file: No such file or directory

I have tried running ./Config and make etc several times but that file still doesn't get created...

Any help?

did you try the
cd build
make install

 on: June 24, 2024, 05:35:00 PM 
Started by CrazyCat - Last post by CrazyCat
Ok, the solution was smtputf8_enable = no in my postfix.

Thanks @PeGaSuS and @Sadie, you gave me new search ideas :)

 on: June 24, 2024, 04:16:20 PM 
Started by CrazyCat - Last post by CrazyCat
Well, my postfix works fine, it's the receiver which seems to dislike my email when subject has accentued chars.
I'll have a deeper look in postfix (sendmail is just the mailutils tool to enable sendmail with postfix)

I tried adding smtputf8_enable = yes in postfix (works) but the dest servers hates me:
2024-06-24T17:36:31.289265+02:00 myserver postfix/smtp[1588328]: C96862AC1C5B: to=<>,[]:25, delay=6.5, delays=0.46/0.31/5.8/0, dsn=5.6.7, status=bounced (SMTPUTF8 is required, but was not offered by host[])

Seems like ovh dislikes utf8

 on: June 24, 2024, 12:58:22 PM 
Started by CrazyCat - Last post by PeGaSuS

So far, I had zero issues with msmtp and accented emails.

My resetpass email has as subject the following:
Code: [Select]
reset_subject = "Reposição de palavra-passe | Password reset request"
The command file -bi anope.conf states:
Code: [Select]
text/x-c; charset=utf-8
The only thing I'm doing different (I think) with msmtp is that I'm sending the email through my mail server which is located on another machine (powered by postfix, though), basically acting as a relay but you can also install the msmtp-mta if you want/need.

Here's an example of how my .msmtprc looks like:
Code: [Select]
# Set default values for all following accounts.
auth           on
tls            on
#tls_trust_file /etc/ssl/certs/ca-certificates.crt
logfile        ~/.msmtp.log

account        example
host           mail.domain.tld
port           465
tls_starttls   off
from           "Example User <example@domain.tld>"
user           example@domain.tld
password       example_password

account default: example

I've also attached a screenshot that shows that accents are received properly (the code received is already invalidated).

NOTE: All configs are from an Ubuntu powered system.

 on: June 24, 2024, 12:25:23 PM 
Started by CrazyCat - Last post by CrazyCat
Small edit:
Code: [Select]
crazycat@server:~/services/conf$ file -bi services.conf
text/x-c; charset=utf-8

 on: June 23, 2024, 11:07:56 PM 
Started by CrazyCat - Last post by CrazyCat
My services.conf is utf-8, I use postfix (on localhost) with mailutils to get the sendmail.
Here is my myfile.txt (utf-8 / CRLF)
Subject: Nouveau mémo
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Merci de valider la réception de ce message.
Normalement ça le fait
Works using /usr/sbin/sendmail -t < myfile.txt

If I use Nouveau mémo in memo_subject (services.conf) I got the error. But If I use Nouveau memo (without accent) I don't have any trouble.
Not that having accentued chars in the body doesn't break the process.

I'll try making more tests (apply iconv to my .conf ?) but the only difference I actually can see is that the mail subjects are treated in another way than the bodies.

 on: June 23, 2024, 09:10:25 PM 
Started by CrazyCat - Last post by Sadie
We're applying a UTF-8 header to the emails so they *should* be sent properly.

Are you sure you're using UTF-8 for your emails not an older encoding like ISO-8859-1?

What email provider are you using? Also, what sendmail client are you using?

 on: June 23, 2024, 03:51:29 PM 
Started by CrazyCat - Last post by CrazyCat

I've tried to translate in french emails sent by anope and noticed that when the subject contains accentued chars, I got (from dest server) "SMTPUTF8 is required, but was not offered by host" when mail is sent.
But when the subject doesn't contains them and the body yes, it works like a charm.

I did a test, creating a file and using sendmail -t < myfile.txt, it works.

So I think there is a little trouble somewhere between and which transform the subject (my tests were with memo_subject) in an improper utf-8 string

 on: June 18, 2024, 05:05:51 PM 
Started by CrazyCat - Last post by CrazyCat
I'm with anope-2.0.15 working on Debian 12

 on: June 18, 2024, 02:35:18 PM 
Started by CrazyCat - Last post by Sadie
What version of Anope are you using?

Pages: [1] 2 3 ... 10