Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1] 2 3 ... 10
 1 
 on: April 11, 2018, 07:49:07 PM 
Started by peter vd linden - Last post by peter vd linden
1129/5000
Hello all
first of all I want to apologize for any faulty English.
however, I scratched this in Dutch and translated it into English with google translate.
this because I am very busy writing in English.
reading generally wants me to succeed.

let me first say what I have done.
i have anope services 2.0.6 running on a 64 bit debian linux 9 server.
the irc server is unrealircd.
everything is working well.
however, I would like to see some things differently.
that's why I have 2 questions.
1: How do I ensure that anope service uses a mysql database?
2 I can state that with the comandows / msg NickServ REGISTER zig can not be controlled
3 can I use the passwords in md5 encripty when using mysql by anope in the table where the existing user acounts are located?
4: can it be asserted that people who do not zigzify within eg 3 minutes with / msg NIckServ IDENTIFY automatsies are kicked or have regrets that they can only read in chats and private chats and can not post anything themselves?

hopefully someone can help me with these things
greetings: Peter

 2 
 on: April 08, 2018, 07:44:29 AM 
Started by Hasbullah Masby - Last post by Hasbullah Masby
why can not I enable hostserv user when I have ircop with netadmin operclass
error messeg -HostServ- Password authentication required for that command.

 3 
 on: April 01, 2018, 03:58:46 PM 
Started by ekym - Last post by ekym
Thanks for the tips, I seam to have sorted this out now. Everything appears to work as intended. I guess the link in services.conf and links.conf needs to be the same, just not the same as your ircd.

 4 
 on: April 01, 2018, 01:55:38 PM 
Started by ekym - Last post by genius3000
I would recommend trying with Anope's 'serverinfo->name' set to "services.SyFyDesigns.com" and ensuring your InspIRCd '<link>' tag has the matching name. Then rehash InspIRCd and try starting Anope again. If it fails again, maybe try `./services -support` to see if Anope's debug can give more clues. You definitely don't want Anope's server name to match that of the IRCd, but having the Network names match is a good idea.

 5 
 on: April 01, 2018, 01:36:27 PM 
Started by Barack Obama - Last post by genius3000
Unfortunately Anope does not have this feature, but there is a 3rd party module to add it. More information on 3rd party modules is available on the Anope Modules help page.

 6 
 on: April 01, 2018, 06:22:20 AM 
Started by ekym - Last post by ekym
I can't seem to figure out how to solve this catch 22 with the config's

Installed the latest inspircd 2.0.25 together with the current anope services 2.0.6 and I have tried about everything I can come up with the get this services running without error's.

When I match my server name the error is ERROR: Server SyFyDesigns.com already exists on server <ourself>!
When I substitute anything else the error is  ERROR: Mismatched server name or password (check the other server's snomask output for details - e.g. umode +s +Ll)

Since this has been solved, the pastebin is now only available upon request.

pastebin organized as follows

[inspircd.conf]
[services.conf]
[links.conf]
[additional info]

The server runs, and the services do start, I just get the error's and it stops logging in to the services as is.

Thanks for any help

myke

 7 
 on: March 15, 2018, 12:10:52 AM 
Started by Luc Mccarragher - Last post by Luc Mccarragher
I got a problem it's intermitant , Never append before
on the main irc server (INSPIRCD Latest) no problem
on the links Server problem occur intermitantly , Server do not reconize the Service
My Second Server have the same Configuration as the main one Except the Name / node
I restartall server it Go fine , some time restart all computer Rarely
my link to anope is not Secure , its local computer , i suspect a memory link , but just suspect !!!



 8 
 on: March 11, 2018, 04:51:24 PM 
Started by Abner - Last post by The Myth Lives
 vIdent is the ident@vhost part, and seems that Hybrid doesn't support it. So, it's just
Code: [Select]
/hostserv set NICK vhost
That way you'll only set the @vhost part and done.
Don't complain about Anope in this case. Complain to the IRCd makers.  ;D

 9 
 on: March 11, 2018, 08:40:25 AM 
Started by taotao - Last post by taotao
I used Unrealircd4 and anope 2.0.6.
the ircd already support chinese nick to login, all is work fine.
but when use "/msg nickserv register password mail" to register this nick, service told me: "Nickname 一二三 may not be registered."
and i can let it to work normaly with services.conf and set the nick_char.
How can i do it?

 10 
 on: March 09, 2018, 09:51:43 AM 
Started by bobby brown - Last post by The Myth Lives
Quote
4) did you reloaded your configuration?
5) I am unable to do this even though I have Service Root
6) Same as above
carl is a Services Operator of type Services Root

You can always reload your configuration file from command line, in /services/bin folder with
Code: [Select]
./anoperc rehash
When you try to do /os reload, what's the error you get?
By any chance do you have https://github.com/anope/anope/blob/2.0/data/example.conf#L898 enabled in your oper block? If you do you need to do the following command after oper up
Code: [Select]
/os login password

Pages: [1] 2 3 ... 10