Anope Support > 2.0.x/1.9.x Support

spkifp authentication


Hi there,

this is a trouble I've since I decided to link my servers (unrealircd) using spkifp passwords: I can't find the way to configure anope to use them, I've to send plaintext password.

What do I miss ?

Your Services must be ssl ready.
When not, go to your Anope install dir
enable m_ssl_openssl.cpp or m_ssl_gnutls.cpp
Enter the name of the module
hit Return and activate the module
after all  type 'q' to quit.
compile anope

** DONT forget to enable the ssl module in your module.conf ! **

Copy your anope.crt into your unrealircd  conf path e.g. the /conf/tls path
now you can use:
./unrealircd spkifp conf/tls/anope.crt
You will get your passwordline for the services link block for unreal and can paste it there.
In your services.conf you can edit the password line with a *

     * The password to send to the IRC server for authentication.
     * This must match the link block on your IRCd.
     * Refer to your IRCd documentation for more information on link blocks.
    password = "*"

For the connection you must enable ssl
     * Enable if Services should connect using SSL.
     * You must have an SSL module loaded for this to work.
    ssl = yes

Greets Han`

Ok, the missing thing was password = "*"... Damn !

Thanks a lot Han


[0] Message Index

Go to full version