Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1] 2 3 ... 10
 1 
 on: Yesterday at 05:05:51 PM 
Started by CrazyCat - Last post by CrazyCat
I'm with anope-2.0.15 working on Debian 12

 2 
 on: Yesterday at 02:35:18 PM 
Started by CrazyCat - Last post by Sadie
What version of Anope are you using?

 3 
 on: June 17, 2024, 02:41:38 PM 
Started by CrazyCat - Last post by CrazyCat
Hi there,

I'm working on a log module, lot of things work but I'm unable to get the part.
Looking at the sources of modules.h:
Code: [Select]
/** Called when a user parts a channel
* @param u The user
* @param c The channel, may be NULL if the channel no longer exists
* @param channel The channel name
* @param msg The part reason
*/
virtual void OnPartChannel(User *u, Channel *c, const Anope::string &channel, const Anope::string &msg) { throw NotImplementedException(); }

So I made in my module (incomplete code, I just show the debug part):
Code: [Select]
void OnPartChannel(User *u, Channel *c, Anope::string &channel, Anope::string &msg) anope_override
   {
      Log(this) << "Got an action " << " part ";
   }
   
   void OnLeaveChannel(User *u, Channel *c) anope_override
   {
      Log(this) << "Got an action " << " leave ";
   }
   
   void OnPrePartChannel(User *u, Channel *c) anope_override
   {
      Log(this) << "Got an action " << " prepart ";
   }
When I part & join a channel, this is what I've in my logfile:
Quote
[Jun 17 15:27:06 2024] M_LOGCHAN: Got an action  prepart
[Jun 17 15:27:06 2024] M_LOGCHAN: Got an action  leave
[Jun 17 15:27:18 2024] M_LOGCHAN: Got an action  join
So, the part is never called, and it's the only one which has the part message.

Did I do something wrong or is it something else ?

 4 
 on: May 29, 2024, 12:16:08 AM 
Started by Marisa Giancarla - Last post by Marisa Giancarla
I'll take those suggestions :)

 5 
 on: May 28, 2024, 01:18:01 PM 
Started by Marisa Giancarla - Last post by CrazyCat
Seems some cool little tools for lazy admins :D
I'll try them and make you a feedback.

Just a few comment: you may separate the configuration from the active files, and why not have only one conf to rule them all.

 6 
 on: May 28, 2024, 09:02:42 AM 
Started by Marisa Giancarla - Last post by Sadie
You are using a 2.0 config on 2.1. The unreal4 module was renamed to unrealircd in 2.1.

 7 
 on: May 28, 2024, 08:14:46 AM 
Started by Marisa Giancarla - Last post by Marisa Giancarla
Hello! I have just made a suite of tools to make running Anope services on Linux easier. Includes a backup script, management console, and scripts to start at boot and within 1 minute if it should crash. Get more info here: https://sourceforge.net/projects/anope-utilities/

If you have any issues just let me know...

 8 
 on: May 28, 2024, 03:17:55 AM 
Started by Marisa Giancarla - Last post by Marisa Giancarla
Ok using the latest "stable" version it compiled and is running fine. Should not have tried the dev version anyway...

 9 
 on: May 28, 2024, 02:36:51 AM 
Started by Marisa Giancarla - Last post by Marisa Giancarla
What version of Anope are you using?
The very latest version from the download area. It says it is a dev version so let me try the latest stable version...

 10 
 on: May 28, 2024, 01:25:44 AM 
Started by David - Last post by Sadie
I've fixed this bug in git. A new 2.1 release containing the fix will be available in a few days.

Pages: [1] 2 3 ... 10