Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: SSL kills the style !  (Read 6344 times)

0 Members and 1 Guest are viewing this topic.

meepmeep

  • Anope User
  • Offline Offline
  • Posts: 12
SSL kills the style !
« on: April 22, 2013, 07:42:19 PM »

Hi

When I access magIRC with ssl enabled (https://stats.fantasya.org), my browser (chrome / IE) doesn't load some script, which kills the layout :




You can see the little shield on the upper right, saying "This page has insecure content." (google explication).
If I click and allow the script to be executed, everything works fine... but I don't think my visitor will see this little icon and accept to load 'unsecure' content.

Is there a way to correct this ?
Logged

Hal9000

  • Team
  • *
  • Offline Offline
  • Posts: 103
Re: SSL kills the style !
« Reply #1 on: April 22, 2013, 07:56:33 PM »

i guess you could correct the base_url parameter in the magirc_config table to have https instead of http
Logged

Mantas

  • Anope User
  • Offline Offline
  • Posts: 1
Re: SSL kills the style !
« Reply #2 on: April 22, 2013, 08:01:27 PM »

Or even, to not have any scheme at all. Just using //stats.fantasya.org will make the browser use the correct scheme.
Logged

meepmeep

  • Anope User
  • Offline Offline
  • Posts: 12
Re: SSL kills the style !
« Reply #3 on: April 22, 2013, 08:08:37 PM »

@Mantas : I didn't get your answer  ??? .. sorry :)

@Hal9000 : I don't have the "base_url" on the magirc_config table ... Moreover, multiple url have access to magIRC (stats.fantasya.org, stats.europnet.org for example) and they don't all run a valid ssl certificate.
Logged

Hal9000

  • Team
  • *
  • Offline Offline
  • Posts: 103
Re: SSL kills the style !
« Reply #4 on: April 27, 2013, 12:13:59 PM »

so what version of magirc are you running then?
Logged

Hal9000

  • Team
  • *
  • Offline Offline
  • Posts: 103
Re: SSL kills the style !
« Reply #5 on: May 26, 2013, 07:15:27 PM »

Sorry for having been so slow on this one... there was a bug in the Magirc setup that affected fresh installs.
Also, I now did what Mantas suggested and left the protocol out of the base url. Didn't know you could do that actually :)
Fix should be in git in a few minutes, and I guess I will release v0.8.7 soon after that since this is a show stopper.
Logged

Jeffrey Turner

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 17
    • TurnerGames
Re: SSL kills the style !
« Reply #6 on: May 27, 2013, 07:06:38 PM »

I actually downloaded the latest git and installed it, however https still shows the same for me, and on top of that, on the admin configuration page, I can no longer see the "Welcome Message" field to edit regardless of which protocol I use for http/https.
Logged
Jeffrey "Zero" Turner

Hal9000

  • Team
  • *
  • Offline Offline
  • Posts: 103
Re: SSL kills the style !
« Reply #7 on: May 27, 2013, 07:13:15 PM »

Damn you are right, the editor is broken.
Will fix it after dinner.
I will also try to fix the SSL problem.
Logged

Hal9000

  • Team
  • *
  • Offline Offline
  • Posts: 103
Re: SSL kills the style !
« Reply #8 on: May 27, 2013, 07:54:59 PM »

Please try the latest git version.
As for SSL, just set https:// in the base url setting in the admin panel. It should then default to ssl and no longer make problems
Logged

Jeffrey Turner

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 17
    • TurnerGames
Re: SSL kills the style !
« Reply #9 on: May 27, 2013, 08:13:38 PM »

Yeah, that fixed the editor. However, it is still giving the error about unsecured content and wont load.
Logged
Jeffrey "Zero" Turner

Hal9000

  • Team
  • *
  • Offline Offline
  • Posts: 103
Re: SSL kills the style !
« Reply #10 on: May 28, 2013, 11:18:45 PM »

if you specify https:// in the base url configuration in the admin panel, it should work fine with ssl
Logged

meepmeep

  • Anope User
  • Offline Offline
  • Posts: 12
Re: SSL kills the style !
« Reply #11 on: November 07, 2013, 05:13:40 PM »

Hi :)

I just updated to 0.87-beta, and the ssl is still no working :/
Logged

Thomas Edwards

  • Anope User
  • Offline Offline
  • Posts: 23
    • Ilkotech Technology and Entertainment
Re: SSL kills the style !
« Reply #12 on: November 07, 2013, 09:11:38 PM »

I've just installed MagIRC on a server with SSL Support and have had no issue. I managed to replicate the Issue by having 'base_url' in SQL incorrect. Make sure your base URL is "//YOURDOMAIN/", the one MagIRC is working off.

If that still don't fix it I will have a proper look at whats causing it.
Logged

Hal9000

  • Team
  • *
  • Offline Offline
  • Posts: 103
Re: SSL kills the style !
« Reply #13 on: November 09, 2013, 06:09:37 PM »

An issue could be that you have MagIRC set up to get some files from CDN. Since these are not SSL, some browser might block them. Just try to disable the CDN feature in the MagIRC admin panel and see if it works fine then.
Logged

meepmeep

  • Anope User
  • Offline Offline
  • Posts: 12
Re: SSL kills the style !
« Reply #14 on: November 16, 2013, 11:48:51 AM »

Thank you guys. I turn off the CDN feature, and it works great, except that some of the script aren't using  httpS:
- google adsense (really strange, the code seems to provide a httpS link)
- AddThis Sharing bouton
Logged
Pages: [1]   Go Up