Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: No output from services  (Read 7730 times)

0 Members and 1 Guest are viewing this topic.

Belgarion

  • Guest
No output from services
« on: July 23, 2006, 11:22:58 AM »

I have installed Anope seemingly correctly with Unrealirc, and all was fine until I actually tried to use a service command, such as /Nickserv LIST.  I get no output at all.

Within the DOS debug window for anope, I get the following:

[Jul 23 11:10:16 2006] debug: Received: :Belgarion PRIVMSG NickServ@services.myserver.com :LIST

So it is receiving the command, but not sending anything back.  What have I missed? :)
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #1 on: July 23, 2006, 12:15:56 PM »

Can you try /whois NickServ and see if you get a response to that?

The reason i ask this is because if Anop hasnt registered the NickServ nick as coming online then if youre using Unreal it will send a kill message back everytime Anope sends a message as a nick that is not online.

[Edited on 23-7-2006 by Jobe1986]
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Belgarion

  • Guest
(No subject)
« Reply #2 on: July 23, 2006, 12:56:56 PM »

Ah no problems, it seems that using the direct /nickserv command doesn't actually work, while using /msg nickserv does. For some reason, sending /nickserv adds the host server to the end of the command - nickserv@services.localhost - which of course isn't acted upon.. very odd.  Any ideas there?
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #3 on: July 23, 2006, 12:59:13 PM »

If youre using UnrealIRCd make sure the services-server parameter is set to the correct name of your services server. For example:
Code: [Select]
set {
services-server "services.invictachat.co.uk";
};

[Edited on 23-7-2006 by Jobe1986]
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Belgarion

  • Guest
(No subject)
« Reply #4 on: July 23, 2006, 01:20:05 PM »

Many thanks - just shows it's the little things that one can overlook :P

Now, for a bonus prize - I don't suppose you know off the top of your head how to forbid channel creation except for Admin ? :)
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #5 on: July 23, 2006, 01:31:29 PM »

Sorry for the late reply.

Have a look in your services.conf file for
Quote
# CSOpersOnly [OPTIONAL]
#     If this is defined, only IRC Operators will be permitted to use ChanServ.

#CSOpersOnly


If you remove the # in front of CSOpersOnly the ONLY users allowed to register channels will be anyone who has an oper block or is on the services oper or service admin lists.

Im not sure if it disallows anyone from using ChanServ or just disallows registering channels but it should help.

[Edited on 23-7-2006 by Jobe1986]
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Belgarion

  • Guest
(No subject)
« Reply #6 on: July 23, 2006, 01:34:28 PM »

Hmm this doesn't stop me from typing say /Join #newchannel - and not creating it....

[Edited on 23-7-2006 by Belgarion]
Logged

Belgarion

  • Guest
(No subject)
« Reply #7 on: July 23, 2006, 01:37:47 PM »

I see you edited just as I did :P

I found a module that is supposed to do this... see if I can compile that under windows....
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #8 on: July 23, 2006, 01:40:59 PM »

You could try in Unrealircd.conf putting:
Code: [Select]
deny channel {
channel "*";
reason "Only registered channels allowed!";
};


And put the following for every channel you want to allow:
Code: [Select]
allow channel {
channel "#main";
};

[Edited on 23-7-2006 by Jobe1986]
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Belgarion

  • Guest
(No subject)
« Reply #9 on: July 23, 2006, 02:02:13 PM »

And that worked perfectly :D

Thank you for your patience and help :)
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #10 on: July 23, 2006, 02:31:10 PM »

No problem at all.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/
Pages: [1]   Go Up