Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Problem with unrealircd and anope  (Read 5643 times)

0 Members and 1 Guest are viewing this topic.

dforce

  • Guest
Problem with unrealircd and anope
« on: June 21, 2006, 11:58:24 AM »

I m getting this error

Code: [Select]

[Jun 21 12:55:02 2006] debug: trying to load core module [he_help]
[Jun 21 12:55:02 2006] debug: status: [0][Module, Okay - No Error]
[Jun 21 12:55:02 2006] debug: Loaded NickServ database (1/7)
[Jun 21 12:55:02 2006] debug: Loaded HostServ database (2/7)
[Jun 21 12:55:02 2006] debug: Loaded BotServ database (3/7)
[Jun 21 12:55:02 2006] debug: Loaded ChanServ database (4/7)
[Jun 21 12:55:02 2006] debug: Loaded OperServ database (5/7)
[Jun 21 12:55:02 2006] debug: Loaded news database (6/7)
[Jun 21 12:55:02 2006] debug: Loaded exception database (7/7)
[Jun 21 12:55:02 2006] Databases loaded
[Jun 21 12:55:02 2006] Info: Reflecting database records.
[Jun 21 12:55:02 2006] debug: Emitting event "db_saving" (1 args)
[Jun 21 12:55:02 2006] debug: Saving FFF databases
[Jun 21 12:55:02 2006] debug: Emitting event "db_saving" (1 args)
[Jun 21 12:55:02 2006] debug: Emitting event "connect" (1 args)
[Jun 21 12:55:03 2006] FATAL: Can't connect to server: No such file or directory


What is going wrong and what do you want to see to fix this problem ?
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #1 on: June 21, 2006, 12:01:46 PM »

[Jun 21 12:55:03 2006] FATAL: Can't connect to server: No such file or directory

Thats the problem.

Post the following:

unrealircd.conf
-> Listen Blocks
-> Link Block for services

services.conf
-> RemoteServer Line
-> ServerName Line
Logged

dforce

  • Guest
(No subject)
« Reply #2 on: June 21, 2006, 12:15:35 PM »

unrealircd.conf
Listen block
Code: [Select]

listen         *:6697
{
options
{
clientsonly;
};
};
listen         *:6667;


Link block
Code: [Select]

link            services.duckserver.duck
{
username *;
hostname 65.43.21.100;
bind-ip *;
port 1234;
hub             *;
password-connect "play";
password-receive "play";
class           servers;
options {
/* Note: You should not use autoconnect when linking services */
};
ulines {
services.duckserver.duck;
stats.duckserver.duck;
};


services.conf
RemoteServer line
Code: [Select]

RemoteServer    65.43.21.100 1234 "play"


ServerName line
Code: [Select]

ServerName  "irc.play.duck"
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #3 on: June 21, 2006, 12:21:21 PM »

Two problems:

1) You are expecting a link on a port you aren't listening on (this is why you get the error you do)
2) ServerName in services.conf should be services.duckserver.duck otherwise you will get an error when you try and link of (No linkblock found).

Try that, and it'll work.
Logged

dforce

  • Guest
(No subject)
« Reply #4 on: June 21, 2006, 12:43:15 PM »

OK thanks it works
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #5 on: June 21, 2006, 12:44:55 PM »

Good, I'm glad.
Logged
Pages: [1]   Go Up