Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Anope 1.8.0 with InspIRCd 1.1.22 451 Error  (Read 13506 times)

0 Members and 1 Guest are viewing this topic.

skippy

  • Anope User
  • Offline Offline
  • Posts: 6
Anope 1.8.0 with InspIRCd 1.1.22 451 Error
« on: January 03, 2009, 08:10:01 PM »

Hello all,  :D

Installed the Anope IRC Services to hopefully expand my newly installed InspIRCd, mainly for the chanserv, nickserv features that are not implemented in the IRCd.

Running the Debug and Windows Logging keeps throwing up:
Noticed Auth :****Looking up your hostname...
Received: irc.thisisnotmyhost.net 451 Server :You have not registered.
Received: irc.thisisnotmyhost.net 451 Version:You have not registered. then..
Erroneous Nickname.
.....
.....
Closing link unknown@127.0.0.0

I'm persisting with it as I'm determined to get this running, but I can't seem to figure out what I might have over looked.  ???

The IRC Daemon is running fine, I just wish I could overcome this hurdle of the "you have not registered".

Appreciate any useful info.

Regards,

Paul.
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
Re: Anope 1.8.0 with InspIRCd 1.1.22 451 Error
« Reply #1 on: January 03, 2009, 09:50:23 PM »

From the errors provided it would seem you connected Anope to a CLIENT port and not a SERVER port.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

skippy

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Anope 1.8.0 with InspIRCd 1.1.22 451 Error
« Reply #2 on: January 03, 2009, 10:13:08 PM »

I thought this was the problem too, so I changed the entry of <bind address="" port="6667" type="clients"> <bind address="" port="6667" type="clients" ssl="gnutils"> over to "servers".

This has cleared up the "You have not registered." when I run the debug now. (The only outstanding error is "No such file or directory" error num2) which I believe is related to a module not being loaded or available.

But, when I do change the bind address to Servers, then I can't connect to the IRCd with my IRC client. I just get disconnected.

I'm wondering if I need an entry for <bind address on say port 6667 for clients> and also an entry for <bind address on a port of the linking servers>

Thanks for the help.
Logged

skippy

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Anope 1.8.0 with InspIRCd 1.1.22 451 Error
« Reply #3 on: January 03, 2009, 10:25:49 PM »

Little update, well I've done the above as I mentioned. Now I can log into IRCd with the Client and the Debug no longer throws up an error.

When I run the anope.exe (Anope IRC Services) a cmd pops up, so I guess its running. But the services are not available when I type nickserv, chanserv.

Just says "*Nickserv :is currently unavailable"
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Anope 1.8.0 with InspIRCd 1.1.22 451 Error
« Reply #4 on: January 03, 2009, 11:35:56 PM »

Please paste your inspircd.conf and services.conf here as it's likely a conflict in the setting of the ports.
Logged

Naram Qashat

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 192
    • CBX's Sprite Animations
Re: Anope 1.8.0 with InspIRCd 1.1.22 451 Error
« Reply #5 on: January 04, 2009, 08:33:15 AM »

I would also make sure that you don't have ssl or ziplinks on the port you use for servers.  Anope can only talk to the IRCd via plain text.
Logged

skippy

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Anope 1.8.0 with InspIRCd 1.1.22 451 Error
« Reply #6 on: January 04, 2009, 10:34:16 AM »

Hi guys, thanks for the positive feedback. I've posted a link to the current .conf I'm using. Exceeded the char$ limit here even after cropping.  :o

http://skippy.dtdns.net/tmp/inspircd.conf

The router is port-forwarded 6000-7005 to 192.168.1.20 (IRCd Server) aka irc.skippy.dtdns.net (http://skippy.dtdns.net)

The Clients I've set to 6667 and the Servers I've set to 7000.

I'm still at the elementary building blocks stage with this project so please forgive any crudity or rookie mistakes.

Regards.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Anope 1.8.0 with InspIRCd 1.1.22 451 Error
« Reply #7 on: January 04, 2009, 10:43:31 AM »

Hi,

Only had a quick look atm but I've spotted a few things I'd urge you to reconsider.

Quote
<bind address="" port="6667" type="clients">
<bind address="" port="6667" type="clients" ssl="gnutls">

Pick one and stick with it on that front; might be worth changing the gnutls one to 6697 which seems to be an accepted SSL Client Port.

You're missing a services linkblock which would stop services being able to link to your ircd;

Quote
<link name="skippy.dtdns.net"
      ipaddr="127.0.0.1"
      port="6667"
      allowmask="127.0.0.1"
      autoconnect="300"

You could adapt this to suit your needs see my example below from my testnet.

Quote
<link name="services.test.lan"
      ipaddr="127.0.0.1"
      port="7000"
      allowmask="127.0.0.0/8"
      sendpass="linkplz"
      recvpass="linkplz">

Make sure services.test.lan in my example marries up with ServerName in services.conf.

This should hopefully get you a few paces further forward, feel free to drop onto our irc (irc.anope.org #anope) or post back here with the next step :)

Oh, also, in your connect block, I see a port entry for port 6667 but no others; either remove this, or duplicate the connect block for each other port.

Quote
#   The optional port value determines which port the connect tag is  #
#   handling. If left out the connect tag covers all bound ports else #
#   only incoming connections on the specified port will match. Port  #
#   tags may be used on connect allow and connect deny tags.          #

From the insp config ^





Charles.
Logged

skippy

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Anope 1.8.0 with InspIRCd 1.1.22 451 Error
« Reply #8 on: January 04, 2009, 11:12:11 AM »

Thanks for the quick response. I've amended those changes.

<bind address="" port="6667" type="clients">
<bind address="" port="6697" type="clients" ssl="gnutls">

<link name="irc.skippy.dtdns.net"  <---added the irc bit for continuity. (matches servername is services.conf)
      ipaddr="127.0.0.1"
      port="6667"
      allowmask="127.0.0.1"
      autoconnect="300"

<link name="irc.skippy.dtdns.net" (matches servername is services.conf)
      ipaddr="127.0.0.1"
      port="7000"
      allowmask="127.0.0.0/8"
      sendpass="spicegirls"
      recvpass="spicegirls">

Removed 6667 from the Connect Block. Saved and re-run the debug, gone through smoothly, only that err2 outstanding. Tried /nickserv in x chat 2, still nothing yet... :-\

I don't wanna seem stupid, but to start the Anope Services in Windows XP Pro, I simply run anope.exe. (That's what I'm doing anyway)  :P

Paul.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Anope 1.8.0 with InspIRCd 1.1.22 451 Error
« Reply #9 on: January 04, 2009, 11:21:04 AM »

You don't seem stupid so don't worry about that.

ServerName (services.conf) shouldn't be irc.skippy.dtdns.net because that's what you're calling the ircd in inspircd.conf - They need to be different; ie.

irc.skippy.dtdns.net is ideal for your IRC Server (inspircd)
services.skippy.dtdns.net is a natural option for your services server (anope).

I'd be inclined to suggest making those changes both to ServerName(services.conf) and the link block in inspircd.conf.

Once you've done that, you'll also need to add a "uline" for services.

Quote
<uline server="irc.skippy.dtdns.net" silent="no">

Change that ^ to whatever you decide to call services.

Once you've got that sorted, try again and see how we get on.

If still no dice, locate the services.log.(todaysdate) file in your anope logs dir and paste it here for us to see why it's not linking.

We'll get there =)
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Anope 1.8.0 with InspIRCd 1.1.22 451 Error
« Reply #10 on: January 04, 2009, 12:38:27 PM »

Issue resolved on irc; link block confusion and a duplicate servername.

All sorted now.
Logged

skippy

  • Anope User
  • Offline Offline
  • Posts: 6
Re: Anope 1.8.0 with InspIRCd 1.1.22 451 Error
« Reply #11 on: January 04, 2009, 12:48:52 PM »

Thanks very much for all the help guys. Issue resolved.

Happy Anoper :)

Paul.
Logged
Pages: [1]   Go Up