Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: anope Error linking  (Read 9613 times)

0 Members and 1 Guest are viewing this topic.

gnophear

  • Anope User
  • Offline Offline
  • Posts: 4
anope Error linking
« on: January 02, 2009, 12:06:24 PM »

Hello, I have searched google and all the readme docs and FAQ's and I can't seem to figure this out.

 *** Notice -- sean is rehashing server config file
* unrealircd.conf :Rehashing
* *** Notice -- Loading IRCd configuration ..
* *** Notice -- Configuration loaded without any problems ..
* *** Notice -- Connection to services.dsx.net[127.0.0.1] activated.
* *** LocOps -- Link denied for DSX.homelinux.net(unknown@127.0.0.1) (No link block named 'DSX.homelinux.net') [@127.0.0.1.1906]
* *** LocOps -- ERROR :from services.dsx.net[127.0.0.1] -- Link denied (No matching link configuration) [@127.0.0.1.1906]
* *** LocOps -- ERROR :from services.dsx.net[127.0.0.1] -- Closing Link: [127.0.0.1] (Link denied (No matching link configuration))
* *** LocOps -- Server services.dsx.net[127.0.0.1] closed the connection

Unrealircd Configure

listen *:6667
{
   options
   {
     clientsonly;
   };
};

listen *:7000;
listen *:6668;
listen *:6669;



link services.dsx.net
{
 username *;
 hostname 127.0.0.1;
 port 6669;
 bind-ip *;
 password-connect "servicespassword";
 password-receive "servicespassword";
 class servers;
  options {
            autoconnect;
        };

};

ulines {
 services.dsx.net;
};

also DNS in unrealircd

dns {
      nameserver 192.168.1.33;
      timeout 2s;
      retries 2;
   };


Services conf.


RemoteServer    127.0.0.1 6669 "servicespassword"
#RemoteServer2  localhost 6667 "mypass"
#RemoteServer3  localhost 6667 "mypass"


ServerName  "services.dsx.net"

ServiceUser "services@DSXserver.net"


any further information please ask.

thanks
Logged

Kreon

  • Anope User
  • Offline Offline
  • Posts: 16
    • http://kreon.net.ru
Re: anope Error linking
« Reply #1 on: January 02, 2009, 12:31:31 PM »

It's clearly stated in many places in configs, forums, docs etc.:
1 - services link block should never be autoconnect. anope connects to the ircd, not vice versa.

PS: dns block in unrealircd config is useless afaik, - it's not implemented yet
« Last Edit: January 02, 2009, 12:33:38 PM by Kreon »
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
Re: anope Error linking
« Reply #2 on: January 02, 2009, 01:12:40 PM »

Additionally, all the errors you show in your post are from the IRCd trying to link to itself (thanks to autoconnect.)

To make Anope link to the IRCd, you have to run it, using either ./services on *nix or anope.exe on windows.

If it doesn't then connect check Anope's log files.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

gnophear

  • Anope User
  • Offline Offline
  • Posts: 4
Re: anope Error linking
« Reply #3 on: January 02, 2009, 05:46:21 PM »

ok autoconnect is gone and now when I start anope.exe it reads.


[Jan 02 11:55:01 2009] Loading IRCD Protocol Module: [unreal32]
[Jan 02 11:55:01 2009] status:
  • [Module, Okay - No Error]
  • [Jan 02 11:55:01 2009] Loading Encryption Module:
[enc_none]
[Jan 02 11:55:01 2009] status:
  • [Module, Okay - No Error]
  • [Jan 02 11:55:01 2009] Launching Anope into the background
    [Jan 02 11:55:01 2009] Anope 1.8.0 (1899) (ircd protocol: UnrealIRCd 3.2+) starting up
    [Jan 02 11:55:07 2009] ms_rsend requested unload...
    [Jan 02 11:55:07 2009] debug: trying to load core module
[ms_rsend]
[Jan 02 11:55:07 2009] debug: status: [6][Module Error, Error during load time or module returned
[Jan 02 11:55:13 2009] Databases loaded
[Jan 02 11:55:13 2009] Info: Reflecting database records.
[Jan 02 11:55:13 2009] Connected to Server 1 (localhost:6667)
[Jan 02 11:55:13 2009] trying to load [cs_appendtopic]
[Jan 02 11:55:13 2009] [cs_appendtopic] Loaded successfully
[Jan 02 11:55:13 2009] status:
  • [Module, Okay - No Error]
  • [Jan 02 11:55:13 2009] trying to load
[cs_enforce]
[Jan 02 11:55:13 2009] status:
  • [Module, Okay - No Error]
  • [Jan 02 11:55:13 2009] trying to load
[ns_maxemail]
[Jan 02 11:55:13 2009] status:
  • [Module, Okay - No Error]
  • [Jan 02 11:55:13 2009] trying to load
[os_info]
[Jan 02 11:55:13 2009] os_info: Loading configuration directives...
[Jan 02 11:55:13 2009] os_info: OSInfoDBName is not defined in Services configuration file, using default os_info.db
[Jan 02 11:55:13 2009] os_info: Directive OSInfoDBName loaded (os_info.db)...
[Jan 02 11:55:13 2009] status:
  • [Module, Okay - No Error]
  • [Jan 02 11:55:13 2009] trying to load
[hs_request]
[Jan 02 11:55:13 2009] hs_request loaded
[Jan 02 11:55:13 2009] status:
  • [Module, Okay - No Error]
  • [Jan 02 11:55:13 2009] Read error from server: No such file or directory (error num: 2)
    [Jan 02 11:55:14 2009]
[cs_appendtopic] Unloaded successfully
[Jan 02 11:55:14 2009] hs_request un-loaded
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: anope Error linking
« Reply #4 on: January 02, 2009, 06:16:45 PM »

Hi,

The log you just pasted doesn't tally up with the configuration file info you provided earlier.

The log shows a connection to localhost on port 6667 which won't work because it's set as clientsonly, whereas your original information shows RemoteServer as port 6669 which would work...

Please if you cannot resolve this yourself now provide new pastes of unrealircd.conf & services.conf with a new logfile to avoid causing more confusion.
Logged

gnophear

  • Anope User
  • Offline Offline
  • Posts: 4
Re: anope Error linking
« Reply #5 on: January 02, 2009, 06:28:54 PM »

Unrealircd conf.

listen *:6667
{
   options
   {
     clientsonly;
   };
};

listen *:7000;
listen *:6668;



link services.dsx.net
{
 username *;
 hostname 127.0.0.1;
 port 6669;
 bind-ip *;
 password-connect "servicespassword";
 password-receive "servicespassword";
 class servers;
 
};

ulines {
 services.dsx.net;
};



Services conf.


RemoteServer    127.0.0.1 6669 "servicespassword"
#RemoteServer2  localhost 6667 "mypass"
#RemoteServer3  localhost 6667 "mypass"


ServerName  "services.dsx.net"
Logged

LEthaLity

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 307
    • LEthaLity
Re: anope Error linking
« Reply #6 on: January 02, 2009, 06:56:29 PM »

In your unrealircd.conf you have ports 6667, 6668 and 7000 covered in listen block, but your setting services to connect to 6669, I don't know where you want services to connect but if like your services conf you want it on 6669 then you want:
listen *:6667
{
   options
   {
     clientsonly;
   };
};
listen *:6668;
listen *:6669;
listen *:7000;

---

link services.dsx.net
{
 username *;
 hostname 127.0.0.1;
 port 6669;
 bind-ip *;
 password-connect "servicespassword";
 password-receive "servicespassword";
 class servers;
 
};

ulines {
 services.dsx.net;
};


-----
and in services.conf:
RemoteServer    127.0.0.1 6669 "servicespassword"

Rehash unreal, start anope.
Logged

gnophear

  • Anope User
  • Offline Offline
  • Posts: 4
Re: anope Error linking
« Reply #7 on: January 02, 2009, 07:01:05 PM »

yeah I figured that out and now have anope services connected but when I type /chanserv it says no text to send thats ok but then I type like /chanserv help or /chanserv register channel etc and it just doesn't come back with a response same with /nickserv
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
Re: anope Error linking
« Reply #8 on: January 02, 2009, 07:38:15 PM »

Check services-server is correct in the set blocks.

Make sure that it is exactly the same case, so if you put "Services" for your services server name, set services-server to "Services" as "services is NOT the same as "Services"
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/
Pages: [1]   Go Up