Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Erreur Anope-1.7.20  (Read 6365 times)

0 Members and 1 Guest are viewing this topic.

Driven

  • Anope User
  • Offline Offline
  • Posts: 3
    • www.canalfusion.org
Erreur Anope-1.7.20
« on: December 31, 2007, 06:59:35 PM »

Bonjour je vous écris pour vous donner une erreur que je pense bonne, en etant
en  administrateur des services on ne puisse pas ce mettre en superadmin sur le
1.7.20, est ce normal ? merci de me répondre tout de même ...
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #1 on: December 31, 2007, 07:06:08 PM »

Could you please ask again in English?
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Driven

  • Anope User
  • Offline Offline
  • Posts: 3
    • www.canalfusion.org
(No subject)
« Reply #2 on: December 31, 2007, 07:25:47 PM »

Hello I am writing to give you a problem that I think good, etant
In services administrator can not put this in the superadmin
1.7.20, is this normal? Please answer me anyway ...
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #3 on: December 31, 2007, 07:35:02 PM »

To use superadmin you need to first enable it in services.conf by removing the #

Then to make use of it you use /msg OperServ set superadmin on
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Driven

  • Anope User
  • Offline Offline
  • Posts: 3
    • www.canalfusion.org
(No subject)
« Reply #4 on: December 31, 2007, 08:00:23 PM »

Yes, but when you type "/ msg operserv set superadmin on" puts us his denial, and yet I am services administrator, this is a line of what is happening

(20:58:21) (@Global) OperServ: Driven: staff
(20:58:22) -OperServ- On Level Pseudo
(20:58:22) -OperServ- * ADMN Driven
(20:58:22) -OperServ- * ADMN KinG [ShAkA]
(20:58:22) -OperServ- * ROOT martin
(20:58:22) -OperServ- * ROOT SlaY
(20:58:22) -OperServ- * ROOT Orion
(20:58:22) -OperServ- Fin du Staff list.
(20:58:25)   —› •operserv• set superadmin on
(20:58:25) (@Global) OperServ: Driven: set superadmin on
(20:58:25) -OperServ- Accès refusé.
(20:58:26) (@Global) Access denied for Driven with service OperServ and command set
Logged

katsklaw

  • Guest
(No subject)
« Reply #5 on: January 01, 2008, 12:51:45 AM »

As of 1.7.20, SuperAdmin can only be used by ServicesRoots as it's a subcommand of /operserv SET. ALL set commands now require root access.

[Edited on 31-12-2007 by katsklaw]
Logged

Yannick80

  • Anope User
  • Offline Offline
  • Posts: 3
    • http://www.ged-doullens.com
(No subject)
« Reply #6 on: July 01, 2008, 08:35:49 PM »

hello,
how can we make more than 1 root please
Excuse my poor english (i'm french)
thanks
Yannick80
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #7 on: July 01, 2008, 09:19:34 PM »

just add them to services.conf with a space...
the example.conf even shows multiple roots

ServicesRoot   "dengel anope"
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

Yannick80

  • Anope User
  • Offline Offline
  • Posts: 3
    • http://www.ged-doullens.com
(No subject)
« Reply #8 on: July 01, 2008, 10:04:43 PM »

thanks, it works :)
Logged
Pages: [1]   Go Up