Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: exception  (Read 5506 times)

0 Members and 1 Guest are viewing this topic.

D_Devil

  • Guest
exception
« on: April 06, 2007, 06:16:08 PM »

Hi,

I have set a exception with limit 0 (unlimited) and noexpire date . The default limit of the server is 3. max exeption limit is 100
now the user is logged on 5 times. after logging on with a 6th connection he gets the session limit warning and can't connect with more then 5 connections.

How is this possible ?

software anope 1.7.18 with unrealircd 3.2.6
Logged

Armadillo

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 72
    • http://www.penguinfriends.org
(No subject)
« Reply #1 on: April 06, 2007, 06:20:40 PM »

did you add an allow block in the uneal-config like this, too?

allow {
        ip xx.xx.xx.xx;
        hostname *@*yourdomain.tld;
        class clients;
        maxperip 50;
};
Logged
IRC-Network: irc.PenguinFriends.org | Website: www.PenguinFriends.org
Anope: 1.9.9 | InspIRCd: 2.0

D_Devil

  • Guest
(No subject)
« Reply #2 on: April 06, 2007, 06:28:26 PM »

yes this block is in the unreal config

allow {
   ip             *@*;
   hostname       *@*;
   class           clients;
   maxperip 5;
};


Have i to adjust this ore just remove it so anope does this ?
Logged

katsklaw

  • Guest
(No subject)
« Reply #3 on: April 06, 2007, 08:49:19 PM »

Quote
Originally posted by D_Devil
yes this block is in the unreal config

allow {
   ip             *@*;
   hostname       *@*;
   class           clients;
   maxperip 5;
};


Have i to adjust this ore just remove it so anope does this ?


OS exceptions are for services, the allow block, in this case maxperip, regulates the number of users per IP. So you must configure both Anope *and* your IRCd to allow for multiple conncetions from the same IP.

If you look in the example you pasted, you will see what is limiting your users connections.

maxperip 5; <--

Since Anope does session limiting you can set maxperip to a much higher number and trust services to regulate clones or you can add allow blocks per granted host as per your ircd's documentation to allow specific hosts to have more than the default number of connections.
Logged

Armadillo

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 72
    • http://www.penguinfriends.org
(No subject)
« Reply #4 on: April 07, 2007, 09:54:25 AM »

So the solution will be, that you add a new allow block like the following to you unrealircd.conf:

allow {
  ip xx.xx.xx.xx; <-- here you hav to add the ip adress of the server from where you want to connect more than 5 clients
  hostname *@*yourdomain.tld; <-- here you have to add the domain name with which the users from the server from where you want to connect with more than 5 clients
  class clients; <-- this setting you mussn't change
  maxperip 50; <-- this is the number how many clients from the given ip you want to allow (be careful and DO NOT add a to high number here, only add what the ip REALLY needs!!!)
};

Greetz

[Bearbeitet am 7-4-2007 von Armadillo]
Logged
IRC-Network: irc.PenguinFriends.org | Website: www.PenguinFriends.org
Anope: 1.9.9 | InspIRCd: 2.0

D_Devil

  • Guest
(No subject)
« Reply #5 on: April 07, 2007, 11:44:47 AM »

thanks fore answering my question. problem is solved

topic can be closed
Logged
Pages: [1]   Go Up