Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Anope on Windows 2003 webedition  (Read 5531 times)

0 Members and 1 Guest are viewing this topic.

RedOne_NL

  • Guest
Anope on Windows 2003 webedition
« on: November 22, 2006, 10:54:00 PM »

Hi all

I had run anope with unreal running on XP pro, no problems
I have running it un lunix, no problem
No i want to install it on my dedicated server with
windows 2003 wEB EDITION. But cant get it to work. When i do aopne.exe -nofork -debug it says that it will not work on Win 98 system (only NT systems) I thought this version is NT
but seems to be not.

Is there a way i can run it on 2003 Web edition???
Otherwise i have to search for anothher services and
everybody has to registrate again :(. I just learned to work with anope and i like it.

Can somebody help me??

Thnks in advance

Rene
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #1 on: November 22, 2006, 11:02:01 PM »

I get the same message when i tried on a Windows NT 4.0 Server comp. Which as you can see is clearly Windows NT based. I think its because the check thats performed doesnt check if the operating system is NT based but is some other check. As far as i am aware every Microsoft OS after Windows 2000 (excluding Windows ME) is NT based. Windows ME was the last OS the released that wasn't NT based as far as i know.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

katsklaw

  • Guest
(No subject)
« Reply #2 on: November 22, 2006, 11:11:20 PM »

I'd like to say that there are differences in "NT based" by definition. NT 3.5x and NT4 based OS's are slighty different than Windows 2k/2k3/XP "NT based" OS's. Anope does support NT4 afaik, but since there is an actual difference in NT4's version of NTFS and XP/2k3/2k versions of NTFS you may experience some oddities.
Logged

heinz

  • Guest
(No subject)
« Reply #3 on: November 22, 2006, 11:37:50 PM »

The checks in SupportedWindowsVersion do not permit Anope to run on Windows 98/ME or below, and also Windows NT4. Win2k, WinXP, Win2k3, WinVista and WinLonghorn should all run fine.

Please can you paste your debug log of the message, along with either the text or a screenshot of the "My Computer" properties page.

[Edited on 22-11-2006 by heinz]
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #4 on: November 23, 2006, 12:57:10 PM »

THe last version of Anope i had running on Windows NT 4 server was 1.7.13 if it helps you find out why.
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

RedOne_NL

  • Guest
(No subject)
« Reply #5 on: November 23, 2006, 02:56:08 PM »

Quote
Originally posted by heinz

Please can you paste your debug log of the message, along with either the text or a screenshot of the "My Computer" properties page.


[Nov 23 15:48:24 2006] Loading IRCD Protocol Module: [unreal32]
[Nov 23 15:48:24 2006] status:
  • [Module, Okay - No Error]
[Nov 23 15:48:24 2006] Microsoft Windows 98   is not a supported version of Windows
[Nov 23 15:49:41 2006] Loading IRCD Protocol Module: [unreal32]
[Nov 23 15:49:41 2006] status:
  • [Module, Okay - No Error]
[Nov 23 15:49:48 2006] Loading IRCD Protocol Module: [unreal32]
[Nov 23 15:49:48 2006] status:
  • [Module, Okay - No Error]
[Nov 23 15:49:48 2006] Microsoft Windows 98   is not a supported version of Windows

This is the last log a have.

Running on dedicated server. Mircosoft Windows 2003 Web Edition.

I had running the anope version running on my laptop with Xp home edition without problems. I installed anope on server and copied the services.conf from my laptop

Hope u can help me

Greetings Rene

PS After i posted this message i tried several things, Its doing now more then first. I keep u informed

[Edited on 23-11-2006 by RedOne_NL]
Logged
Pages: [1]   Go Up