Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: How to prevent...  (Read 6708 times)

0 Members and 1 Guest are viewing this topic.

Alex

  • Guest
How to prevent...
« on: September 07, 2006, 11:49:21 AM »

Hello guys,

I get a message that says the following:
*** Server Notice -- Maximum connections: 20 (19 clients)

I have never seen that message coming up like a global notice before.

My questions is, how can I disable this?
I'm using Anope-1.7.15

Thanks.
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #1 on: September 07, 2006, 12:31:15 PM »

Are you sure that notice come from services(?) ... because i use to see services genarated messages like "Maximum User Counts..." only on the log channel. I think that if the notice is given by the services, it will also include a Global nick on the notice/wallops/globalops messages :-?
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.

Alex

  • Guest
(No subject)
« Reply #2 on: September 07, 2006, 12:42:44 PM »

Hello n00bie,

Yes it does come from notice/wallops/globalops messages, but I have never seen it before, and now it also comes up messages such as:

 *** LocOps Notice -- Forbidding Q-lined nick christopher from emilee[88.233.16.92]

The above does not show anyone, so I'm not sure about it.

Hope you can help me out with this too.

Thanks. ;)
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #3 on: September 07, 2006, 01:00:56 PM »

ok, let me try to explain this from the best of my understanding ^^

if services gives out a wallops or global notices, the name of the nick or services who gives out notice will be included too.
Example:
-irc.localhost.net- *** Global -- from OperServ: n00bie do something

and as for the ircd, it may or maynot give info
Example:
 *** LocOps Notice -- blah blah blah...
-irc.localhost.net- *** NetAdmin.Chat -- from n00bie: hehe

Quote
*** LocOps Notice -- Forbidding Q-lined nick christopher from emilee[88.233.16.92]

that means, user emilee is trying to use a forbidden nick.

sorry for my language.. i cannot explain exactly what i meant to say .. lol ... anyway i hope you get my point.. and p.s. i knew that someone will correct me if i'm wrong or can explain it more about it ^_^
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.

Alex

  • Guest
(No subject)
« Reply #4 on: September 07, 2006, 01:04:21 PM »

Hello n00bie,

No problem at all, I understood what you meant, so your explanation was more than good.

Again, thanks for your help. ;)
Logged

n00bie

  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #5 on: September 07, 2006, 01:10:50 PM »

hehe, and also just for the info, if you look at services.conf there are some settings for globops/wallops which are generated by services and can be enabled or disabled as per your wish.
Example:
WallOper
WallBadOS
WallOSGlobal
and so on... :)
Logged
I am always doing things that which I cannot do, in order that I may learn how to do it.

Alex

  • Guest
(No subject)
« Reply #6 on: September 07, 2006, 04:59:31 PM »

Hey n00bie,

Great, I'll take a look into that too. ;)
Logged

katsklaw

  • Guest
(No subject)
« Reply #7 on: September 07, 2006, 10:35:21 PM »

This is an ircd issue, not a services issue. Hence the term server in the message. Services only communicates with /notice, /*ops or /privmsg. Anope does *not* use snotice.

*** Server Notice -- Maximum connections: 20 (19 clients)

This is actually nothing more than an informational message letting you know that you have exceeded the previous maximum number of connections. This can be helpful information, especially when you see alot of them and often. It can be a tell tale sign of an ongoing clone/connection flood. Unfortunately most ircd's that show this message do not have a way to disable it without editing the source code. Other ircds that have this ability do offer a way to disable it. Consult your ircd documentation.

[Edited on 7-9-2006 by katsklaw]
Logged
Pages: [1]   Go Up