Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: services.conf questions  (Read 7372 times)

0 Members and 1 Guest are viewing this topic.

Alatyami

  • Anope User
  • Offline Offline
  • Posts: 8
services.conf questions
« on: August 26, 2006, 03:59:12 PM »

Quick questions ....

RemoteServer hostname port password

Whats the password for?  I'm connecting the Anope to the local Unreal3.2, does this remote server connect to the daemon?

Also does the LocalAddress need to have a different port than the ircd listener?

Thanks,
Alatyami
Logged

Alatyami

  • Anope User
  • Offline Offline
  • Posts: 8
(No subject)
« Reply #1 on: August 26, 2006, 04:45:54 PM »

NVM ... re-read section three .... but now I have a new problem ...

Code: [Select]

[Aug 26 08:45:23 2006] Loading IRCD Protocol Module: [unreal32]
[Aug 26 08:45:23 2006] status: [0][Module, Okay - No Error]
[Aug 26 08:45:23 2006] Anope 1.7.15 (1128) (ircd protocol: UnrealIRCd 3.2+) starting up
[Aug 26 08:45:24 2006] ns_sendpass requested unload...
[Aug 26 08:45:24 2006] debug: trying to load core module [ns_sendpass]
[Aug 26 08:45:24 2006] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Aug 26 08:45:24 2006] ns_getpass requested unload...
[Aug 26 08:45:24 2006] debug: trying to load core module [ns_getpass]
[Aug 26 08:45:24 2006] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Aug 26 08:45:24 2006] cs_sendpass requested unload...
[Aug 26 08:45:24 2006] debug: trying to load core module [cs_sendpass]
[Aug 26 08:45:24 2006] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Aug 26 08:45:24 2006] cs_getpass requested unload...
[Aug 26 08:45:24 2006] debug: trying to load core module [cs_getpass]
[Aug 26 08:45:24 2006] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Aug 26 08:45:24 2006] ms_rsend requested unload...
[Aug 26 08:45:24 2006] debug: trying to load core module [ms_rsend]
[Aug 26 08:45:24 2006] debug: status: [6][Module Error, Error during load time or module returned MOD_STOP]
[Aug 26 08:45:24 2006] MySQL: has been disabled.
[Aug 26 08:45:24 2006] Databases loaded
[Aug 26 08:45:24 2006] Info: Reflecting database records.
[Aug 26 08:45:24 2006] Connected to Server 1 (irc.redguides.com:6667)
[Aug 26 08:45:24 2006] trying to load [cs_appendtopic]
[Aug 26 08:45:24 2006] [cs_appendtopic] Loaded successfully
[Aug 26 08:45:24 2006] status: [0][Module, Okay - No Error]
[Aug 26 08:45:24 2006] trying to load [cs_enforce]
[Aug 26 08:45:24 2006] status: [0][Module, Okay - No Error]
[Aug 26 08:45:24 2006] trying to load [ns_maxemail]
[Aug 26 08:45:24 2006] status: [0][Module, Okay - No Error]
[Aug 26 08:45:24 2006] trying to load [os_info]
[Aug 26 08:45:24 2006] os_info: Loading configuration directives...
[Aug 26 08:45:24 2006] os_info: OSInfoDBName is not defined in Services configuration file, using default os_info.db
[Aug 26 08:45:24 2006] os_info: Directive OSInfoDBName loaded (os_info.db)...
[Aug 26 08:45:24 2006] status: [0][Module, Okay - No Error]
[Aug 26 08:45:24 2006] trying to load [hs_request]
[Aug 26 08:45:24 2006] hs_request loaded
[Aug 26 08:45:24 2006] status: [0][Module, Okay - No Error]
[Aug 26 08:45:24 2006] Error: Your IRCD's link block may not setup correctly, please check unrealircd.conf
[Aug 26 08:45:24 2006] Error: Your IRCD's link block may not setup correctly, please check unrealircd.conf
[Aug 26 08:45:24 2006] Read error from server: Broken pipe (error num: 32)
[Aug 26 08:45:24 2006] [cs_appendtopic] Unloaded successfully
[Aug 26 08:45:24 2006] hs_request un-loaded
Logged

heinz

  • Guest
(No subject)
« Reply #2 on: August 26, 2006, 04:59:55 PM »

Quote

[Aug 26 08:45:24 2006] Error: Your IRCD's link block may not setup correctly, please check unrealircd.conf
Logged

Alatyami

  • Anope User
  • Offline Offline
  • Posts: 8
(No subject)
« Reply #3 on: August 26, 2006, 05:26:07 PM »

thanks for the quick reply!

I have rolled back one version to 1.6.4  ( because I got 1.6 to work in the past) and fixed the link block, so now i jsut get the following:

Code: [Select]

[Aug 26 09:22:55 2006] Anope 1.6.4 (874) (compiled for UnrealIRCd 3.1.1+) starting up
[Aug 26 09:22:56 2006] Databases loaded
[Aug 26 09:22:56 2006] Connected to Server 1 (localhost:6667)
[Aug 26 09:22:57 2006] Read error from server: Success


And the services still do not start, I have to be overlooking something.

Any help would be great!

[Edited on 26-8-2006 by Alatyami]
Logged

heinz

  • Guest
(No subject)
« Reply #4 on: August 26, 2006, 05:35:05 PM »

If you pasted your link blocks from Unreal it would be a great help.. unfortunately we have not yet mastered the art of mind reading

[Edited on 26-8-2006 by heinz]
Logged

Alatyami

  • Anope User
  • Offline Offline
  • Posts: 8
(No subject)
« Reply #5 on: August 26, 2006, 05:52:22 PM »

Thanks for keeping humor and not flaming ...

here we go ...

unrealircd.conf
Code: [Select]

link services.redguides.com
{
        username        *;
        hostname        localhost;
        bind-ip         *;
        port            6667;
        hub             *;
        password-connect        "An0p3";
        password-receive        "An0p3";
        class   servers;
};


heres my services.conf
Code: [Select]

RemoteServer    localhost 6667 "An0p3"
ServerName  "services.redguides.com"
Logged

heinz

  • Guest
(No subject)
« Reply #6 on: August 26, 2006, 06:06:55 PM »

Probably best to use 127.0.0.1 instead of localhost, just incase things don't resolve properly.
Logged

Alatyami

  • Anope User
  • Offline Offline
  • Posts: 8
(No subject)
« Reply #7 on: August 26, 2006, 06:15:39 PM »

Accordign to this what should me link be labeled as?

Code: [Select]

[Aug 26 10:14:15.890282 2006] debug: Received: :irc.redguides.com NOTICE AUTH :*** Looking up your hostname...
[Aug 26 10:14:15.890593 2006] unknown message from server (:irc.redguides.com NOTICE AUTH :*** Looking up your hostname...)
[Aug 26 10:14:15.890996 2006] debug: Received: :irc.redguides.com NOTICE AUTH :*** Found your hostname (cached)
[Aug 26 10:14:15.891301 2006] unknown message from server (:irc.redguides.com NOTICE AUTH :*** Found your hostname (cached))
[Aug 26 10:14:16.880485 2006] debug: Received: ERROR :Link denied (No matching link configuration) [@127.0.0.1.47382]
[Aug 26 10:14:16.881029 2006] unknown message from server (ERROR :Link denied (No matching link configuration) [@127.0.0.1.47382])
[Aug 26 10:14:16.881582 2006] debug: Received: ERROR :Closing Link: [127.0.0.1] (Link denied (No matching link configuration))
[Aug 26 10:14:16.881893 2006] unknown message from server (ERROR :Closing Link: [127.0.0.1] (Link denied (No matching link configuration)))
[Aug 26 10:14:16.882327 2006] Read error from server: No such file or directory
[Aug 26 10:14:16.882761 2006] debug: Sent: :services.redguides.com SQUIT services.redguides.com :Read error from server: No such file or directory

[Edited on 26-8-2006 by Alatyami]
Logged

heinz

  • Guest
(No subject)
« Reply #8 on: August 26, 2006, 06:26:39 PM »

Did you rehash your IRCd configuration file?
Logged

Alatyami

  • Anope User
  • Offline Offline
  • Posts: 8
(No subject)
« Reply #9 on: August 26, 2006, 06:32:38 PM »

man its always something simple!

Thank you so much for the help works like a charm!
Logged

heinz

  • Guest
(No subject)
« Reply #10 on: August 26, 2006, 06:34:15 PM »

No problem.. glad to be of assistance :)
Logged
Pages: [1]   Go Up