Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Problems with Anope and Inspire IRCd  (Read 12007 times)

0 Members and 1 Guest are viewing this topic.

Kobrakai

  • Anope User
  • Offline Offline
  • Posts: 9
Problems with Anope and Inspire IRCd
« on: March 14, 2008, 10:20:56 AM »

Hello im having some problems getting Anope to link with IRCd, could somebody please let me know if im doing something wrong? See below for details:

Inspire IRCd (v1.1.17) Config:

Quote
<server name="Kobrakai.irc.uk"
        description="Welcome to Kobrakai's Server"
        network="Kobrakai">

<bind address="" port="7000" type="servers">

<link name="services.kobrakai.irc.uk"
      ipaddr="127.0.0.1"
      port="7005"
      sendpass="badgers"
      recvpass="badgers">

<uline server="services.kobrakai.irc.uk" silent="yes">


Anope (v1.7.21) Config:

Quote
IRCDModule "inspircd11"

ServerName  "services.kobrakai.irc.uk"
NetworkName "kobrakai.irc.uk"

RemoteServer 127.0.0.1 7000 "badgers"
LocalAddress 127.0.0.1 7005


Output/Errors:

Quote
[Mar 14 02:58:30.343359 2008] debug: Received: ÿ
[Mar 14 02:58:30.343407 2008] debug: unknown message from server (ÿ)
[Mar 14 02:58:30.343475 2008] debug: Emitting event "db_saving" (1 args)
[Mar 14 02:58:30.343534 2008] [hs_request] Succesfully saved database
[Mar 14 02:58:30.343607 2008] debug: Saving FFF databases
[Mar 14 02:58:30.346411 2008] debug: Emitting event "db_saving" (1 args)
[Mar 14 02:58:30.346525 2008] debug: Emitting event "shutdown" (1 args)
[Mar 14 02:58:30.346586 2008] Read error from server: Broken pipe (error num: 32)
[Mar 14 02:58:30.346643 2008] debug: Sent: :services.kobrakai.irc.uk SQUIT services.kobrakai.irc.uk :Read error from server: Broken pipe (error num: 32)
[Mar 14 02:58:30.346699 2008] debug: firstuser() returning NULL (end of list)
[Mar 14 02:58:30.346743 2008] debug: Emitting event "shutdown" (1 args)


There is more but thats the part with the errors.

Thanks in advance.

[Edited on 14-3-2008 by Kobrakai]

[Edited on 14-3-2008 by Kobrakai]
Logged

Jan Milants

  • Team
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1372
(No subject)
« Reply #1 on: March 14, 2008, 11:55:28 AM »

- Make sure you have inspircd m_spanningtree module loaded

 - Make sure the port you are connecting to is not ssl-only (/stats P). It s not listed as such in your config, but this may have been changed without restarting.
Logged
If you like me donate coins to 1FBmZVT4J8WAUMHKqpWhgNVj3XXnRN1cCk :)

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #2 on: March 14, 2008, 02:10:25 PM »

Run Anope in debug mode (using ./services -debug on *nix or anope.exe -debug on windows) then gives us the entire log file (preferably as a file instead of pasted all on the forum)
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

katsklaw

  • Guest
(No subject)
« Reply #3 on: March 14, 2008, 05:59:20 PM »

If you need to load the m_spanningtree module you MUST restart Inspircd. Also you need the global module as well as m_services.

now for the trouble shooting, Let's play "spot the problem":

<bind address="" port="7000" type="servers">

<link name="services.kobrakai.irc.uk"
ipaddr="127.0.0.1"
port="7005"
sendpass="badgers"
recvpass="badgers">

RemoteServer 127.0.0.1 7000 "badgers"

Delete the LocalAddress line, you do not need it.
Logged

Kobrakai

  • Anope User
  • Offline Offline
  • Posts: 9
(No subject)
« Reply #4 on: March 14, 2008, 06:46:07 PM »

I have m_spanningtree and m_services enabled, Im not sure what you mean by the global module, do you mean m_globalload? If so ive enabled that too and ive just restarted IRCd.

Ive set all  three ports that you have put in bold to 7000 now too and commented out the LocalAddress line.

However im still getting the same errors.

The full output when using debug mode is at: http://www.adamnicol.adsl24.co.uk/log.txt
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #5 on: March 14, 2008, 07:15:46 PM »

Can you give us a FULL /stats P response please?

Quote
[Mar 14 18:32:44.407322 2008] debug: Received: ÿ
[Mar 14 18:32:44.407343 2008] debug: unknown message from server (ÿ)


(I missed that in the first post but it is there)

Suggests SSL port.

[Edited on 14-3-2008 by Jobe1986]
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Kobrakai

  • Anope User
  • Offline Offline
  • Posts: 9
(No subject)
« Reply #6 on: March 14, 2008, 07:33:55 PM »

Quote
Originally posted by Jobe1986
Can you give us a FULL /stats P response please?

Do I type that into IRC? All I get is:

Quote

-
End of /STATS report
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #7 on: March 14, 2008, 07:44:23 PM »

Did you try both upper and lower case P? (bearing in mind /stats is case sensitive)
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

Kobrakai

  • Anope User
  • Offline Offline
  • Posts: 9
(No subject)
« Reply #8 on: March 14, 2008, 07:54:14 PM »

Ahhh, lower case p worked:

*:6000 (client, plaintext)
*:6660 (client, plaintext)
*:6661 (client, plaintext)
*:6662 (client, plaintext)
*:6663 (client, plaintext)
*:6664 (client, plaintext)
*:6665 (client, plaintext)
*:6666 (client, plaintext)
*:6667 (client, plaintext)
*:6668 (client, plaintext)
*:6669 (client, plaintext)
End of /STATS report
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #9 on: March 14, 2008, 08:14:51 PM »

Based on that, your inspircd isn't listening on port 7000 hence why anope won't connect.
Logged

Kobrakai

  • Anope User
  • Offline Offline
  • Posts: 9
(No subject)
« Reply #10 on: March 14, 2008, 08:31:43 PM »

This is how it is in my config:

<bind address="" port="6660-6669" type="clients">
<bind address="" port="7000-7001" type="servers">

Is this the only thing I need to do in order for it to listen on port 7000?
Logged

Jobe

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 1023
    • Anope IRC Services
(No subject)
« Reply #11 on: March 14, 2008, 08:35:30 PM »

I would suggest you restart your IRCd and see what happens. IIRC InspIRCd doesn't show server ports in /stats p
Logged
Your IP: ()
My IRC Status:

Come along and visit http://www.anopequotes.org/

katsklaw

  • Guest
(No subject)
« Reply #12 on: March 14, 2008, 08:36:38 PM »

Quote
Originally posted by Jobe1986
I would suggest you restart your IRCd and see what happens. IIRC InspIRCd doesn't show server ports in /stats p


It didn't, but I think I talked Brain into showing them. Not positive though.
Logged

Kobrakai

  • Anope User
  • Offline Offline
  • Posts: 9
(No subject)
« Reply #13 on: March 14, 2008, 08:37:55 PM »

Tried restarting again but same errors :(
Logged

Kobrakai

  • Anope User
  • Offline Offline
  • Posts: 9
(No subject)
« Reply #14 on: March 15, 2008, 06:45:05 PM »

I’m going to try installing/configuring everything again from scratch and see how that goes.
Logged

Kobrakai

  • Anope User
  • Offline Offline
  • Posts: 9
(No subject)
« Reply #15 on: March 15, 2008, 08:37:27 PM »

Well I have now installed and set up both Inspire IRCd and Anope from scratch again and configured both configs from scratch also and I have the same errors. I just don’t know what else I can do.
Logged

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
(No subject)
« Reply #16 on: March 15, 2008, 11:16:33 PM »

Send your shell info to someone who can poke it until it works?

I volunteer if you email me it chaz@anope.org as I don't regularly check the forum.

(Almost midnight mind you..)
Logged

Kobrakai

  • Anope User
  • Offline Offline
  • Posts: 9
(No subject)
« Reply #17 on: March 15, 2008, 11:34:01 PM »

Ive figured it out!

Changed server port from 7000 to 7500 and it just worked.

Don’t know why it didn’t like the other port, nothing else seems to be using it.

Thanks for your help guys. :)
Logged
Pages: [1]   Go Up