Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  


Pages: [1]   Go Down

Author Topic: Unreal and Anope  (Read 5078 times)

0 Members and 1 Guest are viewing this topic.


  • Guest
Unreal and Anope
« on: December 08, 2006, 01:22:48 AM »

I'm trying to use Unreal with Anope services, But i'm getting a Link error.

[Dec 07 19:48:32 2006] Error: Your IRCD's link block may not setup correctly, please check unrealircd.conf


Listen Block
listen         *:6697

listen         *:8067;
listen         *:6667;

Link Block for services
   username   *;
   bind-ip    *;
   port       6667;
   hub             *;
   password-connect "f00Ness";
   password-receive "f00Ness";
   class           servers;

ulines {



RemoteServer Line
RemoteServer 6667 "f00Ness"

ServerName Line
ServerName  ""

BTW - My ip is allways on my router.
otherwise, my dedicated ip is

[Edited on 7-12-2006 by Austin]


  • Anope User
  • Offline Offline
  • Gender: Male
  • Posts: 411
(No subject)
« Reply #1 on: December 08, 2006, 08:02:37 AM »

Firstly, afaik UnrealIRCd does not have a valid options 'standard' for the LISTEN blocks, you can find more about the valid link blocks by reading this docs or the IRCd docs/manual itself.

Secondly, on your unrealircd link block try using a normal hostname/servername for your services-server or name. example:

 username *;
 port 6667;
 bind-ip *;
 password-connect "f00ness";
 password-receive "f00ness";
 class servers;

Third, your ircd U:Lines ...

ulines {;;

And Lastly, from your services.conf change your ServerName to
ServerName ""

and remember to double check your services-server ""; on your unrealircd SET block.
I am always doing things that which I cannot do, in order that I may learn how to do it.
Pages: [1]   Go Up