Denora Stats (discontinued) > phpDenora 1.4.x Support (Read Only)

Channel List not appearing (MySQL Error)

(1/2) > >>

The channel list as well as some other things like opers, etc. are not not appearing in pHpDenora. Denora is running on Windows for now, so I can do a ./mydbgen, but I did import the denora, and unreal databases that were included with Denora. All of the charts, and other basic information appears, but not the channel list. The pages that have missing information are showing "MySQL Error 1054: Unknown column 'mode_ls' in 'where clause'" at the bottom. I've tried starting over with a new database and still the same problem. You're more then welcome to look around at


Charles Kingsley:
I've never ran Denora on windows so I'm not really sure what to suggest but figured lets cover off on the order of stuff.

Firstly, what version of Windows, and which exactly version of Denora? The latest Denora does not support Windows XP. (whether it works or not, dunno).

Next, I understand you imported the denora.sql and the unreal32.sql, did you import the denora one first? (this is required per the notice at the top of the unreal32.sql file).

The unreal32.sql provides the column mode_ls, can you see if this exists in the "chan" table?

When you imported them did you use phpmyadmin or the MySQL cli client tool?

It's on Windows Server 2008.

Yes, I imported the denora.sql first, and then the unreal32.sql.

In the chan table I do not see the mode_ls column. The ones that are there are chanid, channel, currentusers, maxusers, maxusertime, topic, topicauthor, topictime, and kickcount.

I imported the database using the MySQL gui tools because they refused to import from phpmyadmin for whatever reason.

Charles Kingsley:
That's interesting because those exact columns are the ones denora.sql creates but you don't seem to have any of the ones unreal32.sql creates.

Curiously, if you look in the user table do you see any mode_* tables in there? (something else the unreal32.sql makes).

If phpmyadmin gave an error it would be good to know what, maybe the gui tool decided to hide these from you and they are the problem!

Nope. There are no mode_* tables. In fact, I just noticed on another page in phpDenora that's complaining about those missing too MySQL Error 1054: Unknown column 'user.mode_un' in 'where clause'.

When I try to import denora.sql with phpmyadmin it just says "MySQL said: #1005 - Can't create table 'server' (errno: 13)"

Starting to get frustrating...


[0] Message Index

[#] Next page

Go to full version