Denora Stats (discontinued) > Denora Development (Read Only)

Denora with Inspircd 2.0.2

(1/2) > >>

I just upgrade my IRCD server to inspircd 2.0.2 recently. Unfortunately, there is no denora protocol for inspircd 2 yet. I tried to load the 1.2 protocol but it does not work as expected when I enable SQL.

Is there any way to make it work with 2.0.2 properly or have to wait until denora releases the official protocol one?


There is a difference between 1.2 and 2.0 ircd protocols, you are going to either have to write one yourself, in which case if you do, please submit it for review and possible inclusion, or wait for one to be written.

Unfortunately even closely associated projects like Denora and Anope can have different release schedules.

On a personal note, please don't think this is a rant, but you should always investigate support fully before upgrading to prevent this from happening. It's highly advisable to have a TestNet to test all new software on to insure things run smoothly before introducing the new software to any production network.

I think I might have to wait until Denora releases its protocol to support Inspircd 2.0. First, I thought it worked because Denora bot was connected to Inspircd 2.0 server without any problem.

It's not always an absolute work/don't work scenario. If the bot connects fine that could suggest there is nothing different about the connection handling part of the protocol, and not the same in other parts. I haven't looked at insp 2 proto, so I don't know how much has changed, I just know that it has.

are you using denora 1.4.4 or denora 1.4.5-SVN? i believe there have been some inspircd-related fixes in svn.
using the inspircd 1.2 module "shuold" work with inspircd 2.0.
if you are still having problems, please open detailed bug reports in the bug tracker and i will try to fix the issues asap before 1.4.5 release.


[0] Message Index

[#] Next page

Go to full version