Anope Support > 2.0.x/1.9.x Support

Chanserv joins #services channel, but config file channel list is commented out?


I am using Anope 2.0.9 in combination with UnrealIRCd  I have the main services config file setup to log to both services.log and the channel #services.

For some reason, the ChanServ bot joins the #services channel.  The chanserv config file is unchanged from the example file from the initial install.  The channels line in the config is commented out with a "#".  I even tried deleting this line entirely and reloading the services and nothing changed.  For some reason it is only the ChanServ bot that does this. 

Any ideas?


did you load this module?

cuz i think that is the reason. should be the only one. :)


Commenting here to keep a record for anyone else having this problem.

I removed the module you mentioned.  This isn't enough to stop the problem, just prevent it from happening again.  I tried unassigning ChanServ (using the BotServ command) from the #services channel, but everytime I reloaded the services it would return.  I also tried using the "Set Nobot" command, but again reloading the services would cause the problem to return.

I eventually just dropped (unregistered) the channel and registered it again.  That seemed to resolve it.

huh wow. i never tried the drop myself either..
but yes, i told you in channel ( @ #anope) that i have an other idea how this can happen and that exactly the proble mwhich iam facing all the time.
i just dont really restart anope, so it happens once a year or maybe only twice, but i have exactly one channel where i can see that the prob exists.

i have no clue why it happens, i guess its a bug. but i will drop the channel too and i hope it will work for me too (of course this is just a workaround. :))


[0] Message Index

Go to full version