Anope IRC Services

Please login or register.

Login with username, password and session length
Advanced search  

News:

Poll

Which IRCd do you use with Anope from our supported list?

Bahamut
- 1 (1.7%)
Charybdis
- 0 (0%)
Dreamforge
- 0 (0%)
Hybrid
- 0 (0%)
Inspircd 1.0
- 0 (0%)
Inspircd 1.1
- 4 (6.8%)
Inspircd 1.2
- 19 (32.2%)
Plexus 2
- 0 (0%)
Plexus 3
- 0 (0%)
PTLink
- 0 (0%)
Rageircd
- 0 (0%)
Ratbox
- 2 (3.4%)
ShadowIRCd
- 0 (0%)
Solid IRCd
- 0 (0%)
UltimateIRCd 2
- 0 (0%)
UltimateIRCd 3
- 4 (6.8%)
Unreal 3.1
- 0 (0%)
Unreal 3.2
- 29 (49.2%)
Viagra
- 0 (0%)
Other (please mention in thread)
- 0 (0%)

Total Members Voted: 49


Pages: [1]   Go Down

Author Topic: Anope Supported IRCDs - Which do you use?  (Read 7349 times)

0 Members and 1 Guest are viewing this topic.

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Anope Supported IRCDs - Which do you use?
« on: August 16, 2009, 12:33:58 PM »

Which IRCd do you use Anope with?

We're looking through which IRCds we currently support with 1.8 moving into 1.9 and are wondering what everyone is using.

It is important that everyone has a vote; as these figures will influence which versions we bring through into 1.9 and beyond.
Logged

mooncup

  • Contributor
  • *
  • Offline Offline
  • Posts: 65
Re: Anope Supported IRCDs - Which do you use?
« Reply #1 on: August 16, 2009, 12:53:04 PM »

I use unreal 3.2, I'm sure you'll continue supporting now that you know I use it :3
Logged

Han`

  • Contributor
  • *
  • Offline Offline
  • Posts: 33
Re: Anope Supported IRCDs - Which do you use?
« Reply #2 on: August 16, 2009, 01:06:54 PM »

Unreal 3.2
insp maybee in the future
Greets Han`
Logged

Darth Panda

  • Anope User
  • Offline Offline
  • Posts: 33
    • Cheap Software
Re: Anope Supported IRCDs - Which do you use?
« Reply #3 on: August 16, 2009, 02:07:51 PM »

I'll predict the outcome of this poll as:

1> Unreal3.2
2> Inspircd 1.x
3> bahamut/solid-ircd

And somewhere in the mix will be a few custom or semi-custom ircds based on Unreal or Inspircd that doesn't require it's own protocol module.
Logged
Some things just don't need to be fixed.
Less is usually more.
One meets his destiny often on the road he takes to avoid it.

Trystan Scott Lee

  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 343
Re: Anope Supported IRCDs - Which do you use?
« Reply #4 on: August 16, 2009, 02:54:06 PM »

Its time to let some of the ircds die out.

DreamForge was the early Unreal code base, which last I tried to compile DreamForge it failed with modern compilers

PTlink is dead. the dev kind of killed it about two years ago now, granted still some using it but time to move it to the list of unsupported

UltimateIRCd 2 should be removed, v3 has been out nearly 2 years now.

Unreal 3.1 is ready to die, I wrote the split that gave it 3.2 support, and since all the fancy options to be more like 3.2 are in the config file, there is no need for both any more

ViagraIRCD in short Chris killed the project, was a good one, but now is not worth looking at

In the end, Unreal 3.2, Inspircd, should win out here. Hybrid ircd such as Hybrid, Ratbox, etc.. should just be merged and config options to enable the differences.
Logged
my God my tourniquet, return to me salvation

Charles Kingsley

  • Contributor
  • *
  • Offline Offline
  • Posts: 1405
Re: Anope Supported IRCDs - Which do you use?
« Reply #5 on: August 16, 2009, 03:01:09 PM »

As a question of interest, 1.9 currently only supports inspircd 1.1 / 1.2, unreal, bahamut and ratbox; has this stopped anyone having a go?
Logged

Andrew B.

  • o.O
  • Contributor
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 35
    • Keyboard-Failure
Re: Anope Supported IRCDs - Which do you use?
« Reply #6 on: August 18, 2009, 10:30:47 AM »

If anyone saw my rant about Ultimate and Trystan being wrong, please excuse me, I didn't read his entire sentence. =) 

Anyway, Unreal3.2 is what I use.
Logged
Andrew Berquist,

irc.kbfail.net

Taylor

  • Contributor
  • *
  • Offline Offline
  • Posts: 98
Re: Anope Supported IRCDs - Which do you use?
« Reply #7 on: August 19, 2009, 04:26:56 AM »

I started out hanging on an Unreal3 network and started mine out on unreal still use it never used anything else, and always will use it, till something of significant is out, which who knows maybe unreal cpp will be done by then! In which case i'll stay with it still xD

Its always done what i want and i know it more than any other ircd
Logged
Cronus
irc.cncirc.net
http://CnCIRC.net

Jose Luis I.

  • Anope User
  • Offline Offline
  • Posts: 3
Re: Anope Supported IRCDs - Which do you use?
« Reply #8 on: August 31, 2009, 04:42:38 PM »

if a few votes ircd has also shall be supported by Anope? for example, ratbox

a.
Logged

GhosT

  • Anope User
  • Offline Offline
  • Posts: 43
Re: Anope Supported IRCDs - Which do you use?
« Reply #9 on: October 15, 2009, 04:34:10 AM »

Before I use Unreal. I just changed to use Inspircd last year. It's cool!
Logged
Pages: [1]   Go Up